Question / Help NDI Source black on receiving OBS


New Member
Hello people,

I've just revived my old Laptop, installed Windows 10, an SSD etc. Basically I got it up to speed and thought: Hey, I could use this as a dedicated encoding device to relieve my gaming PC.

Now, almost everything is working as it should. My PC is sending the correct output via NDI, the Laptop definitely receives the signal as it shows up in the NDIAnalyze tool and I can even preview it in the NDIStudioMonitor. The quality is perfect, it doesn't lag and sound is transmitted as well.

Now if I try to get this Stream into OBS it's just black. I know this has been posted many times before here, as well as on GitHub, but I simply can't figure out whats wrong with my setup. At this point I'm out of answers.

I've tried so far to:
  • Disable Windows Firewall on both devices
  • Manually open the ports for NDI as described in the manual that comes with the NDIAnalyze tool
  • Reinstall the newest NDI Runtime on both systems
  • Reinstall OBS (with clearing user data by hand) on both systems
  • Reset everything back to default settings
  • Troubleshooting myself with the OBS Log (which doesn't seem to spit out anything bad)
  • Disable all Network Adapters but the ones that actually connect via LAN
As I said, with the NDIStudioMonitor my Laptop can display the stream no problem, but OBS fails to do so.

Is there anything else I can try? Did I miss something? I doubt it's going to help but you can find the LOG HERE

Thanks in Advance!


New Member
Oh my god, of course the moment I post on the forum I figure it out! The tutorial I saw involved manually TYPING the Source name into the Source Name field... turns out there is a dropdown menu and the Syntax for the Source Name is NOT the same as in this older Tutorial. I named the stream on my Gaming PC just "Stream" and naturally typed that into the NDI Source on my Laptop.

Turns, but using the dropdown that I COMPLETELY overlooked for HOURS reveals that the correct syntax would have been:
Instead I just typed:
Now it's working perfectly... man I feel stupid now.

Anyways, I hope that this at least helps somebody at some point...