NDI HX iOS App only showing audio / NO VIDEO (Mac Pro late 2013)

Mr. Smiley

New Member
Hi OBS users,

Recently had this issue with OBS and NDI HX iOS app on Mac OS 10.15 Catalina. I've checked this in a MacBook Pro 2018 and worked perfectly. But in my Mac Pro late 2013 used to work correctly and now it isn't. Somebody has this same issue. I update all drivers, also a did a clean installation of Mac OS thinking it could be a cache problem, but didn't solved it I have no ways to try in mind.
I checked the NDI signal with NDI Video monitor on the same computer and it works perfectly (screen capture 1). I attach some screen captures if they help.
The strange thing is that the NDI signal is detected by OBS but when it comes to OBS only audio is outputted. (screen capture 4)

Thanks in advance!
 

Attachments

  • Captura de pantalla 2021-02-12 a las 7.26.15.png
    Captura de pantalla 2021-02-12 a las 7.26.15.png
    632.4 KB · Views: 24
  • Captura de pantalla 2021-02-12 a las 7.26.28.png
    Captura de pantalla 2021-02-12 a las 7.26.28.png
    227 KB · Views: 23
  • Captura de pantalla 2021-02-12 a las 7.26.37.png
    Captura de pantalla 2021-02-12 a las 7.26.37.png
    212.7 KB · Views: 22
  • Captura de pantalla 2021-02-12 a las 7.26.46.png
    Captura de pantalla 2021-02-12 a las 7.26.46.png
    202.6 KB · Views: 22

Lawrence_SoCal

Active Member
a 2013 computer is more than a bit old for the demands of real-time video encoding. possible, but on with care and reduced expectations

Is your hardware utilization (CPU, RAM, GPU, disk) getting maxed out?
and you aren't using WiFi are you?
 

Mr. Smiley

New Member
Lawrence, thanks for your reply. The computer is not the problem or the specs. A 12 core Xeon, 64gb of ram, 4gb of graphics card and a external egpu with 8gb must be enough. I’ve run several times this setup. The thing of using the ndi hx iOS app is to have no wires, also I’ve run this setup through a cellular connection.
The computer cpu is 3,4% as you can see in the screenshots.
 

Lawrence_SoCal

Active Member
Sorry, haven't played with NDI that much (my Panasonic PTZ NDI PoE camera has its own Virtual USB driver, precluding need to deal with NDI directly). But I know I log onto NDI camera itself, in my case, to set up stream settings (fps, etc)

Wouldn't the default NDI stream settings be on the sending (iOS) device itself? [yes, I would expect an NDI receiver to be like other protocols and be able to request a different setting, but a typical setup is for the receiver to accept sender settings, unless specific reason not to. And that wouldn't be a default,

so, maybe someone can tell you have to configure to the NDI receiver to request/insist on HX stream? or figure out the settings on the sender to switch to HX?
 

calvinius

New Member
Hi OBS users,

Recently had this issue with OBS and NDI HX iOS app on Mac OS 10.15 Catalina. I've checked this in a MacBook Pro 2018 and worked perfectly. But in my Mac Pro late 2013 used to work correctly and now it isn't. Somebody has this same issue. I update all drivers, also a did a clean installation of Mac OS thinking it could be a cache problem, but didn't solved it I have no ways to try in mind.
I checked the NDI signal with NDI Video monitor on the same computer and it works perfectly (screen capture 1). I attach some screen captures if they help.
The strange thing is that the NDI signal is detected by OBS but when it comes to OBS only audio is outputted. (screen capture 4)

Thanks in advance!
Hey Mr Smiley,

Are you still having this same issue or did you figure out a solve? I am running in to this very same issue with similar specs on my Mac Pro..

Any help is appreciated!
 
Top