Mouse not displaying when using OBS with fullscreen minecraft.

Other

New Member
So I have an issue: when OBS is running at the same time as minecraft is, I can't see my mouse while i.e in my inventory (in minecraft) when I'm in fullscreen in minecraft. I know that was extremely hard to understand, here is a simplification: I have OBS running. I open minecraft, and put it in fullscreen. I now can't see my mouse (not my cursor, my *mouse*) when I open i.e my inventory (in minecraft). When I'm not running OBS and playing minecraft in fullscreen, my mouse is there when I need it but then as soon as I open obs, gone.
OBS does seem to capture my mouse tho since when I watch back recordings made during this glitch do show my mouse. This is just irritating since it's very hard to play minecraft without seeing your mouse.

Things I've already tried: Running OBS as an administrator, restarting computer, unplugging and re-plugging mouse, updates mouse driver, unchecked and re-checked capture mouse on my game capture, scowering youtube, the OBS forums, the minecraft forums for answers. All these things I have done without success. (disabling pointer trails and all those things didn't work either)



I would have attached a video with proof but apparently this forum doesn't allow that :(

Please help if you've maybe had the same issue or know a fix for the issue! :D







Log file:
23:23:47.135: CoInitializeEx succeeded: 0x00000001
23:23:47.135: CPU Name: Intel(R) Core(TM) i5-3330 CPU @ 3.00GHz
23:23:47.135: CPU Speed: 2993MHz
23:23:47.135: Physical Cores: 4, Logical Cores: 4
23:23:47.135: Physical Memory: 16313MB Total, 8303MB Free
23:23:47.135: Windows Version: 10.0 Build 18362 (release: 1903; revision: 900; 64-bit)
23:23:47.135: Running as administrator: true
23:23:47.136: Aero is Enabled (Aero is always on for windows 8 and above)
23:23:47.136: Windows 10 Gaming Features:
23:23:47.136: Game DVR: On
23:23:47.138: Sec. Software Status:
23:23:47.141: Norton Internet Security: disabled (AV)
23:23:47.198: Windows Defender Antivirus: enabled (AV)
23:23:47.199: Norton Internet Security: disabled (FW)
23:23:47.199: Windows-brandväggen: enabled (FW)
23:23:47.199: Current Date/Time: 2020-06-25, 23:23:47
23:23:47.199: Browser Hardware Acceleration: true
23:23:47.199: Portable mode: false
23:23:47.692: OBS 25.0.8 (64-bit, windows)
23:23:47.692: ---------------------------------
23:23:47.693: ---------------------------------
23:23:47.693: audio settings reset:
23:23:47.693: samples per sec: 44100
23:23:47.693: speakers: 2
23:23:47.696: ---------------------------------
23:23:47.696: Initializing D3D11...
23:23:47.696: Available Video Adapters:
23:23:47.699: Adapter 0: AMD Radeon HD 7700 Series
23:23:47.699: Dedicated VRAM: 1052860416
23:23:47.699: Shared VRAM: 4258174976
23:23:47.699: PCI ID: 1002:683f
23:23:47.700: Driver Version: 26.20.12028.2
23:23:47.700: output 0: pos={0, 0}, size={1600, 900}, attached=true, refresh=60, name=VH203
23:23:47.704: Loading up D3D11 on adapter AMD Radeon HD 7700 Series (0)
23:23:47.794: D3D11 loaded successfully, feature level used: b000
23:23:47.794: DXGI increase maximum frame latency success
23:23:47.794: D3D11 GPU priority setup success
23:23:48.542: ---------------------------------
23:23:48.542: video settings reset:
23:23:48.542: base resolution: 1600x900
23:23:48.542: output resolution: 1064x600
23:23:48.542: downscale filter: Bicubic
23:23:48.542: fps: 60/1
23:23:48.542: format: NV12
23:23:48.542: YUV mode: 601/Partial
23:23:48.542: NV12 texture support enabled
23:23:48.545: Audio monitoring device:
23:23:48.545: name: Default
23:23:48.545: id: default
23:23:48.545: ---------------------------------
23:23:48.556: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
23:23:48.558: Failed to load 'en-US' text for module: 'decklink-ouput-ui.dll'
23:23:48.722: [AMF] The detected AMF runtime is too old, please update your drivers.
23:23:48.722: [AMF] AMF Runtime is outdated.
23:23:48.777: [AMF] AMF Test failed due to one or more errors.
23:23:48.777: Failed to initialize module 'enc-amf.dll'
23:23:49.516: [obs-browser]: Version 2.8.6
23:23:50.133: Couldn't find VLC installation, VLC video source disabled
23:23:50.602: A DeckLink iterator could not be created. The DeckLink drivers may not be installed
23:23:50.604: No blackmagic support
23:23:50.626: ---------------------------------
23:23:50.626: Loaded Modules:
23:23:50.626: win-wasapi.dll
23:23:50.626: win-mf.dll
23:23:50.626: win-dshow.dll
23:23:50.626: win-decklink.dll
23:23:50.626: win-capture.dll
23:23:50.626: vlc-video.dll
23:23:50.626: text-freetype2.dll
23:23:50.626: rtmp-services.dll
23:23:50.626: obs-x264.dll
23:23:50.626: obs-vst.dll
23:23:50.626: obs-transitions.dll
23:23:50.626: obs-text.dll
23:23:50.626: obs-qsv11.dll
23:23:50.626: obs-outputs.dll
23:23:50.626: obs-filters.dll
23:23:50.626: obs-ffmpeg.dll
23:23:50.626: obs-browser.dll
23:23:50.626: image-source.dll
23:23:50.626: frontend-tools.dll
23:23:50.626: enc-amf.dll
23:23:50.626: decklink-ouput-ui.dll
23:23:50.626: coreaudio-encoder.dll
23:23:50.626: ---------------------------------
23:23:50.626: ==== Startup complete ===============================================
23:23:50.627: Service '' not found
23:23:50.661: All scene data cleared
23:23:50.661: ------------------------------------------------
23:23:50.798: WASAPI: Device 'Speakers (USB PnP Sound Device)' [48000 Hz] initialized
23:23:50.798: [Loaded global audio device]: 'Skrivbordsljud'
23:23:50.863: WASAPI: Device 'Microphone (USB PnP Sound Device)' [44100 Hz] initialized
23:23:50.863: [Loaded global audio device]: 'Mic/Aux'
23:23:50.865: [window-capture: 'Fönsterkälla'] update settings:
23:23:50.865: executable: chrome.exe
23:23:50.918: adding 46 milliseconds of audio buffering, total audio buffering is now 46 milliseconds (source: Mic/Aux)
23:23:50.918:
23:23:51.825: Switched to scene 'Scen'
23:23:51.826: ------------------------------------------------
23:23:51.826: Loaded scenes:
23:23:51.826: - scene 'Scen':
23:23:51.827: - source: 'Display Capture' (monitor_capture)
23:23:51.827: - source: 'Fönsterkälla' (window_capture)
23:23:51.827: - source: 'Game Capture' (game_capture)
23:23:51.827: ------------------------------------------------
23:34:12.823: Starting recording due to hotkey
23:34:12.826: ---------------------------------
23:34:12.826: [x264 encoder: 'simple_h264_recording'] preset: veryfast
23:34:12.826: [x264 encoder: 'simple_h264_recording'] profile: high
23:34:12.826: [x264 encoder: 'simple_h264_recording'] settings:
23:34:12.826: rate_control: CRF
23:34:12.826: bitrate: 0
23:34:12.826: buffer size: 0
23:34:12.826: crf: 20
23:34:12.826: fps_num: 60
23:34:12.826: fps_den: 1
23:34:12.826: width: 1064
23:34:12.826: height: 600
23:34:12.826: keyint: 250
23:34:12.826:
23:34:12.829: ---------------------------------
23:34:12.829: [FFmpeg aac encoder: 'simple_aac_recording'] bitrate: 192, channels: 2, channel_layout: 3
23:34:12.829:
23:34:12.877: ==== Recording Start ===============================================
23:34:12.877: [ffmpeg muxer: 'simple_file_output'] Writing file 'C:/Users/Beavis And Butthead/Videos/2020-06-25 23-34-12.mp4'...
23:34:27.795: [game-capture: 'Game Capture'] attempting to hook fullscreen process: javaw.exe
23:34:27.801: [game-capture: 'Game Capture'] using helper (compatibility hook)
23:34:27.834: [game-capture: 'Game Capture'] hook not loaded yet, retrying..
23:34:30.812: [game-capture: 'Game Capture'] attempting to hook fullscreen process: javaw.exe
23:34:30.927: [game-capture: 'Game Capture'] gl shared texture capture successful
23:34:30.928: [game-capture: 'Game Capture'] shared texture capture successful
23:34:31.789: Stopping recording due to hotkey
23:34:32.204: [ffmpeg muxer: 'simple_file_output'] Output of file 'C:/Users/Beavis And Butthead/Videos/2020-06-25 23-34-12.mp4' stopped
23:34:32.204: Output 'simple_file_output': stopping
23:34:32.204: Output 'simple_file_output': Total frames output: 1136
23:34:32.204: Output 'simple_file_output': Total drawn frames: 1152 (1160 attempted)
23:34:32.204: Output 'simple_file_output': Number of lagged frames due to rendering lag/stalls: 8 (0.7%)
23:34:32.204: ==== Recording Stop ================================================
23:34:34.926: [game-capture: 'Game Capture'] Hooked DXGI
23:34:47.093: [game-capture: 'Game Capture'] ------------------ gl capture freed ------------------
23:34:47.116: [game-capture: 'Game Capture'] gl shared texture capture successful
23:34:47.144: [game-capture: 'Game Capture'] shared texture capture successful
 

Attachments

  • Anteckning 2020-06-25 234837.png
    Anteckning 2020-06-25 234837.png
    1.9 KB · Views: 134
Or, you can do game capture, and don't do full screen, and also trim the taskbar at the bottom of your screen by doing Alt+ dragging the red dot on the sides of the preview
 

AtlasTheProto

New Member
Hi, I was also having the same issue (albeit with Streamlabs OBS)

What ended up being the problem in my case, was my simultaneous window capture of Spotify. Having that active at any time caused my mouse to stop rendering in minecraft, in fullscreen. (Yet it would still show up in the preview window in OBS)

Thought I would bump this thread with my information incase anyone else finds themselves having a similar issue.
 

catbong

New Member
Hi, I was also having the same issue (albeit with Streamlabs OBS)

What ended up being the problem in my case, was my simultaneous window capture of Spotify. Having that active at any time caused my mouse to stop rendering in minecraft, in fullscreen. (Yet it would still show up in the preview window in OBS)

Thought I would bump this thread with my information incase anyone else finds themselves having a similar issue.
i love you
 

ShadowKlassic

New Member
Actually, for regular/standard OBS, you can change the capture method. For me, Bitblt worked and fixed my crosshair problems. Windows 10 1903 seemed to be the problem for minecraft specifically. Everything else it worked fine.
1639117964205.png
 

Soft Pawbs

New Member
Hi, I was also having the same issue (albeit with Streamlabs OBS)

What ended up being the problem in my case, was my simultaneous window capture of Spotify. Having that active at any time caused my mouse to stop rendering in minecraft, in fullscreen. (Yet it would still show up in the preview window in OBS)

Thought I would bump this thread with my information incase anyone else finds themselves having a similar issue.
Yeah, I have a PNG Tuber so I NEED to capture another Window. But I hate playing Minecraft in windowed mode so much and I ain't going to stream without my png tuber
 

Gr1mmGuts

New Member
Helloo !! I have a fix that has worked for me and I'm hoping to help,
(I have tried everything from going thru OBS settings to going deep into the pc settings)

Instead of using a "window capture", use a "game capture" and make sure that the "display capture" has the line through the eye (not being shown) or you have removed it completely. As long as you don't use a "display capture" you should be able to use your PNG Tuber and etc and be able to see your cursor.

If you need a visual idea or something to compare yours to I have attached what mine looks like.
 

Attachments

  • blhhh.JPG
    blhhh.JPG
    14.8 KB · Views: 77

comp69

New Member
Hey so i had this same issue with minecraft and a solution i found is that u disable all other screen captures other than u use
i use game capture so i disable display and window capture
1666875769171.png
 

zparison

New Member
I still have the same issue; I want to use a facecam as well as having minecraft on screen, so I can't get rid of either. Any ideas?
 
Top