Macro Deck

Free Macro Deck 1.2.5 Beta

#21
The "Play Sound" under "Soundbar" command isn't working, I've tried with "play_stop", "play _overlap" and "play_replay" and chosen my file but none are working
can you check the macro and see if it's storing a file path "C:\this\is\the\path" or just the file name because I'm having the same issue and the path just says "clip.mp3" or something like that
 
#22
I've been looking at one of the 'competitor products', and ran across this in another forum.

I have 2 issues.

1) when i start up the Macro Deck Server application, it generates an error:
Code:
Failed to check for updates.  Please make sure you have an internet connection and your filewall/anti virus isn't blocking Macro Deck Server.exe and Macro Deck Server Installer.exe
(it should be noted, that there is no "Macro Deck Server Installer" anywhere on my machine.)

When the error is generated on startup, a network scan (using fiddler) seems to indicate that it's trying to access a resource located at, with a 301 permanent redirect response in place:
Code:
http://macrodeck.org/services/installer/versions/version_release.ini
But when I try to access this resource via a browser, it gives me a 403 Access Denied.
When I try to use a tool like Insomnia, it give me an error that reads
Code:
Error: Peer certificate cannot be authenticated with given CA certificates
I can only presume that the 301 redirect is from HTTP to HTTPS, but the requested resource is inaccessible via HTTPS.


2) even with the firewall opened "wide open" for this application (public, domain and private, which is far more permissions that I want any application to have), I cannot connect from my android device.

Using a port scanner, I can see that port 50000 (as defined statically in the Macro Deck Server settings page) is open, and is currently being held by Macro Deck Server (and not something else).

I can connect to the open port using a local telnet tool from my windows machine (puTTY) and get a response that the port is open. I can also do the same from my android phone using ConnectBot.

But still, the MacroDeck app will not connect.
 
#23
can you check the macro and see if it's storing a file path "C:\this\is\the\path" or just the file name because I'm having the same issue and the path just says "clip.mp3" or something like that
When I first add the file it shows "C:\path\to\file.mp3". After applying it and going to Right Click>Edit it just shows "file.mp3"
 
#24
View attachment 46985
I keep getting this even after reinstalling and sorting out the firewall
I installed Macro Deck 1.3.1 yesterday, and it worked just fine. However, today morning when I started my PC, I got these same errors and was unable to use Macro Deck. I went through Google and found no solutions, and I can't remove other adb related apps to test the solution provided on this thread. Also, the developer of Macro Deck doesn't seem to offer any kind of support, even for donators.

I noticed that Macro Deck uses fairly old version of .Net Framework, but in Win10 I can't install older one if I already have newer version. And I surely need that newer version for other stuff.

Luckily I found a solution for that "Failed to bind to port"-error, which is more crucial as it kills the app on startup:
1. Go to Control Panel > Programs > Programs and Features
2. On the left sidebar, click "Turn Windows features on or off"
3. Expand ".NET Framework 4.8 Advanced Services" (or some other version you have there)
4. Expand "WCF Services", activate "HTTP Activation" and click OK.


I'm not sure if it's disabled as default in all Win10 versions, but in my case it was the solution. Posting this here as this was one of the only topics about this issue that I found from Google.

Edit: This morning same thing happens again, so clearly this wasn't the solution. I'll try to track down what everything I did yesterday in order to get it working.

Edit2: It takes 30-40mins from the startup of my computer before Macro Deck Server works. After that delay it finds the IP correctly and doesn't give "Failed to bind to port" error anymore.
 
Last edited:
#25
I have a problem with Macro deck server, when I have been with my Android connected by Wifi for a while, my PC desktop application goes into sleep mode and loses the connection. I have to restart the desktop application and resynchronize the Android. I recently reinstalled Windows for other reasons and the same thing still happens to me. Any solution?
 
#26
It keeps crashing and there's no instructions on how to set it up, I'm trying to get it setup with SLOBs so I can control Spotify while using it, it also doesn't like my twitter PIN either because it likes to crash - every.single.time. I input it.

I really wanna use this because a friend recommended it over SLOBs remote control but I can't if it won't let me set anything up (or I don't know how to).
 
Top