Mac big sur 11.2.3 audio capture for livestreaming

Sml13

New Member
Hi, I recently switched to macbook pro running on big sur 11.2.3, obs version 26.1. I've been trying to livestream and noticed the desktop audio is not captured. I've followed other threads on the forum and tried out ishowu, blackhole, eqmac, background music for mac, and literally every suggestion for external apps. I've followed youtube video tutorials and gone down reddit rabbit holes. But nothing has worked!! I'm not new to streaming, I've used obs for 3 years now on windows but needed a second device for a simultaneous stream and my only option is this mac. But I can't get the desktop audio to be captured. I'm at my wits end, so if there is any software that I can download or any tips to make this work, please lmk.
 

BennMusicTech

New Member
I'm relatively new myself, but I believe this is dealt with in Settings-Audio
Screen Shot 2021-03-24 at 2.27.39 PM.png

I think your Mic/Auxiliary Audio needs to be set to one of the other selections, Depending on what's on your computer and how you are hearing audio. Good Luck.
 

AethersHill

New Member
I use blackhole on my M1 MacBook Air and it works just fine.
Did you:
  • Go into Audio Midi Setup
  • Create Multi-Output Device
  • Set Macbook Speakers as master device
  • Add on any other devices you want to hear audio from (for your headphones)
  • Go into Sound Settings and set Multi-Output Device as your output devince
  • Go into OBS Audio settings
  • Set Desktop Audio to Blackhole.

For reference I'm including screenshots of what my settings look like
 

Attachments

  • Screen Shot 2021-03-25 at 1.14.11 AM.png
    Screen Shot 2021-03-25 at 1.14.11 AM.png
    82.6 KB · Views: 14,679
  • Screen Shot 2021-03-25 at 1.14.22 AM.png
    Screen Shot 2021-03-25 at 1.14.22 AM.png
    613.2 KB · Views: 14,770
  • Screen Shot 2021-03-25 at 1.14.25 AM.png
    Screen Shot 2021-03-25 at 1.14.25 AM.png
    235.5 KB · Views: 13,167

nikosV

New Member
I have exactly the same problem!!!
Desktop audio is not captured (no lights on OBS Audio Mixer)
I use MacBook Pro (early 2015) running on Big Sur 11.2.3, OBS version 26.1.2
I spent many many hours trying all possible settings, according tutorials and blogs...
The craziest thing is that two nights ago, around 3am, I managed to see lights on OBS audio mixer! I also did a test Facebook live streaming for a few minutes...
However, I was so tired that I decided to close the laptop (without changing my settings of course) and continue the next day...
Guess what? Next day (yesterday) was not working!
I am very persistent and try again and again but nothing...
Please help!
 

coreync

New Member
I was able to get it working on a m1 macbook air following AethersHill's instructions above... but had to install both the 2ch and 16ch blackhole and add them to the multii-output for it to work.
 

OBS User 7657

New Member
I just downloaded OBS and I have 11.2.3 Big Sur. When I started to just try to figure out how I'm going to record videos, I found that the Audio Output Capture didn't have any audio going through it and when I tried testing it by playing a youtube video, it didn't show any signs of audio from the desktop.
 

OBS User 7657

New Member
I just downloaded OBS and I have 11.2.3 Big Sur. When I started to just try to figure out how I'm going to record videos, I found that the Audio Output Capture didn't have any audio going through it and when I tried testing it by playing a youtube video, it didn't show any signs of audio from the desktop.
My computer is just a regular mac and I just need to know how to fix the output audio thing. Not complicated and I'd appreciate some answers.
 

joeyqvg

New Member
I use blackhole on my M1 MacBook Air and it works just fine.
Did you:
  • Go into Audio Midi Setup
  • Create Multi-Output Device
  • Set Macbook Speakers as master device
  • Add on any other devices you want to hear audio from (for your headphones)
  • Go into Sound Settings and set Multi-Output Device as your output devince
  • Go into OBS Audio settings
  • Set Desktop Audio to Blackhole.

For reference I'm including screenshots of what my settings look like
How do you create a Multi-Output Device. is it in OBS or on MacOS
 

shasnan

New Member
I'm following what you're saying, but for me, when I went into MIDI to add the multi-output device, my MacBook Pro speakers are not an option for the master device. Only built-in-output and black hole. When I did built-in-output I was getting no audio. Does anybody know what's up?
 

shasnan

New Member
I'm following what you're saying, but for me, when I went into MIDI to add the multi-output device, my MacBook Pro speakers are not an option for the master device. Only built-in-output and black hole. When I did built-in-output I was getting no audio. Does anybody know what's up?
It works now. No idea what was wrong.
 

EnzoCast

Member
I've got both the audio selected in the settings and added it as Audio Input Capture. I'm getting a signal on the faders but no audio on the stream. I don't really want to have to use BlackHole, is this really the only solution?
 

Attachments

  • Screenshot 2021-04-29 at 18.38.45.png
    Screenshot 2021-04-29 at 18.38.45.png
    87.5 KB · Views: 1,479
  • Screenshot 2021-04-29 at 18.34.21.png
    Screenshot 2021-04-29 at 18.34.21.png
    88.6 KB · Views: 1,469

Ami_pancakes

New Member
I use blackhole on my M1 MacBook Air and it works just fine.
Did you:
  • Go into Audio Midi Setup
  • Create Multi-Output Device
  • Set Macbook Speakers as master device
  • Add on any other devices you want to hear audio from (for your headphones)
  • Go into Sound Settings and set Multi-Output Device as your output devince
  • Go into OBS Audio settings
  • Set Desktop Audio to Blackhole.

For reference I'm including screenshots of what my settings look like

Hi there! This was super helpful and it works perfectly fine in my OBS, however I have an issue where the audio is coming through my desktop speakers as well as going through to my headphones, do you know how I can fix this? (This seriously saved me! Thank you!!!)
 

A Johnston

New Member
Any chance this is as simple as go to your Mac settings > Security and Privacy, find Microphone, and then tick to allow OBS access to your mic? I did this and it worked. No complicated downloading of Blackhole, etc. It has worked for my built-in mic, though it's not showing an external mic which I have attached. So, still need to troubleshoot that part.
 

stevecarty

New Member
hey all.. I have my desktop audio working in my obs for computer sounds / discord and playing music. I'm wondering if there is a way to have music / computer sounds coming in on separate obs channels so I can include desktop audio in my vods / live streams but not include music in my vods, but include my discord chat or any other desktop audio / YouTube videos I want to share.. I have all audio coming in to my obs on one channel. if it's coming through my comp, I get it but it's all through one pipe.. any solutions?
 

Lowluh

New Member
I use blackhole on my M1 MacBook Air and it works just fine.
Did you:
  • Go into Audio Midi Setup
  • Create Multi-Output Device
  • Set Macbook Speakers as master device
  • Add on any other devices you want to hear audio from (for your headphones)
  • Go into Sound Settings and set Multi-Output Device as your output devince
  • Go into OBS Audio settings
  • Set Desktop Audio to Blackhole.

For reference I'm including screenshots of what my settings look like
Hello, what if I have no "macbook pro speakers" as an option for master device =( these are the only options. I cant even change the Master Device. Or is the "Built in Output" the same thing? Sorry, im such a noob
 

Attachments

  • Screen Shot 2022-02-09 at 7.17.30 PM.png
    Screen Shot 2022-02-09 at 7.17.30 PM.png
    168.1 KB · Views: 294

Lowluh

New Member
Hello, what if I have no "macbook pro speakers" as an option for master device =( these are the only options. I cant even change the Master Device. Or is the "Built in Output" the same thing? Sorry, im such a noob
ok I went ahead with picking Built in Output and it works, at least all audio are being detected by OBS (desktop, mic via dongle headphones, and I can hear the audio on my headphones) But now my issue is the audio comes out on both my laptop speakers and headphones, obviously because built in speakers is selected. but i want everything to just come out via my headphones of course. do i just unselect built in output? how to fix this? =)
 

theecryptiid

New Member
ok I went ahead with picking Built in Output and it works, at least all audio are being detected by OBS (desktop, mic via dongle headphones, and I can hear the audio on my headphones) But now my issue is the audio comes out on both my laptop speakers and headphones, obviously because built in speakers is selected. but i want everything to just come out via my headphones of course. do i just unselect built in output? how to fix this? =)
Hopefully you've figured this out, but if you haven't I found this tutorial very helpful! It doesn't use the MacBook speakers at all, and fixes the problem entirely. Hope this helps!
Macbook OBS Audio Fix
 

Trubador

New Member
I wanted to post this because I was having the same problems. I wasn't getting any audio at all after creating the multi-output device using Blackhole and my main speakers. I have an audio mixer connected to my computer and was also selecting the Mac speakers in the multi output device but still not getting any audio at all. But I realized the order in which you select the devices matters. I unchecked all of the devices and then selected the Mac speakers first so they went up to the top of the list and audio started coming through them. Then I just checked the Blackhole box and the box for my audio mixer and they all came alive. I used system preferences > Sound to turn the Mac speakers down all the way so that the sound is coming from only my Audio mixer and Studio monitors and Blackhole is sending it to OBS. I was looking at AethersHill's response / checklist and realized I didn't really put too much stock into making the Mac Speakers the Master Device as its never mattered before and I've always used my studio monitors and mixer for listening so they were never selected anyways. But now all 3 of them are selected. So if you're still having the problem where you're getting no audio and everything seems to be set up properly, maker sure you go into Audio-Midi and redo the checklist starting with your Mac / built-in speakers. That'll make them the master source and bring them to the top of the list which form some reason is a crucial element to this working. And if you also use an interface and studio monitors for listening, you can just turn the built-in speakers down using system preferences so that you're not hearing two sets of speakers. It's weird to me that the built in speakers have to be the master even when you have a whole separate audio interface set-up in there. But whatever. Im just glad I finally got this to work on this machine.
 
Top