M1 Mac Mini - Video distortion in recordings & streaming

lyrictech

New Member
New to the forums, but been using OBS for about 1 year now for livestream:

We just split our livestream to a dedicated M1 Mac mini - Maxed out RAM to 16 gb - 1TB ssd.

The issues I'm seeing is artifacts/glitches in the video at first I thought it had something to do with just the monitors we were using - I repurposed some old Insigina's I had laying around. I am using a 2nd monitor off an apple usb-C to HDMI converter on the 2nd monitor, but the glitches are being recorded and also streamed so it appears it's inside of OBS. I've seen a thread somewhere about video issues but it seemed to be tied to the graphics card and users experiencing issues with glitches on their screens, not necessarily streaming which Is my main concern. Not sure if anyone else is experiencing this.

I've also had issues where OBS will crash or become unresponsive we have a feeling it has to do with DanteVia drivers and software since we use that to pipe audio so not too worried about that right now because they are supposed to release an update before the end of the month.

Would be great if we split the Mac threads between Intel and M1 since this will probably be how things will look for quite a while on the Mac landscape
 

lyrictech

New Member
Here are some images of the issue. FYI we are receiving an NDI stream from a 2019 iMac that has Propresenter on it (Intel i7 running Big Sur) Camera is a PTZOptics 30x NDI/HX - we were running it simultaneously on the iMac before getting the M1 Mac mini, so it doesn't appear to be an issue with the OS or Mac in general just the M1
 

Attachments

  • Screen Shot 2021-04-18 at 10.28.32 AM.png
    Screen Shot 2021-04-18 at 10.28.32 AM.png
    556.5 KB · Views: 199
  • Screen Shot 2021-04-18 at 10.59.17 AM.png
    Screen Shot 2021-04-18 at 10.59.17 AM.png
    821.1 KB · Views: 195

Producer Paul

New Member
Here are some images of the issue. FYI we are receiving an NDI stream from a 2019 iMac that has Propresenter on it (Intel i7 running Big Sur) Camera is a PTZOptics 30x NDI/HX - we were running it simultaneously on the iMac before getting the M1 Mac mini, so it doesn't appear to be an issue with the OS or Mac in general just the M1

I am having issues with the M1 aswell , what can I do to resolve it?
 
Top