Resource icon

Instant Replay 1.1.0

sedris

New Member
Thank you for your answer.
As I understand the replay should show me 10 second back ( with my settings) from the moment of pressing a button.
instant.jpg
Meanwhile It shows me video from 15th to 5th second of the buffer, when 0 is time of pressing the button.
Do you have any idea how to make it work correctly? In my case it's important, I need to show exact moment of scoring a point on a replay.
 
Ah, this may be me being bad at explaining how this works.

This plugin doesn't actually do the replay buffer side of things, that's dealt with by the default OBS replay buffer. What this plugin does is the following:

Your button/hotkey is pressed (it should be the same as the one you use to save replays if you don't have the plugin enabled)
Nothing happens for "Write Pause" time.
The scene is switched to "Replay Scene". The desktop and mic are muted if the option is selected.
After "Replay length" - "Transition Pause" the scene is switched back to the original scene. The desktop and mic are unmuted if the option is selected.

Note, it never triggers the replay to be saved.

You have to set up the replay as you would normally. I can't remember exactly where it is (and I'm not at my PC to check) but it should be something like "Output - Recording". Possibly an "advanced" in there somewhere.

Hopefully that explains it better. If that wasn't your problem then I will have to think some more.

As to why it's saving the replay from after when you press the button, I have no idea. Perhaps you could post a screenshot of OBS when it's recording/streaming the way you have it when you are trying to do the instant replays (the main window and the replay buffer options window). Maybe that will show something.
 

sedris

New Member
Hopefully this will show you what I mean.

https://we.tl/BCsXM69pW1
There are six files in the link attached. Marked - 9, 10, 12, 13, 14, 16 seconds.

In each case, to save the replay, I pressed the key (in my case F4) at the moment when the seconds hand was at 12 o'clock.

In each case, however, the replay showed a different fragment of time back (see it in the videos). In my opinion, according to my settings, the replay should show 10 seconds back, and it was only in two cases (9_sec and 10_sec videos)

Is it possible to set it up so that the replay works the same way every time? So it showed the same number of seconds back from the moment of pressing the key? (for me F4)

I am also attaching my settings. Thank you for your help.

cleardot.gif
instant(1).jpg
hotkeys.jpg
 
The plugin looks like it's doing what it is supposed to do and what you have it set up to do. As I said, it is not in control of the replay buffer, it just switches scenes. There is nothing I can do on my end to make sure the replay saves the same amount of time each time.

The only thing I can think of is how long you have the replay set to save. Is it set to 10sec under Settings -> Output -> Replay Buffer ?
 

The Scro MX

New Member
Hello, I contact you because I currently have a problem.

I had installed the Front Plugin. But I had to reinstall my Computer due to a problem with the System.

Except that when I reinstall the plugin in Obs. In the Tools Sections, I'm no longer the Replay Window.

I am currently on the latest versions of OBS and I download the Plugin via the OBS site.

I did a Copy paste folder.

I rebooted the computer.

But nothing to make the window in OBS that its 32 or 64 bits did not apap.

what to do please because this is a major part of my stream.
 
Hello, I contact you because I currently have a problem.
...
what to do please because this is a major part of my stream.

It sounds like you have the .dlls in the wrong folder.
Do you have a log file (don't need a stream or recording attempt)? It will show if the .dlls are in the right place.
 
Thanks. OBS is finding a .dll in the right place but it's not loading it. I'm not entirely sure why.

You could try re-downloading the plugin in case the download was an issue (but I doubt it).
There are some run time things that may be causing it (after a very quick google). You may need to install the MSVC 2015 redistributable: https://www.microsoft.com/en-us/download/details.aspx?id=48145

I'll have a better look tomorrow evening if one of these doesn't work.
 

Quenaros

New Member
I don't get how to catch the correct videofile. In the Media Source I have to specify the videofile I want to play. But every time I save the replay Buffer it is a generated file name with Date and Timestamp.

So it is no fire and forget solution for me. I have to change the video file in the media source first. How do you guys handle this problem?
 
You need to remove all the time dependent stuff from the name of the recording like it says in the OP:

Setting up the replay source:
Set your Recording to a constant name (so remove all the % stuff). Makes it easy to point your replay source to a file that will exist. Point your Media Source to what your replay will be saved as.
 
Started playing with this, and it's great.
Set the replay buffer to 10 seconds, set the delay to 3, and then changed the media play speed to 60%.
After that I just added a small intro vid to cover up the occasional beginning buffer glitch that this seems to have, and set the replay time in the plugin to 14 which also cuts a bit off the end.
Have it set to Close source file when inactive and Restart playback when source becomes active
Here's a small demo vid I made using the feature
https://youtu.be/u_bqgrydVXg
 

RandomVillain

New Member
Do you have to stop and start recording between replays? I game stream for hours on end and never know when I need a replay so I just set it to record and it will replay the first one but if I try to do another replay later it just shows the same one from before.
 
Do you have to stop and start recording between replays? I game stream for hours on end and never know when I need a replay so I just set it to record and it will replay the first one but if I try to do another replay later it just shows the same one from before.
No. It should pick up the latest one. Try increasing the write pause and see if that helps.
 

kubo6472

New Member
Okay, maybe I am silly, but how to exactly set this up ? I created new scene with name replay and set up the hotkeys. The rest is unclear for me. Some media source... okay, what file to point that media source to ?
 
Okay, maybe I am silly, but how to exactly set this up ? I created new scene with name replay and set up the hotkeys. The rest is unclear for me. Some media source... okay, what file to point that media source to ?
You point it to the file made by the Replay Buffer. (Settings -> Advanced -> Recording).
For the name of the recording file, you will need to remove all the % signs or the name is not the same each time.
 

JS Creators

New Member
The plugin doesn't capture anything, it just switches scenes and mutes/unmutes audio.


It's a quality of life thing more than an added functionality thing.

With this plugin, you press one button, it saves a replay, waits for the replay file to be written, switches to a scene with the replay as a source, mutes the desktop and mic audio, plays the replay then switches back and unmutes the desktop and mic.

Without out it, you'd have to save the replay, wait for a bit, press a hotkey to switch scenes, press a hotkey to mute the desktop and mic, wait and hope you have left it long enough to show the whole replay, press a hotkey to switch scenes back and press another hotkey to unmute the desktop and mic.

So the plugin is a kind of fire and forget plugin. You hit one button and it deals with all the scenes and audio settings so you can continue playing or what ever. Without it, you have to remember to press all the hotkeys at the right time while also doing what ever you were doing.
Do u have a demo video on this? if, yes then please share
 

ded_12

New Member
Привет, отличный плагин. Можно ли сделать так, чтобы каждый повтор сохранялся в отдельном файле, чтобы потом можно было сделать отдельный ролик из интересных моментов?
 

Dreamcast88

New Member
Sorry dude, but this isn't working as expected. I attach a screenshot and text from the terminal.
 

Attachments

  • Снимок экрана от 2021-05-25.png
    Снимок экрана от 2021-05-25.png
    329.2 KB · Views: 21
  • terminal.txt
    2.1 KB · Views: 11
Top