Hotkeys disabled by Logic Pro X


New Member
Hi all,
I've been doing a weekly livestream on Patreon for a few years now. It's been fun slowly upgrading my equipment and honing my livestream chops.

I actually purchased a custom-made scene switcher with programmed hotkeys like "option+shift+F1" and option+shift+F2" to make sure I can use the "never disable hotkeys" function without interfering with other apps open. I programmed about 12 different scenes and It works amazingly well except when I have one app open: Logic Pro X

I use a hotkey to switch to a display, not an app, so I know the hotkey works just fine.

This is what happens when I use Logic Pro X:
with the app selected, if I push a a button to switch scenes I get an opaque white flash and an alert sound
the scene wont switch and I have to manually click to a new scene in obs

From there, it somehow disables my "never disable hotkeys" and I have to quit Logic Pro and restart OBS to get that functionality back.

In other words, my shortcuts work in the background beautifully until I open logic pro, and I can't switch away from Logic with a shortcut, nor do they work after they have been attempted with Logic open and selected.

------AS I was writing this, I found an ok solution but I don't like it----------

I took some obscure un-assigned shortcuts in Logic and assigned all my hotkeys to those and it made the problem go away, but it's also weird to have unnecessary shortcuts assigned in Logic just to make OBS work.

It works but there must be a better way! Anyone got any ideas?