Question / Help GPU Encoder Overload (on well equipped machine)

well I have kept researching it and even though my recordings have smoothed out and work now without the game mode on it still confuses me......
At the time of me writing this, all NVIDIA GPUs in a generation have the same NVENC chip (RTX 2060 = 2070 = 2080 = 2080ti). Have a look at this NVENC Matrix from NVIDIA:


1552030073998.png


An RTX 2080 will be overkill if you are only using the 2nd PC for streaming/recording. If you are determined to get an RTX 2080, then I would use that as your main driver and put your 1080ti in your 2nd build for dedicated streaming. You would also need a capture card (EposVox on YouTube will be an excellent resource for you to decide which capture card you want).

Alternatively, if you want to install a second GPU in your current build, YouTuber Battle(non)sense has done extensive testing into what you can expect to see when dedicating a second GPU to NVENC:


Also, I tried SLOBS last night, and my frame rates were back to normal again (even when I had dozens of chrome tabs open, researching what could be going wrong with my setup). Does anybody have any insight as to why SLOBS would be performing better than OBS (settings were imported directly from OBS)?
 
Last edited:

carlmmii

Active Member
Don't know if OP ever did this, but no one mentioned that he was using Max Quality as well, which still uses CUDA acceleration.

For rendering lag: game mode off, limit framerate in-game so that GPU isn't maxed out (so that OBS has room for rendering).
For encoding lag: Quality (not Max Quality), disable Look Ahead and Psycho Visual Tuning. This should disable any extra GPU requirements.
 
It's OBS that takes up so much resources on the gaming machine that does this. Running a scan converter without OBS on gamer to a streaming machine completely solved these issues for me. I can now play at max settings and stream/record at max settings without gimping the fps or settings.
 

NotNow

New Member
It's OBS that takes up so much resources on the gaming machine that does this. Running a scan converter without OBS on gamer to a streaming machine completely solved these issues for me. I can now play at max settings and stream/record at max settings without gimping the fps or settings.
Yeah I'm starting to think this might be the case.

This RTX new NVENC thing is a total bust. Using more cuda cores for the extra quality completely nullifies the whole point of using NVENC: the magical separate chip.

Bumping the quality settings down and limiting in game settings negates any supposed quality increase of new NVENC.

I was getting better performance using a 1050 (and old NVENC) on an dedicated 2012 built PC using ddr3 ram.
 

Maelas

Member
This is defintiely the bug where OBS is starved resources due to the game taking up all the resources. Im surprised this is still an issue honestly. However, iirc this is a bug in Win10, not OBS. The only way around this bug was to stop using obs altogether on the PCand use Scan converter or something
 

nabat

New Member
Hello guys. I have nearly the same system as TS. And have absolutely same stream lags. Any new solutions?
When i start stream, it always works fine at the start, but then after some random time (30 minutes - to 2 hours) gpu hits almost 100 percent of load. And stream became some kind of slideshow... :(
Sorry for mistakes.
 

proxypunk

New Member
I just wanted to record Resident Evil 3 Remake with my funny raged face expressions - nada!
Funny thing: When I recorded with GeForce Experience overlay everything was nice and smooth! Dawhat?!
Ok, so after I freaked out and cursed OBS for being crappy I did some intense research and the following helped me to eliminate lags on my low-spec rack (i7-2600, GTX 1060 6 GB, 16 GB RAM):
- Disable Windows Gaming shiat
- Disable VSYNC in the game
- In OBS try to switch from quality to performance!
- In OBS try to avoid rescaling the output (check recording and video settings for your desired resolution)
- In OBS switch from nevenc new to nevenc (old). This settings gave me some space already!
If you still run into this problem, run GPU-Z and watch the GPU usage. Mine was literally always 99% until i tweaked the graphics settings a bit. And don't forget two things: 1) If you set the priority for recording from quality to performance your recording quality will suffer. 2) To compense this, you may raise the bitrate (I honestly recommond this).
You will struggle, you will cry. But in the end, you will become a OBS pro - and that's what many people will desperately need in the following months since the virus outbreak. ;)
 
Top