Bug Report Game Capture crashes CoD:MW (DEV ERROR 5761)

Adrian Thompson

New Member
Call of Duty Modern Warfare (2019) runs fine until trying to create a 'Game Capture' source of the game in OBS Studio. At that point the "DEV ERROR 5761" will appear and crash the game immediately and on subsequent launch attempts.

Log file attached. Thanks for any help or insight you can provide!
 

Attachments

  • 2019-10-25 20-11-48.txt
    47 KB · Views: 1,974

Adrian Thompson

New Member
@kharoooN @Saecus I don't know if this is what solved it for me, but some steps I took:

- Reinstalled NVIDIA drivers.
- Lowered all graphics settings in CoD:MW.
- Limit in-game FPS to 120. You may want to set it lower.
- Created "Desktop Capture" in OBS Studio to see if it worked. It did.
- Created a "Game Capture" with "Capture any fullscreen application" to see if it worked. It did.
- Then finally switched to "Game Capture" with the specific window selected. It worked.
- Slowly raised up all the graphics settings and it didn't crash.
 

kharoooN

New Member
I don't know how but i guess fixed now. I updated net framework and restart pc.

**
After broadcasting for 5 hours, it's gave the same error again.
 
Last edited:

mrkt_

New Member
Yeah but by changing the fullscreen to fullscreen borderless we loss in lantency and I don't think that's great for a fps.
 

Adrian Thompson

New Member
Yeah, fullscreen borderless fixes it for me too, but there does seem to be a sacrifice in "Frames missed" and "Skipped frames" from encoding lag using that method. Oh well, better than nothing I guess!
 

kharoooN

New Member
Guys i guess i have a good news for you :D Most likely this time I've solved the problem. Close the all in-game overlays like discord, nvidia etc. When i turned off discords in game overlay, i didn't get any error. Hopefully it will be a permanent solution. Please leave your feedback here
 

Xephor

New Member
Like kharoooN said, if you have any overlays enabled like Discord, Nvidia, etc. you need to disable them to stop the crashing. This should be fixed soon.
 

MikeEbert

New Member
I was able to fix it for myself. For me the downscale filter was set to Lanczos (Sharpened scaling, 36 samples) and it works perfectly now at Bicubic 16 samples. I know the OP has his/her set to bicubic, try reducing it further and see if it fixes it for you.
 

NVIDIA_Manuel

New Member
Hello,
My name is Manuel and I work for NVIDIA. I was wondering if users experiencing problems streaming with OBS while playing Call of Duty: Modern Warfare could try an experiment and let me know if it fixes the issue.

  1. Launch Call of Duty: Modern Warfare
  2. Alt-tab back into the desktop
  3. Press Control+Alt+Del to bring up the task manager
  4. Find the Call of Duty: Modern Warfare process as shown in the attached screenshot and change it from High to Normal
    Capture.PNG
  5. Star streaming with OBS.
Please let me know if it fixes the issue or if you notice any changes. You can post a reply here or send me a DM at www.twitter.com/ManuelGuzman

Thank you.

Regards,
Manuel
 

Nayabinghi93

New Member
I have found a fix, at least it works for me. Change call of duty modern warfare executables to run as administrator, with obs do the same because it will not record the game if it hasn't admin rights as the game has. This solved the problem for me, at least, for now.
 

Bawbjohnson

New Member
Hello,
My name is Manuel and I work for NVIDIA. I was wondering if users experiencing problems streaming with OBS while playing Call of Duty: Modern Warfare could try an experiment and let me know if it fixes the issue.

  1. Launch Call of Duty: Modern Warfare
  2. Alt-tab back into the desktop
  3. Press Control+Alt+Del to bring up the task manager
  4. Find the Call of Duty: Modern Warfare process as shown in the attached screenshot and change it from High to Normal
    View attachment 48800
  5. Star streaming with OBS.
Please let me know if it fixes the issue or if you notice any changes. You can post a reply here or send me a DM at www.twitter.com/ManuelGuzman

Thank you.

Regards,
Manuel

Did not work for me. Still getting stream stopped error whenever a multiplayer game ends. I was able to play and stream using OBS perfect in beta but now it's crashing the stream.
 

NVIDIA_Manuel

New Member
Did not work for me. Still getting stream stopped error whenever a multiplayer game ends. I was able to play and stream using OBS perfect in beta but now it's crashing the stream.

Thanks for the feedback. If you launch OBS by right-clicking on the OBS icon and select "Run as administrator", does that make any difference? My guess at this point is that the game is using up all of the available VRAM and not leaving any for the NVENC.
 
Last edited:

Padinn

Member
Thanks for the feedback. If you launch OBS by right-clicking on the OBS icon and select "Run as administrator", does that make any difference? My guess at this point is that the game is using up all of the available VRAM and not leaving any for the NVENC.

I run OBS in Admin mode and it will randomly pop up a diaglog box saying the encoder has stopped, I don't see an error code though (2080ti, latest drivers)
 

achelos9

New Member
Thanks for the feedback. If you launch OBS by right-clicking on the OBS icon and select "Run as administrator", does that make any difference? My guess at this point is that the game is using up all of the available VRAM and not leaving any for the NVENC.
I use OBS.Live as I have my stuff integrated with streamelements, this crash has affected me since the beta of Modern Warfare and makes it unstreamable unfortunately. I have a i7 9700k (not OC'd), 32gb ddr4 3200mhz ram, and a 2080. I use the Nvec encoding and notice a huge performance hit whenever the game is loading a cutscene. The worst cutscene hit is when loading to the multiplayer party/gamemode selection menu and it shows your guy walking, I also take a hit sometimes when loading a map, the last big hit I notice is when the game is giving a game summary and showing my XP after a match. All 3 of these mentioned cause OBS to stop streaming, the few times it's able to power through I can see the "Encoding overloaded, choose lower quality preset" and my KB/s for upload tanks completely and then will skyrocket. Most of these crashes happen when loading the multiplayer party/matchmaking loading scene. Also have had a lot of crashes just today on maps loading when going into a match, running driver version 441.12. Hope this helps with finding the culprit. I also run OBS in admin mode, have overlays turned off, and run modern warfare in admin mode with no luck.
 
Top