Frames skipped due to encoding lag


New Member
Hello, I've been constantly having an issue with skipped frames due to encoding lag. I've looked all over online to find a fix for this, but everything I've tried has not resolved my issue. I'm not sure what else to do. PS. I often use 100K of Bitrate the video never lagged, today with 50K the video start to skip frames.

I recorded a 30 seconds video and it skipped 347 / 1860 frames.

OBS Last Video Log:

CPU: Intel Core I5-10600KF

GPU: Msi Nvidia GeForce GTX 1650 SUPER

MotherBoard: MSI B560M Pro-VDH

RAM: Corsair Vengeance RGB Pro 16GB DDR4 2933MHZ

Current settings in OBS

Bitrate: 50K

Encoder: NVIDIA NVENC H.264 (new)

Frequency Control Type: CBR

Keyframe Interval: 0

Preset: Highest Quality

Profile: High

Look-Ahead checked

Psycho Optimization checked

GPU: 0

Maximum B-frame: 2

Resolution: 1920x1080

FPS: 60

Scaling Filter: Lanczos

Im using MKV

I've updated all my drivers, i have played around with bitrate, using x264. My GPU have barely hit 40% utilization, and a few times i've gotten the message saying my encoder is overloader. I'm not sure what else to try...

Any help?


Well from what I remember having multiple game captures can affect performance

18:33:03.628: - source: 'Desktop 2' (monitor_capture)
18:33:03.628: - source: 'Desktop 1' (monitor_capture)
18:33:03.628: - source: 'Dead Cells' (game_capture)
18:33:03.628: - source: 'Droidcam' (game_capture)
18:33:03.628: - source: 'Geometry Dash' (game_capture)
18:33:03.628: - source: 'Minecraft' (game_capture)
18:33:03.628: - source: 'Fortnite' (game_capture)
18:33:03.628: - source: 'Grand Theft Auto V' (game_capture)
18:33:03.628: - source: 'VR' (game_capture)
18:33:03.628: - source: 'Cattura gioco' (game_capture)

Also if you are recording. Don't use CBR that for streaming, should be using CQP if recording local


New Member
Ok thank you, I removed all of the Game Captures (Now I have only Minecraft) and what Frequency Control Type I need to use? My options are: CBR, CQP, VBR, Lossless.