Striderx2z

New Member
After trying almost every single thing possible, I have finally come to OBS forums for any sort of last resort help.

I am a streamer who multistreams on TikTok, Twitch, Kick and YouTube. For ages whenever I load into games, it would work however it would be a terrible gaming experience. From frame drops to music on my google randomly pausing because of "overload" (I'm assuming this). Whenever I stream I would have TikTok live studio open (to stream to tiktok) then OBS to stream to Twitch, Kick and YouTube. I would have several google tabs open for chat, music and more. The ONLY reason why I am running so many applications including the game is because I have a R9 5950X + 4070 12gb VRAM + 32GB RAM. I went from a 3060ti to a 4070 in hope the issue would fix with a more powerful graphics card, and guess what. Nothing changed and it got worse somehow someway. I use to be able to stream + record at the same time, now it won't even let me with an error of NVENC encoder whenever I press record while I'm streaming. Yesterday I streamed with my new 4070 and OBS told me I lost over 200,000 dropped frames. How is that even possible with a PC this strong? I hope you guys can see my frustration and I know having a single PC is to much demand on what I'm trying to do but I've tried everything and I just don't know anymore.
 

Attachments

  • 2024-01-12 13-37-01.txt
    28.7 KB · Views: 13

rockbottom

Active Member
Your issues have issues. Mixed Refresh Rates, Scenes have multiple Window/ Display/Game Captures. Bad Internet connection on your LAN. Timestamp warnings. Rendering lag = GPU overload The list goes on & on... Start here:

16:05:13.398: [rtmp stream: 'multi-output'] Connecting to RTMP URL rtmps://fa723fc1b171.global-contribute.live-video.net...
16:05:13.398: [rtmp stream: 'multi-output'] Connecting to RTMP URL rtmp://b.rtmp.youtube.com/live2?backup=1...
16:05:13.398: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmp://mia05.contribute.live-video.net/app...
16:05:13.402: No application or playpath in URL!
16:05:13.412: [rtmp stream: 'adv_stream'] Interface: Realtek PCIe GbE Family Controller #2 (ethernet, 100↓/100↑ mbps)
16:05:13.412: [rtmp stream: 'adv_stream'] Interface has non-zero error counters (0/21 errors, 0/0 discards)
16:05:13.425: [rtmp stream: 'multi-output'] Interface: Realtek PCIe GbE Family Controller #2 (ethernet, 100↓/100↑ mbps)
16:05:13.425: [rtmp stream: 'multi-output'] Interface has non-zero error counters (0/21 errors, 0/0 discards)
16:05:13.434: [rtmp stream: 'multi-output'] Interface: Realtek PCIe GbE Family Controller #2 (ethernet, 100↓/100↑ mbps)
16:05:13.434: [rtmp stream: 'multi-output'] Interface has non-zero error counters (0/21 errors, 0/0 discards)

16:05:13.652: [rtmp stream: 'multi-output'] Connection to rtmp://b.rtmp.youtube.com/live2?backup=1 (172.253.62.134) successful
16:05:13.653: [rtmp stream: 'multi-output'] Socket send buffer is 65536 bytes
16:05:14.462: [rtmp stream: 'multi-output'] Connection to rtmps://fa723fc1b171.global-contribute.live-video.net (52.223.243.182) successful
16:05:14.463: [rtmp stream: 'multi-output'] Socket send buffer is 65536 bytes
16:05:14.663: [rtmp stream: 'adv_stream'] Connection to rtmp://mia05.contribute.live-video.net/app (99.181.101.252) successful
16:05:14.663: [rtmp stream: 'adv_stream'] New socket loop enabled by user
16:05:14.663: [rtmp stream: 'adv_stream'] Low latency mode enabled by user
 

rockbottom

Active Member
I'm not 100% sure what's causing all of those timestamp warnings but it could be one of the media sources.

16:04:14.815: ------------------------------------------------
16:04:14.892: [Media Source 'Stinger (Stinger)']: settings:
16:04:14.892: input: C:/Users/husse/Desktop/Stream Overlays/stinger-transition.webm
16:04:14.892: input_format: (null)
16:04:14.892: speed: 100
16:04:14.892: is_looping: no
16:04:14.892: is_linear_alpha: no
16:04:14.892: is_hw_decoding: yes
16:04:14.892: is_clear_on_media_end: yes
16:04:14.892: restart_on_activate: yes
16:04:14.892: close_when_inactive: no
16:04:14.892: full_decode: no
16:04:14.892: ffmpeg_options:
16:04:14.906: warning: Could not update timestamps for skipped samples.
16:04:15.076: ---------------------------------
 

rockbottom

Active Member
Graphics/Video thread is very slow for your set-up. Rendering especially.


obs_graphics_thread(16.6667 ms): min=0.053 ms, median=4.934 ms, max=4260.36 ms, 99th percentile=20.019 ms, 98.1044% below 16.667 ms

19:06:45.604: ┣tick_sources: min=0.001 ms, median=0.264 ms, max=4240.7 ms, 99th percentile=1.573 ms

19:06:45.604: ┣output_frame: min=0.047 ms, median=1.671 ms, max=25.896 ms, 99th percentile=8.206 ms

19:06:45.604: ┃ ┣gs_context(video->graphics): min=0.019 ms, median=0.466 ms, max=20.491 ms, 99th percentile=3.543 ms, 1.99988 calls per parent call

19:06:45.604: ┃ ┃ ┣render_video: min=0.002 ms, median=0.246 ms, max=19.199 ms, 99th percentile=3.483 ms

19:06:45.604: ┃ ┃ ┃ ┣render_main_texture: min=0.002 ms, median=0.142 ms, max=18.262 ms, 99th percentile=2.89 ms

19:06:45.604: ┃ ┃ ┃ ┣render_convert_texture: min=0.003 ms, median=0.011 ms, max=1.555 ms, 99th percentile=0.057 ms

19:06:45.604: ┃ ┃ ┃ ┣stage_output_texture: min=0.001 ms, median=0.004 ms, max=1.298 ms, 99th percentile=0.014 ms, 0.498572 calls per parent call

19:06:45.604: ┃ ┃ ┃ ┗output_gpu_encoders: min=0 ms, median=0.042 ms, max=4.769 ms, 99th percentile=0.179 ms, 0.496651 calls per parent call

19:06:45.604: ┃ ┃ ┣gs_flush: min=0.002 ms, median=0.075 ms, max=13.317 ms, 99th percentile=0.418 ms

19:06:45.604: ┃ ┃ ┗download_frame: min=0 ms, median=0.003 ms, max=20.313 ms, 99th percentile=0.012 ms, 0.498572 calls per parent call

19:06:45.604: ┃ ┗output_video_data: min=0.003 ms, median=0.578 ms, max=17.229 ms, 99th percentile=4.133 ms

19:06:45.604: ┗render_displays: min=0 ms, median=2.416 ms, max=297.948 ms, 99th percentile=16.06 ms
 

rockbottom

Active Member
In one of the logs this device started normally, not so here.

16:01:01.368: [DShow Device: 'Main Cam'] settings updated:
16:01:01.368: [DShow Device: 'IVCam'] settings updated:
16:01:01.368: video device: e2eSoft iVCam
16:01:01.368: video device: Logitech BRIO
16:01:01.368: video path: \\?\usb#vid_046d&pid_085e&mi_00#7&32c5595a&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
16:01:01.368: resolution: 1920x1080
16:01:01.368: flip: 0
16:01:01.368: fps: 60.00 (interval: 166666)
16:01:01.368: format: MJPEG
16:01:01.368: buffering: disabled
16:01:01.368: hardware decode: disabled
16:01:01.368: video path: \\?\root#image#0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
16:01:01.368: resolution: 640x480
16:01:01.368: flip: 0
16:01:01.368: fps: 25.00 (interval: 400000)
16:01:01.368: format: YUY2
16:01:01.368: buffering: disabled
16:01:01.368: hardware decode: disabled
16:01:01.490: DShow: Run failed (0x800705AA): Insufficient system resources exist to complete the requested service.
 

Striderx2z

New Member
I thin
In one of the logs this device started normally, not so here.

16:01:01.368: [DShow Device: 'Main Cam'] settings updated:
16:01:01.368: [DShow Device: 'IVCam'] settings updated:
16:01:01.368: video device: e2eSoft iVCam
16:01:01.368: video device: Logitech BRIO
16:01:01.368: video path: \\?\usb#vid_046d&pid_085e&mi_00#7&32c5595a&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
16:01:01.368: resolution: 1920x1080
16:01:01.368: flip: 0
16:01:01.368: fps: 60.00 (interval: 166666)
16:01:01.368: format: MJPEG
16:01:01.368: buffering: disabled
16:01:01.368: hardware decode: disabled
16:01:01.368: video path: \\?\root#image#0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
16:01:01.368: resolution: 640x480
16:01:01.368: flip: 0
16:01:01.368: fps: 25.00 (interval: 400000)
16:01:01.368: format: YUY2
16:01:01.368: buffering: disabled
16:01:01.368: hardware decode: disabled
16:01:01.490: DShow: Run failed (0x800705AA): Insufficient system resources exist to complete the requested service.
I think the one log that it started normally, it wasn't actually streaming at all.
 

Striderx2z

New Member
Graphics/Video thread is very slow for your set-up. Rendering especially.


obs_graphics_thread(16.6667 ms): min=0.053 ms, median=4.934 ms, max=4260.36 ms, 99th percentile=20.019 ms, 98.1044% below 16.667 ms

19:06:45.604: ┣tick_sources: min=0.001 ms, median=0.264 ms, max=4240.7 ms, 99th percentile=1.573 ms

19:06:45.604: ┣output_frame: min=0.047 ms, median=1.671 ms, max=25.896 ms, 99th percentile=8.206 ms

19:06:45.604: ┃ ┣gs_context(video->graphics): min=0.019 ms, median=0.466 ms, max=20.491 ms, 99th percentile=3.543 ms, 1.99988 calls per parent call

19:06:45.604: ┃ ┃ ┣render_video: min=0.002 ms, median=0.246 ms, max=19.199 ms, 99th percentile=3.483 ms

19:06:45.604: ┃ ┃ ┃ ┣render_main_texture: min=0.002 ms, median=0.142 ms, max=18.262 ms, 99th percentile=2.89 ms

19:06:45.604: ┃ ┃ ┃ ┣render_convert_texture: min=0.003 ms, median=0.011 ms, max=1.555 ms, 99th percentile=0.057 ms

19:06:45.604: ┃ ┃ ┃ ┣stage_output_texture: min=0.001 ms, median=0.004 ms, max=1.298 ms, 99th percentile=0.014 ms, 0.498572 calls per parent call

19:06:45.604: ┃ ┃ ┃ ┗output_gpu_encoders: min=0 ms, median=0.042 ms, max=4.769 ms, 99th percentile=0.179 ms, 0.496651 calls per parent call

19:06:45.604: ┃ ┃ ┣gs_flush: min=0.002 ms, median=0.075 ms, max=13.317 ms, 99th percentile=0.418 ms

19:06:45.604: ┃ ┃ ┗download_frame: min=0 ms, median=0.003 ms, max=20.313 ms, 99th percentile=0.012 ms, 0.498572 calls per parent call

19:06:45.604: ┃ ┗output_video_data: min=0.003 ms, median=0.578 ms, max=17.229 ms, 99th percentile=4.133 ms

19:06:45.604: ┗render_displays: min=0 ms, median=2.416 ms, max=297.948 ms, 99th percentile=16.06 ms
How would this possible with a brand new gpu like a 4070?
 

rockbottom

Active Member
Possible with any GPU, a 4070 isn't anything special. Overload is overload & it's not much better in the new log. You need to reduce the load. You also changed Multipass to fullres in your encoding settings, switch it back to qres.

Internet looks suspect at best.
 

qhobbes

Active Member
I didn't look over the entire log but at one point it got to 1600 for the bit rate but it didn't drop any frames, as it should. I would leave that enabled while you troubleshoot your network issue. Try another provider (Restream, Twitch, Facebook, Twitter, etc.). If it's still happening, it's more than likely something on your end.
 

Striderx2z

New Member
Possible with any GPU, a 4070 isn't anything special. Overload is overload & it's not much better in the new log. You need to reduce the load. You also changed Multipass to fullres in your encoding settings, switch it back to qres.

Internet
Jeez it's like that? I guess the only way to stream whatever you want with no limitations is having dual PC's. I really thought a game + OBS + tiktok live studio + google tabs would be perfect for this setup but I guess its way to demanding on the graphics card alone.
 

qhobbes

Active Member
Multipass uses additional GPU. https://docs.nvidia.com/video-techn...-guide/index.html#multi-pass-frame-phencoding That should be off, not qres. The analyzer shows only 0.1% encoder over load and rendering lag, so you're close.

If you only need game + OBS + tiktok live studio + google tabs then get rid of your Display Captures and use Window Capture. Display Capture should only be used if you need to capture Windows stuff such as desktop and start menu.
 

Striderx2z

New Member
Multipass uses additional GPU. https://docs.nvidia.com/video-techn...-guide/index.html#multi-pass-frame-phencoding That should be off, not qres. The analyzer shows only 0.1% encoder over load and rendering lag, so you're close.

If you only need game + OBS + tiktok live studio + google tabs then get rid of your Display Captures and use Window Capture. Display Capture should only be used if you need to capture Windows stuff such as desktop and start menu.
Got it thank you so much! Also there is no option to turn off Multipass It's only "Single pass, qpass, multipass"
 

rockbottom

Active Member
Jeez it's like that? I guess the only way to stream whatever you want with no limitations is having dual PC's. I really thought a game + OBS + tiktok live studio + google tabs would be perfect for this setup but I guess its way to demanding on the graphics card alone.

That's not true. Your system is more than capable of doing what you are trying to do but the execution is lacking.
 

rockbottom

Active Member
Knock those (2) monitors down to 60HZ. Fix your Scenes & the timestamps. Encoding & rendering lag will be a thing of the past. That just leaves you to figure out what's wrong with your internet.
 

Striderx2z

New Member
Thank you Rock for being helpful! I had a question though, do you not think that TikTok Live Studio could be the culprit? I mean it has its own OBS to stream to TikTok to (but I adjusted all settings to be 4000 bitrate and 60fps 720p)
 
Top