Question / Help Extremely choppy recordings

mr_cool998

New Member
I've got a computer that's more than capable of doing a smooth 60fps recording without any issues. Despite this, nothing I do can fix the ridiculously choppy recording issue I have in OBS studio. Unless I get a 100% sure answer and not just a suggestion for a change in the settings, I don't know if I'll ever get this fixed.

Here's a video showing an example of how choppy it is - https://www.youtube.com/watch?v=qUsgnUhTDdQ&feature=youtu.be
Here's my PC part list - https://pcpartpicker.com/list/Zj7V8Y
Here's my OBS log - https://obsproject.com/logs/TxkZk-VitRVwlcEv
 

Mike321

Member
Im not an expert or anything but what i noticed was that your skipping alot of frames. Encoding lag means your CPU is being pushed to hard, and rendering lag/stalls means your GPU is being pushed to hard. Have you capped your fps ingame to take a bit of strain off ur CPU and GPU?

number of skipped frames due to encoding lag: 951/3417 (27.8%)
Number of lagged frames due to rendering lag/stalls: 330 (15.3%)

you also have the windows 10 gaming features on which can cause alot of problems, defo turn these off as they are crap :P

Game Bar: On
Game DVR: On
Game DVR Background Recording: On

Make sure in each scene there is only 1 capture method for your game dont have multiple like display capture and game capture. Id pick game capture as its the best one.

Id switch from CBR to CQP and start off at a value of 20.

Your PC is decent so its just a matter of optimizing your settings :) are you also recording to a seperate hard drive thats only used for recording?
 

koala

Active Member
Disable Windows Game Mode (Windows setting). Game Mode monopolizes the computer resources to your running game, so OBS starves.
Disable Game DVR Background recording (Windows setting). Having this enabled makes you actually having 2 recordings active at the same time: Windows itself and OBS.
 

mr_cool998

New Member
Im not an expert or anything but what i noticed was that your skipping alot of frames. Encoding lag means your CPU is being pushed to hard, and rendering lag/stalls means your GPU is being pushed to hard. Have you capped your fps ingame to take a bit of strain off ur CPU and GPU?

number of skipped frames due to encoding lag: 951/3417 (27.8%)
Number of lagged frames due to rendering lag/stalls: 330 (15.3%)

you also have the windows 10 gaming features on which can cause alot of problems, defo turn these off as they are crap :P

Game Bar: On
Game DVR: On
Game DVR Background Recording: On

Make sure in each scene there is only 1 capture method for your game dont have multiple like display capture and game capture. Id pick game capture as its the best one.

Id switch from CBR to CQP and start off at a value of 20.

Your PC is decent so its just a matter of optimizing your settings :) are you also recording to a seperate hard drive thats only used for recording?
Thank you for the reply! I didn't even know I had the windows gaming features on, other than game DVR which I would use to save FH4 clips. I'll disable all those things and switch to CQP to see if that helps. Also I dont have game capture because it crashes my game for some unknown reason.

Also I do save the recordings to my harddrive. I have some programs and windows 10 installed to the SSD and use it as the main boot drive and that's about it.
 

mr_cool998

New Member
Disable Windows Game Mode (Windows setting). Game Mode monopolizes the computer resources to your running game, so OBS starves.
Disable Game DVR Background recording (Windows setting). Having this enabled makes you actually having 2 recordings active at the same time: Windows itself and OBS.
Thank you for the reply! I'll be sure to disable the windows game features and try recording again
 

Mike321

Member
Thank you for the reply! I didn't even know I had the windows gaming features on, other than game DVR which I would use to save FH4 clips. I'll disable all those things and switch to CQP to see if that helps. Also I dont have game capture because it crashes my game for some unknown reason.

Also I do save the recordings to my harddrive. I have some programs and windows 10 installed to the SSD and use it as the main boot drive and that's about it.
You could always use nvidias geforce experience replay program to save some clips instead, but its a struggle to have DVR running while also recording with obs, as koala said its running 2 at the same time. What FPS do you get in FH4 while playing?
 

mr_cool998

New Member
You could always use nvidias geforce experience replay program to save some clips instead, but its a struggle to have DVR running while also recording with obs, as koala said its running 2 at the same time. What FPS do you get in FH4 while playing?
I get anywhere between 90 - 130 with a 144hz monitor on high settings
 

mr_cool998

New Member
You could always use nvidias geforce experience replay program to save some clips instead, but its a struggle to have DVR running while also recording with obs, as koala said its running 2 at the same time. What FPS do you get in FH4 while playing?
I managed to fix the recording issues. It was mostly the thing with the windows recording features but another thing too is that because my FPS was uncapped, it was also causing lag spikes. So I limited my FPS in game to 72 and it fixed everything and I get a mostly smooth recording. I get a small lag spike occasionally but other than that I should be fine now. Thank you to both of you guys for helping me fix this problem and now I have the motivation to record and to stream. Cheers!
 

WoodDuck

New Member
Hi There, im dealing with the same Issue, where did you cap the ingame FPS? I cant find that setting
 

carlmmii

Active Member
This thread is over a year old, and 2 windows versions and several OBS versions have been released since then, so the guidance has changed.

Post a new thread with your issue and include a log file of a recording/streaming session where you encounter the problem.
 

fkingchips

New Member
I'm late but I figured I'd just put down what fixed this for me because this is the first search result for anyone else with the issue

Watching my recordings on windows media player showed a lot of stutters but just switching the VCL media player completely fixed it and it was 60fps
 

epicxmo

New Member
ya using VCL media player fix the problem. Windows media player makes the quality look like trash and makes the frames really choppy.
 

mtliu

New Member
LOL. 2 years later and 2 versions later and this still helped. I'm not even playing a game, but straight using OBS to record a slowed-down video file. I didn't realize OBS was causing the choppiness and I thought it was my video rendering. It turns out OBS was outputting them with dropped frames. Just turning off game mode seemed to do the trick.
 

mtliu

New Member
LOL. 2 years later and 2 versions later and this still helped. I'm not even playing a game, but straight using OBS to record a slowed-down video file. I didn't realize OBS was causing the choppiness and I thought it was my video rendering. It turns out OBS was outputting them with dropped frames. Just turning off game mode seemed to do the trick.
I spoke too soon. The choppiness returned after 10 sec. However, even though I have a brand new laptop at work, it has no dedicated GPU. I'm going to try this on my home desktop machine, which has a much more powerful CPU and a dedicated GPU (in addition to more RAM).
 

koala

Active Member
This thread is 2 years old. Turning off game mode isn't recommended any more for recent versions of Windows 10 - actually, it gets worse with turning game off.

Recent Windows 10 updates changed Windows behavior, so it's actually best to activate game mode. If you still have issues while game mode on, run OBS as admin, since OBS is able to reserve required GPU resources this way. If it still doesn't work, make sure the thing you intend to record isn't consuming all GPU resources on its own. With games, limit the fps of the game and reduce graphics settings of the game.
 

Ontheway

New Member
This thread is 2 years old. Turning off game mode isn't recommended any more for recent versions of Windows 10 - actually, it gets worse with turning game off.

Recent Windows 10 updates changed Windows behavior, so it's actually best to activate game mode. If you still have issues while game mode on, run OBS as admin, since OBS is able to reserve required GPU resources this way. If it still doesn't work, make sure the thing you intend to record isn't consuming all GPU resources on its own. With games, limit the fps of the game and reduce graphics settings of the game.
are you sure? my videos are super choppy but everybody is recommending game mode off but you recommend game mode on
 

koala

Active Member
Game mode was and is recommended to be turned off for older Windows 10 versions, and is recommended to be turned on for Windows 10 versions 1809 and newer.

See the official OBS documentation:
 

ForyxeZ

New Member
Hi I am having the same problem my recording and streams are very choppy but my FPS is a solid 60 in game. Can anyone help me with this it would be a god send. I have looked for solutions everywhere but have had no luck.
PC Specs
Processor Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz, 3501 Mhz, 4 Core(s), 8 Logical Processor(s)
Installed Physical Memory (RAM) 16.0 GB
NVIDIA GeForce GTX 1650
 

Attachments

Top