Display Capture(s) don't refresh correctly


New Member
Years ago when I used OBS I had no issues, but over the last 3 or 4 years it has been an absolute nightmare trying to get it to work. I have uninstalled (using revo which deletes all traces of an installation so there's no older versions of setting messing with things) multiple times, tried 32 bit and 64 bit, running as admin, selecting between my graphics cards on startup, every combination imaginable and there's always something wrong.

The latest makes OBS basically unusable. It simply doesn't show the windows on my display. I need the entire display captured as I'll be using a variety of software for teaching remotely, and it refuses to consistently update any windows on the recording if I move or change them. It works *sometimes* then without reason just stops updating. I can still see my mouse move around and what-not but the windows don't work. I haven't seen any issues on the forum or youtube to help with this. Here's a video showing the behavior: https://youtu.be/_x9LBie67Cw

* This is on a Dell E6530 Laptop with 2 graphics cards, but I'm using the built-in one.
* I have a second display setup through a Dell Docking station.
* Focusrite Scarlett 2i2 2nd gen
* Have to use a separate MXL USB mic because I can't capture audio from the scarlet for some dumb reason (that's a whole different rabbit hole of failures I've gone down)


Forum Admin


New Member
Thanks for the link. I had done all the things listed on that page in the past as I came across that page when quarantine began however I decided to check and make sure. That led to a solution. I reinstalled my NVIDIA drivers and I removed "Classic mode" in my graphics settings. After that it worked consistently.