Question / Help Desktop audio doesnt record. Tried everything... Need some help


New Member
I have been unable to record any desktop audio... I was first using Shadowplay where i noticed that the game audio was sounding at about 10% even though the Volume Mixer shows that all audio is at the same place. I have read countless forums to try to find a solution and could not.

This is where I decided i would download obs and see if i can get it working in this app. It worked... but the audio for the mic and game was muffled after watching multiple more videos and reading more forums it as well stopped recording the game audio just like shadowplay even though i returned the settings back to before it stopped working..

Now im 3 days in troubleshooting and have given up... Ive tried everything. I installed Voicemeeter Banana in the hopes that would work but only the mic records, never the game audio. Although Voicemeeter upped the mic quality my problem still remains. I cant record game audio with any software.

Anyone have a suggestion?

For starters here is the log file.
I cant make any sense of it but maybe it will help you guys..

My headset is the Astro A40 TR mixamp edition and prior to downloading Voicemeeter Banana i used the Digital Audio (S/PDIF) as the default communication and default device and had no issues... I also set the Headset Earphone (Astro MixAmp Pro Voice) as the output in Discord so i could record that with shadowplay and obs but now nothing i do or try gets the game audio recorded...

Aside from that here are my specs:
Processor : Intel Core i9-7980XE Skylake X 18-Core 2.6 GHz LGA 2066 165W
Ram : 16gb DDR4
Motherboard : EVGA DARK X299

Here are the screen grabs i took to possibly help more.

Discord settings
discord settings.png

Playback Sounds part 1
Playback sound pic 1.png

Playback Sounds part 2
Playback sound pic 2.png

Voicemeeter Banana Settings
Voicemeeter Banana.png

Volume Mixer Levels
Volume mixer.png


Active Member

Quick Startup Guide, Page 9.

It looks like you've got it set properly so that "Voicemeeter VAIO" is your default WIndows output device. Game audio should go there.

For it to get into OBS for recording, you have to capture that device. It doesn't look like you have:

15:42:03.776: WASAPI: Device 'Digital Audio (S/PDIF) (High Definition Audio Device)' initialized
15:42:03.856: WASAPI: Device 'Headset Earphone (Astro MixAmp Pro Voice)' initialized
15:42:03.878: WASAPI: Device 'CABLE Output (VB-Audio Virtual Cable)' initialized

15:42:03.918: adding 46 milliseconds of audio buffering, total audio buffering is now 46 milliseconds (source: Mic/Aux)
15:42:04.931: Switched to scene 'Scene'
15:42:04.935: ------------------------------------------------
15:42:04.935: Loaded scenes:
15:42:04.935: - scene 'Scene':
15:42:04.935: - source: 'Game Capture' (game_capture)
15:42:04.935: - source: 'Display Capture' (monitor_capture)
15:42:04.935: ------------------------------------------------
15:43:32.043: WASAPI: Device 'CABLE Output (VB-Audio Virtual Cable)' Terminated
15:43:32.067: WASAPI: Device 'VoiceMeeter Aux Output (VB-Audio VoiceMeeter AUX VAIO)' initialized

You've got your S/PDIF port, your headset, and VB-Audio Virtual Cable (which I think is your Discord output) selected in OBS, presumably in Settings > Audio.

And then in OBS you have VoiceMeeter Aux Output (VB-Audio VoiceMeeter AUX VAIO) selected where it should be Voicemeeter VAIO, not Voicemeeter AUX VAIO.

You have the S/PDIF selected in Settings> Audio but I'm not sure why because it doesn't seem like anything is going there, unless you have an external device plugged in?

You do add that device once, but one thing OBS does not like is changing audio device settings on the fly.

I would suggest this:

Delete your sources in OBS. In Settings > Audio, disable everything. Reboot.

Then, in OBS, in a fresh scene collection, add VoiceMeeter VAIO as an audio source in a scene, and play some audio to the default windows device to make sure it works. (Rebooting can change your default device selection, so check that before you open OBS!)

If that works, then add your other sources. Start with default audio and go forward, not from the mic and go backwards.

Also make sure in Windows' audio settings that all your devices are set to non-exclusive. If you don't, then OBS will be unable to access some audio devices if other applications are using them (like Discord).


New Member
Okay so I got all of that to work thanks to your help! Now i have a new problem... My microphone which is now picked up is muffled/under water lol.

Every other program it sounds crisp and clear but not once it goes through obs. Any suggestions?