Blurry stream when moving in game (TWITCH)

Stfiler

New Member
Hi, I need help with a problem I have with my broadcasts. These look blurry / pixelated when I move in game and when I'm still it looks perfect. I thought my problem was my CPU but recently I changed it for a Ryzen 9 3900x but I still have the same problem before I had an I5 7600k. I don't understand why, because my download and upload speeds are good.

Below I leave screenshots of my settings and my speed

Speedtest.jpg
Output.png
Video.png
Advanced.png


My PC Settings :
GPU: GTX 1080
CPU: Ryzen 9 3900x
RAM: 24GB

My Log file:
 

Attachments

FerretBomb

Active Member
That is a common symptom of insufficient bitrate. During moments of high screen motion (turning, moving) it doesn't have the bitrate needed to maintain image quality. When you stop, the low-motion is much easier to handle.

It appears you're trying to run 1080p60 at 6000kbps, half of the recommended 12mbps needed to maintain adequate image quality at that resolution and framerate (0.1 bits-per-pixel is the baseline). This is only made worse by using the x264 Fast encoding preset.

Advise dropping to 30fps or downscaling to 720p, which can maintain a consistent image quality on the 6mbps you're using.
 

Anubis Mann

Member
Hi, I need help with a problem I have with my broadcasts. These look blurry / pixelated when I move in game and when I'm still it looks perfect. I thought my problem was my CPU but recently I changed it for a Ryzen 9 3900x but I still have the same problem before I had an I5 7600k. I don't understand why, because my download and upload speeds are good.

Below I leave screenshots of my settings and my speed

View attachment 60715View attachment 60716View attachment 60717View attachment 60718

My PC Settings :
GPU: GTX 1080
CPU: Ryzen 9 3900x
RAM: 24GB

My Log file:
Sos de Moreno, Buenos Aires, Argentina con Movistar fibra (como yo, pero a mi me da 300 clavados y mas).

1- No sirve de nada que pongas Lanczos sino estas haciendo ningún reescalado ya que tenes base 1080p y salida 1080p..... por otro lado es mejor por defecto en Bicubic en caso de reescalar.

2- Tampoco hay que setear 709 en salida de color ya que Android y Google Chrome de donde te ve la gente funciona a un espacio de color 601. Y por otro lado en el nuevo OBS 26 que saldra..... el espacio de color por defecto será sRGB (ya estoy utilizando para mis streams 26 rc1)

3- Modo Juego ON en Windows 10 2004
2- Run OBS en modo Administrador (siempre)
3- Descargar el codec AAC, link: Apple codec
- No instalar !, extraelo con Winrar en una carpeta.
- Dentro de la carpeta donde extrajo todo instalá sólamente AppleApplicationSupport64 (si usas OBS 64 bits, sino el otro que no dice 64)
- Reiniciar PC

4- La configuración correcta para streaming 2020 es la siguiente:

Placas de video NVIDIA

OBS

Output:
Encoder: NVIDIA NVENC (new)
Rescale: uncheck
Keyframe: 2
Preset: Quality
Profile: high

Audio:
Sample Rate: 48 kHz

Video:
Base (canvas): Resolución de tu monitor
Output: Si la salida es igual a la de tu monitor no se produce ningún reescalado, por lo tanto Lanczos o cualquiera no influye en nada.
Downscale: Bicubic siempre es mejor, como viene por defecto (y Lanczos consume el doble de recursos).

Advanced:
Color space: 601 y en la nueva versión de OBS 26 y superior por defecto será sRGB
Color Range: Partial

Network: (tip que no sabe ningún youtuber porque no son formados en la materia - multimedial, etc...)
Seleccionar 2 opciones:
- Enable network optimizations
- Enable TCP pacing
Estas dos opciones hacen que el ping de los juegos online no aumente ni afecte al estar haciendo stream, funciona "similar" a un QoS de los routers...

* Encoder NVENC (new) Sirve bien para tu placa pero en placas NVIDIA de arquitectura Turing (1660 y RTX) funciona mucho mejor todavía, cuando puedas cambiar a una 1660 o superior..... será mucho mejor para tu stream con ese encoder.

* Parámetros recomendados por la propia Twitch: (Twitch parámetros oficiales)
 
Top