Black screen when using capture card Avermedia Live Gamer Ultra-Video (GC553)

fdaciuk

New Member
Hi people! I'm trying to use this capture card, but with no success.
On windows, it works only in ReCentral, but not in OBS.

That is the result of the command `v4l2-ctl --list-formats`:

Code:
$ v4l2-ctl --list-formats
ioctl: VIDIOC_ENUM_FMT
        Type: Video Capture

        [0]: 'YUYV' (YUYV 4:2:2)
        [1]: 'YV12' (Planar YVU 4:2:0)
        [2]: 'NV12' (Y/CbCr 4:2:0)
        [3]: 'BGR3' (24-bit BGR 8-8-8)
        [4]: '' (30313050-0000-0010-8000-00aa003)
I've attached my logs from when I was trying to use and configure the capture card.
Any thoughts how to solve it?
 

Attachments

fdaciuk

New Member
New test results:
On Windows, if I remove USB and put it again, then open OBS, it works like a charm.

On Linux, the best I could get was audio working fine. Video is still black screen.
I did get once one frame from my source, but that was it. The log is the same as posted before :\
 

fdaciuk

New Member
Ok, I finally did make it work properly!

First, you just need to configure capture card audio and video on OBS. In my case, I used those configurations:

Screenshot from 2021-05-25 18-23-26.png


Then: close OBS, disconnect the capture card from USB, connect it again, and open OBS. If still not working, close / open OBS again.
Sometimes is needed to change some configuration to make OBS "woke up", like changing the Video Format.

But it works now!

Thanks in advance to @Tarulia (OBS on Discord) who wrote this feedback:

The feedback helped me to realize that I just needed to unplug / plug again the capture card, and now everything works like a charm on Linux! :D
 
Top