Bad quality of stream. (Good internet, hardware, OBS settings) [A lot of information]

Inkers

New Member
Bad quality of stream when moving. Makes stream look pixelated. (It's even worse with a webcam)
(Bad quality regardless of avc1 or vp9.)

Example: (CBR 9000 Kbps, 1080p, 60fps, faster)

All information about the stream settings in the attachments. (All in english)

The most important information about the hardware imo:
Intel Core i5-10600K
KFA2 GeForce RTX 2070 SUPER EX Gamer Black Ed 8GB GDDR6
MSI Z490-A PRO
GOODRAM 16GB (2x8GB) 3600MHz CL17 IRDM PRO
ADATA 1TB M.2 PCIe NVMe XPG SX8200 Pro
TP-Link Archer C6 DualBand
First Monitor 1440p 144hz
Second Monitor 1080p 60hz

(Stream Nvidia NVENC H.264. (new) 30k bitrate look pixelated too. Stream at 1440p also blurred.)
I use OBS in Polish, so the names of the scenes are in Polish in the log file.

I saw nicer streams than mine, despite worse internet and hardware.
My expectations are to stream at 1080p 60fps.
 

Attachments

  • Advanced.png
    Advanced.png
    138.1 KB · Views: 133
  • AministratorON.png
    AministratorON.png
    31 KB · Views: 130
  • Audio.png
    Audio.png
    135.4 KB · Views: 98
  • General.png
    General.png
    117.6 KB · Views: 89
  • OutputAudio.png
    OutputAudio.png
    100.5 KB · Views: 91
  • Output.png
    Output.png
    119.3 KB · Views: 93
  • Log File.txt
    13.4 KB · Views: 16
  • OutputRecording.png
    OutputRecording.png
    127.7 KB · Views: 97
  • SpeedTest.png
    SpeedTest.png
    30.3 KB · Views: 80
  • Video and Stream.png
    Video and Stream.png
    165.4 KB · Views: 101

Inkers

New Member
Second example:
(You can see the problem better)
 

qhobbes

Active Member
Change the refresh rate on your Gigabyte monitor from 144 to 120 Hz and cap your games at 120 FPS

For Streaming use:
Encoder: NVENC
Rate Control: CBR
Bitrate: 9000
Keyframe and B-frames: 2
Preset: Quality
Profile: High
Look-ahead and Psycho Visual Tuning: not checked
 

Inkers

New Member
Change the refresh rate on your Gigabyte monitor from 144 to 120 Hz and cap your games at 120 FPS

For Streaming use:
Encoder: NVENC
Rate Control: CBR
Bitrate: 9000
Keyframe and B-frames: 2
Preset: Quality
Profile: High
Look-ahead and Psycho Visual Tuning: not checked

Still blurry. Unless I'm exaggerating. Please rate. (The Witcher 3 60FPS, CS:GO 120FPS)
 
Last edited:

qhobbes

Active Member
Try changing the Downscale Filter to Bicubic. Games are not real-life video.

Also try lowering the game quality settings a bit until you get a persistent 120 FPS in game.
 

Inkers

New Member
Try changing the Downscale Filter to Bicubic. Games are not real-life video.

Also try lowering the game quality settings a bit until you get a persistent 120 FPS in game.
Nothing helped. I also tested Mirillis Action! and it was blurry.
Stream with Nvidia Experience looks great at 1440p 60fps 144hz so thanks for help but I'm abandoning obs.
 

stevenschulz

New Member
I hope you ended up getting this sorted out Inkers, but I wanted to add the following for future reference for people searching out this topic.

When having lots of pixilation troubles during movement:

Make sure of course you are running OBS as an Administrator (right click icon - run as administrator) to make sure Windows isn't going to throttle OBS to preserve your game's performance over OBS.

The key to this problem is usually in the preset when everything else is good to go. Try the different Low-Latency settings and see which one you like. I played with every preset there is on OBS and I ended up liking Low-Latency Quality the best for first person shooters and other games with lots of screen changes. Your preferred setting might end up being Low-Latency Performance, try them out and see what you think. Happy Streaming.
 

Attachments

  • OBS Settings Pic Low Res.jpg
    OBS Settings Pic Low Res.jpg
    592.9 KB · Views: 364
Top