Audio Issue with Elgato HD60s

Verrea

New Member
I'm having an issue in OBS with regards to an Elgato capture card and my microphone input that I can't seem to find any information about.

The issue is that OBS automatically picks my microphone input instead of the Elgato input for sound. Meaning that in the audio mixer I have both my microphone input recording my mic and my Elgato input also recording from my mic input. I have checked the settings to make sure that it's picking the correct source and nothing has changed. I've been using the Elgato and OBS together for years and I haven't changed any settings nor was I changing anything when this happened. I cannot get the Elgato source to actually pick up sound from my Elgato like it should. I also have Streamlabs OBS installed and it does the exact same thing when I open that program, which it didn't do yesterday. I've tried the following:

-Rebooting PC
-Rebooting/Reinstalling OBS
-Uninstalling the Elgato device altogether and reinstalling the drivers
-Plugging everything into different USB ports
-Going into properties for the Elgato source in OBS and scrolling down to where it says Use custom audio device, selecting that and then manually choosing the Elgato as the sound input I want it to use. Doing this has no different outcome, it says it's using the output from the Elgato but it's actually still taking my mic input.
-Unplugging both my Microphone and Elgato, then only connecting the Elgato seems to work. Once I plug my microphe back in however, it changes the sound back to automatically choose the mic input.
-Opening Elgato Game Capture software to check if the Elgato can actually still pick up sound, works fine there, checked all the settings there also to make sure.

This is an issue that just popped up today when trying to record, and nothing I do seems to fix this.
I run my microphone through a USB audio interface called Roland Edirol UA-25EX.
I just cannot stop OBS from prioritizing this device when trying to get the Elgato sound to work.

I also cannot find any discussions of anyone having a similar issue so I'm hoping someone can come up with something I haven't tried yet.
 

Attachments

IJN

New Member
I found this out just now i think it's gonna work

-Open up obs and deactivate Elgato, don't close obs
-Go to volume control to right click and press Sounds to open up Sound Control Panel
-Once your in Sound Control Panel disable the audio interface your using including the microphone
-Go to obs again and reactivate elgato and test it if it's picking your game audio
-Go back to Sound Control Panel again to enable the audio interface and microphone

And that's that, i had this problem too when i got the new audio interface for the past 4 months
This could probably work
 

Verrea

New Member
I found this out just now i think it's gonna work

-Open up obs and deactivate Elgato, don't close obs
-Go to volume control to right click and press Sounds to open up Sound Control Panel
-Once your in Sound Control Panel disable the audio interface your using including the microphone
-Go to obs again and reactivate elgato and test it if it's picking your game audio
-Go back to Sound Control Panel again to enable the audio interface and microphone

And that's that, i had this problem too when i got the new audio interface for the past 4 months
This could probably work
That fixed it! Thank you very much. I still had this problem after all these months, what a relief!
 
Top