Audio filters not being applied to USB interface (Presonus Studio 24c)

Brian L

New Member
The situation is streaming to YouTube. We were using a cheap RCA to USB interface for a video camera to capture audio, and recently upgraded to a Presonus Studio 24c.
When I hooked up the Presonus for the first time and everything worked perfectly, with Windows and OBS recognizing it without a hitch, I thought everything was great. But, there was some clipping so I turned the volume down on the Presonus. The volume of the stream was a little low, so in OBS I raised the dB of the output from 0.0 to 6.0. When I tried to apply a Compressor and Limiter to keep the peaks down, I noticed that they were having no effect. This is my main question.
Another issue I noticed was that the 6.0 dB would go back to 0.0 on its own. I assume these are both symptoms of the same problem, but I don't know if I should be seeking answers for OBS, the Presonus, or Windows.
If you need more info, just let me know.
Thanks in advance.


Another issue I noticed was that the 6.0 dB would go back to 0.0 on its own.
Probably your adjustment was done in Advanced Audio Properties by typing at the Volume field, changing 0.0 into 6.0. This way you are controlling the fader, so to say. See for yourself by typing -6.0 and the fader will be slided left (or down when using Vertical Layout). Then grab the fader and move it and subsequently notice the changing value of the Volume field.

Have the Presonus in your scenes by adding an Audio Input Capture source. Then right click that source, select Filters and add a Gain filter. Set it to the desired value of 6.0 dB.

Brian L

New Member
Thank you both, I will look into using ASIO.
In the meantime, my main issue with filters not being applied still stands.
Does anyone have any thoughts about what could be going on?

Brian L

New Member
I switched to ASIO and have not had any problems, so I consider my problem solved. Thank you WBE and SopherFellow.
  • Like
Reactions: WBE