Advanced Scene Switcher .so file not copying during install process.


New Member
Hey hey,

I've tried many many things to get this to work and haven't made any headway. Log is here:

A bit of the story:

I'm on an old Mac tower, Mid 2012 running High Sierra 10.13.3. I've run the .pkg and the .plugin file is copied to application support but the .so file isn't showing up in the application package contents.

I've run the terminal command:

xattr -r -d ~/Library/Application\ Support/obs-studio/plugins/advanced-scene-switcher.plugin

and gotten back this weird bit of nonsense:
xattr: No such file: /Volumes/Project Media/Users/mandoplan/Library/Application Support/obs-studio/plugins/advanced-scene-switcher.plugin

Likely because I used to have my user folder on a different drive than the boot disk and applications and the older folder is still parked there, though my users are currently on the boot disk with the applications folder. All I need is the .so file and I can copy it to the location where it needs to go in the package contents, is that available anywhere?

@Warmuptill you are my only hope.


Active Member
You might ask in the Adv. SS thread:


Active Member
It seems like you are stuck on OBS 24.
Unfortunately this version is not supported by the plugin.

I think upgrading OBS is also not an option for High Sierra. (At least to my knowledge)

So I am afraid there is no solution :(


Active Member
@Warmuptill thanks for the reply and for looking at my issue. I've been able to get OBS 27.2.4 to work on the machine, is there a version of Advanced Scene Switcher that will work with that version of OBS? I tried to figure it out but 'triangulating' the dates on Github made this video guy's head swim . Latest log is here:
This is the last release compatible with OBS 27: