Activating/deactivating a video source with shortcuts?


New Member
Hey there.

Sometimes two of my video sources act up a little; my capture card audio lags, or my Cam Link needs refreshing for my video to show up.

Both of these issues are solved by just clicking "Deactivate" in their settings, and then Activating them again. This also needs to happen if I start OBS before turning my camera on for my Cam Link to detect.

I was wondering if there was a way to automate this, mostly for ease of use. Most of the shortcuts I've seen are just for showing/hiding them, not for Activating/Deactivating.



Active Member
Settings --> Hotkeys --> Filter: source name --> input something in Show/Hide 'source name'* boxes such as Ctrl + 1 [Apply] [OK]


New Member
Settings --> Hotkeys --> Filter: source name --> input something in Show/Hide 'source name'* boxes such as Ctrl + 1 [Apply] [OK]

Show/hide is not the same as Activate/Deactivate.


What I'd like is something to toggle the button in the Video Source settings, essentially.


New Member
Huh, good point. I think since my camera is showing on every scene, I can make a generic background or something and then switch there/back.


New Member
I've got my Camera's set up as their own scenes, and then I use these scenes inside whatever other scene's I want. This should allow me to apply filters to each scene, without applying them to the "whole" camera input that I've defined.

I've also had this Activate/deactivate issue and I found that the steps above (with one tweak) worked:
1. Set the Camera to "Deactivate when not showing".
2. Now click the "Activate" button on screen to activate it (after doing this the button will show "Deactivate").

3. Now use your Show/Hide hotkey. On screen any activate/deactivate" buttons will still show "Deactivate", but the camera will now cycle through being active/inactive (the light on my camera goes off/on) as well as shown/not-shown.

This term is probably wrong, but in my mind there is a "Hard" activate and a "Soft" activate. Unless the "Hard" activate is on (clicking the on-screen Activate button), then the "Deactivate when not showing" does nothing for me when I use the show/hide hotkey.