Resource icon

3DS Capture Plugin (CLR-Hosted) 2014-04-17

Tirium

New Member
Tirium, plugins that rely on CLR Host go in its folder. So for example, with the 32-bit version of OBS:

- The 32-bit CLR Host plugin (the CLRHostPlugin folder and CLRHostPlugin.dll you extracted) go in C:\Program Files (x86)\OBS\plugins

- The 32-bit 3DS Capture DLLs (from the x86 folder, don't move the folder itself) go in C:\Program Files (x86)\OBS\plugins\CLRHostPlugin
Thank you, but it still doesn´t seem to work. There already was a file in the CLRHostPlugin folder between which I replaced with one of the dll´s from the 3DS capture plugin. I think, I am missing something. :/
 

Attachments

Sapiens

Forum Moderator
Have you tried right-clicking in the sources box to see if it's an option there? It won't show up in the plugins list AFAIK.
 

Tirium

New Member
Yes, I tried that and no new options appeared there. I also tried it with the 3DS connected now. Just in case. Still no success though.
 

Myrhdin

New Member
Hello there. Facing a bit of an issue here.

I tried out this plugin last week on another computer and decided to set it up on my main streaming machine this week. And I just can't get it to work, whatever I try.

When I try to set the current package up in its 32 bits version, I get the following error message: The plugin 'CLRHostInterop.dll' is meant for the 64 bits version of OBS and cannot be loaded. This is just plain weird since I'm copying and pasting the content of the 32x folder you can find in the archive.

Since I just need to use that plugin to record content on my 3DS, I hopped on the 64 bits of OBS, after installing the 64x version of the plugin. This time, I get this message: Impossible to run the program because CLRHostPlugin.dll is missing on your computer. That's just totally weird since this is like the first plugin I ever installed and it's present in all installation directories for OBS on my computer, in its correct spot, since my other plugins use it without any problem.

I tried reinstalling OBS twice. I deleted my entire collection of plugins twice. I reinstalled everything anew twice. All of that to no avail so far.

Am I missing something? Am I the only one facing this issue?
 

HashBrownJM

New Member
So, quick question.

First off, THANK YOU for such an awesome plug-in! I have a Loopy 3DS and this captures video feed like a champ.

However, I'm in sort of a bind when it comes to audio. The audio from the 3DS isn't being picked up even though the video is. If I open Loopy's 3DS Capture program, audio gets picked up, but then the plugin doesn't pull in the video feed anymore. (I assume because it's being pulled to two sources?)

What can I do to use this plugin and still have it pull audio, or am I out of luck?
 

xarxex

New Member
Any idea if this works with Loopy's Vita mod as well?
http://www.3dsvideocapture.com/product/31
It's probably not gonna work, but I have no idea how the vita capture card works since I don't have one available.

What can I do to use this plugin and still have it pull audio, or am I out of luck?
I wrote the plugin when there was still no support for audio. I'm getting to work soon™ with a new plugin, which will have support for audio.
 
I cannot use the CLR browser and this plug in at the same time. The whole program locks up. Is there a way to use both at the same time? I want to use the CLR browser for donation alerts and stuff while playing. Another question, is there an OBS Studio version for this plug in?
 
Top