Bug Report 144hz Monitor loses Smoothness when OBS Preview Enabled on 60hz monitor

I think it's time to bring this discussion back. I've installed Win 10 1903 update and games no longer stutters having playing videos on my second (60Hz) screen. Blizzard and discord clients with animated banners that were causing stutters in 1809 now working flawlesly.

OBS with preview mode is still causing issues! Ans this need to be investigated.
Yeah same here. This discussion is needed. I need to see if the Streamlabs version is UWP or operating like a fullscreen borderless mode. I think Microsoft made some DirectX changes, but from my understanding now....these stutters are happening because of the desktop composite and the way the app uses the frame buffering. Developers do not want to remove code that still support Windows 7 and earlier. They can say what they want, but because this code is still present it causes stuttering to the DWM. It's called "Fullscreen Optimizations", which are implemented on the image. If you run your games in Windowed Fullscreen or Borderless Fullscreen, then you will notice that there is no stuttering. Microsoft apps or UWP apps run like this because that is how they should run. Fullscreen Exclusive is broken on purpose in Windows 10 so they can stop using Windows 7....thus it's coming to an end later this year. I'm not a theorist on it. If you ask a mechanic to change the oil in a car, then they will do it regardless of the car and not say, "you need to upgrade before I can change it." Now I know OBS is open source. If I knew C++ really well, then I would have helped in this area a long time ago. Microsoft is not slowing down gutting Windows 7/XP code to improve the frame buffering so apps can run a bit closer to kernel mode.

Monitor certification is the other problem. EDID's are F'd up in all places. Windows 10 correctly recognizes 59.94 and 60hz in the registry by applying the correct numerator and denominator, but the drivers may state 60hz and represent 59.94hz. I had to add additional EDID info, but we are supposed to be using the new EDID info by now.
 
Last edited:
So I want to confirm what I posted about this stuttering and apps not running with UWP and still using old Win32 code to keep Windows 7 floating. The latest Streamlabs OBS version has zero stuttering in the preview and output as it's running UWP like a Microsoft app.
 

NotNow

New Member
So I want to confirm what I posted about this stuttering and apps not running with UWP and still using old Win32 code to keep Windows 7 floating. The latest Streamlabs OBS version has zero stuttering in the preview and output as it's running UWP like a Microsoft app.
Are you saying that using SLOBS fixes the issue?
 

Skendertv

New Member
Here is an easy work around.
Start OBS with preview disabled.
Then launch your game, alt/tab to desktop and re enable the OBS preview. This worked for me, hope it works for you.
 
Are you saying that using SLOBS fixes the issue?
Just to note: I'm using OBS on a dedicated streaming/recording PC.

I believe so. I think it's compiled to run more like a Universal Windows Platform app, which takes better advantage of the desktop composite in a Borderless Fullscreen Mode. Download a free Microsoft App like Candy Crush and you will see what I mean. It's as if the app uses framebuffers differently than if the app was exclusive fullscreen or windowed.
 
Last edited:
Here is an easy work around.
Start OBS with preview disabled.
Then launch your game, alt/tab to desktop and re enable the OBS preview. This worked for me, hope it works for you.
I wanted to caveat on what you wrote. This is also my recommendation.

1. Set your primary and or extended monitor’s refresh rate to 60hz. For better results, use a monitor that has a 1 millisecond timing or use a FreeSync / G-Sync Monitor. You can use G-Sync on a FreeSync monitor with a NVIDIA GPU if you have at least a 10-series GPU (1060 and above). Setting the refresh rate to 144hz will cause OBS to drop more frames thus stutter in the preview window.

Note 1: YouTube supports capturing at 120 hz, but it’s not recommended to set OBS’s FPS this high.

Note 2: If you have two GPUs, do not connect the monitor to the second GPU in the Extended Mode and use the Windowed or Fullscreen Preview on this monitor. Doing so will cause the encoder to drop frames in OBS.

2. In OBS, set your capture card to 60 FPS for capturing video.
3. In OBS, Buffering: change to Enable.
4. In OBS, disable the preview. If you need to modify your scene, then enable the preview.
5. In OBS, use a Windowed Projector (Preview). Keep it on the same monitor unless you have at least a core i5 and above (4th Generation) or Ryzen. Some APU’s will cause the encoder to overload if the AMD GPU is disabled in Windows
 

Excalidoom

New Member
I wanted to caveat on what you wrote. This is also my recommendation.

1. Set your primary and or extended monitor’s refresh rate to 60hz. For better results, use a monitor that has a 1 millisecond timing or use a FreeSync / G-Sync Monitor. You can use G-Sync on a FreeSync monitor with a NVIDIA GPU if you have at least a 10-series GPU (1060 and above). Setting the refresh rate to 144hz will cause OBS to drop more frames thus stutter in the preview window.

Note 1: YouTube supports capturing at 120 hz, but it’s not recommended to set OBS’s FPS this high.

Note 2: If you have two GPUs, do not connect the monitor to the second GPU in the Extended Mode and use the Windowed or Fullscreen Preview on this monitor. Doing so will cause the encoder to drop frames in OBS.

2. In OBS, set your capture card to 60 FPS for capturing video.
3. In OBS, Buffering: change to Enable.
4. In OBS, disable the preview. If you need to modify your scene, then enable the preview.
5. In OBS, use a Windowed Projector (Preview). Keep it on the same monitor unless you have at least a core i5 and above (4th Generation) or Ryzen. Some APU’s will cause the encoder to overload if the AMD GPU is disabled in Windows
You are waaay of the point. This issue happens when u have only 1 PC. If you can help with a fix, do it for 1 PC. 99% of the people who stream/record don't have extra pc's and capture cards so this ain't helpful at all, it's more of a "why are you poor" kind of deal.

Back to the subject, latest Windows 10 build (2004 i think), issue still here. The only work around is to disable preview (if you stream,use the platform dashboard). At this rate the whole thing will be fixed when win 7 is 101% dead. There are no workarounds except same refresh rate monitors, minimising the obs (but then u can just disable preview in the first place) or puting on the high refresh rate screen (which again beats the point of having 2 screens).
 
You are waaay of the point. This issue happens when u have only 1 PC. If you can help with a fix, do it for 1 PC. 99% of the people who stream/record don't have extra pc's and capture cards so this ain't helpful at all, it's more of a "why are you poor" kind of deal.

Back to the subject, latest Windows 10 build (2004 i think), issue still here. The only work around is to disable preview (if you stream,use the platform dashboard). At this rate the whole thing will be fixed when win 7 is 101% dead. There are no workarounds except same refresh rate monitors, minimising the obs (but then u can just disable preview in the first place) or puting on the high refresh rate screen (which again beats the point of having 2 screens).
I don't stray from the topic, I just get technical. Windows 7 will always be a part of Windows 10, so that's a dead issue. 99 percent of the people who stream don't have the experience of recording either, so you either learn or you don't want to learn. If you don't meet the requirements of your capture card (most are either a Core-i5 or a Ryzen), then you will have issues when encoding video. Disabling Preview does nothing to improve that. It's the sharing of resources with those USB capture cards that companies like Elgato, Razer, and Avermedia keep supplying, so USB 3's 10 GB/s is shared with other USB devices on the Southbridge chipset....that may leave about 5 GB/s. As it fights for resources.....it stutters.

The best way is to use a PCIe based capture card. I tested OBS with numerous CPU's and APU's and so far, the Core-i7 4850K series (4th Gen) and it's chipset is what I recommend, because I can make OBS output at 480 frames per second at full screen. Older Haswell CPU's and their motherboard's chipset have bandwidth limitations and cannot output past 120 frames per second full screen. When those older 3rd Gen CPU's and below are mitigated with Spectre/Meltdown by Microsoft, they will slow down the encoding.
 

Bllicky

New Member
My main monitor is a 165hz and my secondary ones are 60, so my main monitor would switch to 60hz when I tab back into the game since I was running OBS on a 60hz monitor, so I resorted to keeping OBS on my main monitor behind my gameplay and, while inconvenient, it fixed the issue. But would getting another 165hz monitor and running OBS on that one fix the issue altogether? Would it matter that my third monitor is 60hz, but OBS and my game are still being ran on 165hz monitors?
 

Agent_scott_snr

New Member
Im here now with the same problem, this has been about 4 years after this started,
This is ridiculous on windows side that they haven't addressed a issue for over 4 years since that bug report was sent to them
I think im going to move to Linux or something
 

Raion969

New Member
I have right now the same problem with cs go i have about ingame while streaming and recoding with nvenc new 300fps but my game feels still really choppy and not really smooth when having obs on the second monitor.

Is there still not a fix for it ?
 
Top