Bug Report 144hz Monitor loses Smoothness when OBS Preview Enabled on 60hz monitor

bluelamb

New Member
I have a decently high spec system for gaming
i7-4770k-------------Windows 10 on SSD where OBS is installed
GTX 1070-----------Dell S2716DG 1440P 144hz Gsync Primary Monitor connected to GPU
16GB RAM--------- HannsG HZ281 1980x1200p 60hz Secondary Monitor also connected to GPU

I've noticed that with OBS 20.1.3 64bit running on the second monitor with preview enabled, the gameplay on the primary monitor is not as smooth and fluid. (haven't tested other OBS versions but I assume it's the same)

This occurs even when there are no sources - just a blank template and a black screen in the preview of OBS.

The 144hz looks very smooth Preview Enabled turned off - however it's quite important to be able to see what is being shown in real time sites like Twitch.

It seems that somehow, OBS throttles (?) the performance of the 144hz monitor. This can hinder the ability to record/stream games in real time with Preview Enabled.

So in conclusion, OBS on 60hz Secondary Monitor degrades 144hz Primary monitor refresh rate or framerate while Preview is Enabled. Disabling preview is the only fix (?)

CPU or GPU usage don't appear to spike or overload due to preview enabled - so it may not be a hardware performance issue, rather something to do with how OBS handles differing monitor refresh rates.

I have tested in various games like Black Desert Online, PUBG, Rocket League and CSGO. CSGO will probably give the best results in tests because it keeps the highest constant FPS for testing with high refresh rates.

*I'd like to add that if I move OBS to the primary monitor (but not minimized), the issue does not persist. It is only when games are in the primary monitor (144hz) and OBS with Preview Enabled is on the secondary monitor(60hz).
OBS does not have to be capturing the game or recording, or streaming, It simply just needs to be open with preview enabled.

I appreciate OBS teams help and hope there is a solution!
 

BK-Morpheus

Active Member
That's "normal" and nothing, that OBS can "fix".
Windows can't handle 3d accelerated programs (Games, videoplaybay, OBS live preview evt.) on two different refreshrate-monitors at the same time.
The 144Hz monitor will switch down to 60Hz, when this happens.

You could ask in the Microsoft forums, if and when Microsoft will address this issue.
 

sam686

Member
Limitations of forced v-sync in DWM. A possible workaround is to go back to windows 7 and turn off DWM/Aero.
This isn't limited to OBS, playing 60fps YouTube video on a 60Hz monitor have the same effect of slowing down higher refresh rate monitor.

This search might have some more information.
https://www.google.com/search?q=windows+10+multi+monitor+refresh+rate+lock

A dual PC streaming is possible, but it has some limitations. Many cheap capture cards is limited to HDMI 1080p 60Hz, and no capture cards have G-Sync. Only the more expensive capture cards have DisplayPort capture and/or 4k 60fps.
 

awolive

Member
I have the exact same Dell 144hz monitor for gaming and obs on a dedicated 60hz monitor and I don't have this problem. I also use Window capture over display/game capture too though so not sure if that might help.
 

bluelamb

New Member
I have the exact same Dell 144hz monitor for gaming and obs on a dedicated 60hz monitor and I don't have this problem. I also use Window capture over display/game capture too though so not sure if that might help.
That's interesting because if it's a windows related problem like BK-Morpheus says, your 144hz monitor should be switching to 60hz.

Perheps you can't tell the difference or BK Morpheus is incorrect about 144hz switching to 60hz due to Windows 10's inability to handle 2 different 3D accelerated programs on 2 different refreshrate monitors.

I went ahead and recorded some videos with the preview enabled and disabled and I can say the difference in smoothness is very obvious to me in sight and feel during gameplay.

Preview is disabled here - so it runs quite smooth.
https://www.youtube.com/watch?v=_mU1ZTGOlic&feature=youtu.be

Preview enabled here.
https://www.youtube.com/watch?v=zk6qacQuUDw&feature=youtu.be
 

sam686

Member
I have made this video to show this windows 10 DWM problem, using 60 Hz and 24 Hz.
https://www.youtube.com/watch?v=p10OMGDXolQ

I have the exact same Dell 144hz monitor for gaming and obs on a dedicated 60hz monitor and I don't have this problem.
Running game at exclusive fullscreen mode? I have heard that allowing the game to run at exclusive fullscreen mode might bypass DWM problem for games and allow turning off game game's v-sync to get lowest latency with screen tearing. Note that windowed borderless mode may not work.
 

awolive

Member
maybe my g-sync is kicking in and helping because it definitely doesn't feel like 60hz when gaming for me. i did notice it was a little smoother changing to full screen on my game as opposed to fullscreen borderless window. also in overwatch you can cap your FPS to the monitors effective refresh rate and it tends to stay around 144hz for me if that was the case my FPS would drop to 60 respectively.

@sam686, what is your nvidia monitor optimization settings? maybe changing to single or multi monitor optimization helps?
 
Last edited:

sam686

Member
what is your nvidia monitor optimization settings? maybe changing to single monitor optimization helps?
I don't have NVidia graphics card. My computer is good enough for x264 1080p 30fps or 720p 60fps streaming console games (PS3 and PS4), on a super weak GPU. http://www.userbenchmark.com/UserRun/5244517

I used intel graphics properties, custom resolution, to be able to drop the refresh rate to as low as 24 Hz to show this problem with Windows 10 mixing 24 Hz and 60 Hz refresh rate, using both capture cards. CRU 1.3 (custom resolution utility) may be able to add more resolution or refresh rates on AMD or newer GPU. Also, sadly, having 2 GPU, one monitor on each GPU, does not fix windows 10 DWM v-sync problem.
 

awolive

Member
The problem you are displaying is definitely a issue but I believe its only a issue for me when physically interacting with a window/program within the 60hz monitor once you go back to interacting with the high refresh rate monitor it goes back to its own refresh rate.
 

awolive

Member
i was able to experiment with this idea a bit. my conclusion is enabling preview impacts your refresh rate but doesn't mirror the lower frame rate (i.e. gaming on 144hz and obs stream w/preview on 60hz monitor doesn't give your 144hz monitor 60hz while gaming unless you are interacting with the 60hz monitor) but it does impact by giving a reduce frame rate of around 80-100fps or similar hz) so disable preview if you want to enjoy full 144hz while gaming or take a loss on hz to around 80-100hz.

Note: g-sync will help with this problem a bit but you definitely can feel a slight reduction in smoothness with obs showing a preview. If i had to guess it helps it feel more like 100-110hz in terms of smoothness.
 

awolive

Member
I contacted Microsoft support regarding this issue. They are aware of this issue case # 1407200434
They don't have a time when it will be fixed unfortunately, they claim it has to do with the manufacturers of graphics cards getting to work with their own engineers at Microsoft.
 

Mike321

Member
Exactly the same thing happens to me its so annoying :( like you said we want to be able to see everything thats going on with obs while recording,streaming. The only thing to do for now is disable the preview window sadly
 

Zeltcon

New Member
Or if you have an old gpu like gt 9800 above that's where I plug my 2nd monitor(60hz) in and it fixes the issue, but if you don't have one well you need another same refresh rate monitor to balance annoying the bug
 

Capitin

Member
That's interesting because if it's a windows related problem like BK-Morpheus says, your 144hz monitor should be switching to 60hz.

Perheps you can't tell the difference or BK Morpheus is incorrect about 144hz switching to 60hz due to Windows 10's inability to handle 2 different 3D accelerated programs on 2 different refreshrate monitors.

I went ahead and recorded some videos with the preview enabled and disabled and I can say the difference in smoothness is very obvious to me in sight and feel during gameplay.

Preview is disabled here - so it runs quite smooth.
https://www.youtube.com/watch?v=_mU1ZTGOlic&feature=youtu.be

Preview enabled here.
https://www.youtube.com/watch?v=zk6qacQuUDw&feature=youtu.be
Youtube's max fps is 60 I believe. So unfortunately your demonstration couldn't help :P
 
I understand this issue. When recording, I also captured the stutter when using 144hz at first. There are actually two problems here: The monitor manufacturer and the driver developer.

The monitor manufacturer test their products to ensure they meet environment standards, VESA standards, etc.
The driver developers test monitor standards and make sure that programs and video function by adding standard refresh rates.

Missing refresh rates, missing resolutions, missing monitor data, and missing cable data is the problem. I had to use a nice utility called Custom Resolution Utility and my monitor's manual to add any missing data. DisplayPort is required because 144hz uses more than 300 MHz....which is not possible with HDMI (unless you have HDMI 2.0 standards). Driver developers don't even add the appropriate data for DisplayPort, so that's why it's choppy when using OBS in regards to the preview.

Thought: I added all possible framerates to include the drop frames (59.94, 29.97, 71.93, 119.90) because Windows applications use GPU scaling, therefore OBS is supposed to detect 60hz or whatever refresh rate it falls to (59.98, 59.99, etc) . The video preview is choppy because you are not observing 60hz, but you are observing a non-refresh rate of 72hz, 80hz, or 100hz. 60hz is placed as a standard refresh rate, so I think it's a Windows 10/driver development bug....not OBS.

Feel free to comment or correct, because I was testing this with OBS all day today.
 

wailk

New Member
Hello, i have the same problem and i went to as far as getting my old GPU (GTX 960) installed with my new GPU (GTX 1070). Non SLI of course.

So i hooked up my GTX 960 to my 60hz monitor and my GTX 1070 to my 144hz monitor. THIS DID NOT FIX IT!
I was sure it would but it did not, so i think getting a WHOLE NEW PC is not a good idea to try and fix this issue.

I hope this situation gets solved as it is very frustrating to me.
 

Juanescacha

New Member
have the same problem, PC specs : i7 9700k Gtx 1080 16 gb ram ssd m.2 500gb
i have primary monitor 144hz and second one 60hz, and when im recording in OBS or streaming i dont feel 144, even my Game Fortnite its 144 fps on the counter constant, i dosnt fell to bad as 60 but fells 100hz so... i first think it about cpu or gpu stress but men, they are very relax doing the tasks in Msi After bourner so. i will check full screen, disabling live prview, enabling/disabling game bar and Activating Gsync ( my main monitor has free sync but gsync compatibility recently) couse when i dont have obs open i fell the fluid of 144hz its weird you know
 

Juanescacha

New Member
i think disabling live preview in obs, not having chrome with videos open in your second monitor and disabling vertical sync will help
 

morgun_ua

New Member
I think it's time to bring this discussion back. I've installed Win 10 1903 update and games no longer stutters having playing videos on my second (60Hz) screen. Blizzard and discord clients with animated banners that were causing stutters in 1809 now working flawlesly.

OBS with preview mode is still causing issues! Ans this need to be investigated.
 
Top