Zoom sees v42lsink virtual webcam but doesn't display video

Peter N

New Member
I've set up v4l2loopback as root in PCLinuxOS 2020 with OBS-Studio and obs-v4l2sink (both at version 25.0.8-4) with

modprobe v4l2loopback devices=1 label="OBSoutput" exclusive_caps=1

and am using OBS-Studio/v4l2sink to select video camera output running in a Firefox window to be fed to Zoom. The 'Path to V4L2 Device' in Tools is shown as /dev/video0 However, while Zoom sees a webcam which it identifies as 'Dummy video device (0x0000)' the Zoom screen is totally black. I've tested the output from OBS-Studio in Qt V4L2 video capture utility, and the video is clearly there. It feels a bit 'so near and yet so far' so if anybody can help a relative beginner to work out what needs to be done, I would be very grateful


New Member
Hi, in my case I used v4l2loopback in order to connect my DSLR through a "hack" of the Lenkeng LKV373 extender (like these, found by Danman's blog: link) and also wanted to make my device visible through zoom as a webcam.

So, I tried to achieve this by adding a label to my camera in modprobe, just like you, but I changed the number in the device to /dev/video2:

modprobe v4l2loopback card_label="camera1" video_nr=2 exclusive_caps=1

Then, the device was accesible by Zoom, but still no video.

I thought that the possible cause was that the original input format (yuv420 in my case) is not compatible with the expected input from a standard webcam (they normally input the video as H264, divx, mjpeg or similar compressed formats), and thought maybe a previous conversion could help. So, I tried some formats without success until I found that the best available to handle this was:

ffmpeg -i udp://@ -codec:v mjpeg -qscale 1 -codec:a copy -f v4l2 /dev/video2

So, as you can see, video was converted through ffmpeg and sinked to v4l2loopback, and was able to send to Zoom with great quality (in this case, 1080p). It still has a near-second delay (because of the time required for conversion), maybe using a hardware-assisted solution like videocard acceleration (Cuda or OpenCL) may help for lowering the latency.


New Member
I have the same problem, only streaming a black square. I have tried countless tutorials, asked on all the forums and reddits and discords possible.

It just seems OBS wasn't able to make their software work on Linux.

When i enter your ffmpeg command and I try to start the stream on OBS, in gives me: "device open fails".