v4l2-sink shows only Black Screen


New Member
Since I moved to Linux(I'm using elementaryOS), I seek OBS Plugin that could replace OBSVirtualCam Plugin on Windows,
and I found v4l2-sink from this forum thread.

I installed and try to use it into Google Hangouts and Discord, or Zoom, but Google Hangouts won't show it (In the Chromium Setting, too)
In the Discord and Zoom, I selected 'Dummy Video Devices (0x0000)' but nothing shows on camera.

For finding my virtual camera, I run v4l2-ctl --list-devices and got this :

Dummy video device (0x0000) (platform:v4l2loopback-000):

LG HD WebCam: LG HD WebCam (usb-0000:00:14.0-7):

And I mapped v4l2-sink input to /dev/video2.
If i test this on VLC Media player with v4l2://dev/video2, It works! (Like the screenshot below.)
스크린샷, 2020-09-16 13-23-38.png

But Not on Zoom, Discord, and doesn't shows on Chromium. two screenshot files are Zoom, and Discord.
2020-09-16 13.27.06에 스크린샷 찍기.png
2020-09-16 13.28.22에 스크린샷 찍기.png

And also I tried sudo modprobe v4l2loopback exclusive_caps=1, and it won't work, too.

Is there a solution for this?

I'm Using elementaryOS 5.1.7 Hera (Based on Ubuntu 18.04.4LTS), and my Kernal is Linux 5.3.0-61-generic.
My desktop Environment is Pantheon (As default on eOS)