Question / Help There is something wrong with AMD VCE encoding: fast forward\jump is really bad


regardless of a container. MKV is especially bad. mp4 is a bit better.

When you try to fast forward or jump forward it uses CPU VERY intensively and it takes generally 10-15 seconds to jump forward.Sometimes it doesn't even work (MKV)

Nothing like this happens with afterburner\bandicam AMD VCE encoding.

PS it Would be really nice if we had access to advanced settings of AMD VCE encoder in OBS multi platform version( afterburner is very customizable in this regard via config files).

Try and change the keyframes setting. Default is 2 seconds, but you might've set it higher. Higher time between keyframes = longer seek-times, but smaller files.


The thing is even setting keyframes to 300 in other recording tools doesn't produce this effect...And OBS doesn't even allow keyframes to be set higher than 20 even for x264 codec.
So, say,
tool X: AMD VCE\x264. 300 frames- normal seek times
OBS -> keyframes, say, auto,(no more than 20) AMD VCE(I haven't checked x264)-> atrocious seek times within mkv container.
You say "no more than 20", but those are seconds you are entering in OBS. Not "number of keyframes". Still 300 = a keyframe every 10 seconds at 30fps. So if that ends up fine... I got nothing.

Then again, Sony Vegas creates an index when importing media, so it could be due to that that I'm not having this issue...