Strange Echo streaming with Focusrite 18i20

LegendaryAction

New Member
Hello,

We do a little humble D&D show. We use a Focusrite 18i20 streaming 8 mono channels. We are having an issue with a delay/echo on our mics. We have ruled out all the simple answers like stream being open or a audio feed making its way back into the presentation (as far as we can tell)

We have found if we close the stream and reset that the audio echo goes away.

OBS Studio 15.0.8

Focusrite
Firmware 1644
Driver:4.65.5

Mics
Rhode NTG-1
DPC Latency checker is in the green even when running test streams through the network

System Specs
intel i7 5960x
32gb RAM
nvme m.2 SSD
Nvidia TITAN X in sli
black magic 4k capture card
(x2 Cam link 4k)

We are still trying to figure this out. we are not running any games or heavy loaded stuff short of the capture and encoding of the video feeds.

Example youtube video, echo in the beginning and corrected sound on the back end.
 

Attachments

Sukiyucky

Member
If its not echo, but more weird sound related:
  1. feedback coming from one of you mics.
  2. Feedback coming from the speakers being too close to the mic.
  3. Voltage feedback from the cables.
  4. Gain level on the mic being set too high above unity.
Most of the tmes its #4.

If its echo, check:
  1. That your webcam mic is muted in OBS
  2. Your studio monitors are muted in OBS to avoid open mics picking them up and duplicating.
 

MarkOakley

New Member
Just ran across this:


Audio Input/Output Capture

WARNING: Audio Input/Output Capture source can cause an echo effect if you have the same device selected in Settings -> Audio. If you plan on adding audio devices directly to your scenes, make sure they are disabled globally first.

This source allows you to add an audio input or output device (i.e. microphone or headset repsectively) to a specific scene. Simply pick the device you wish to capture, and the audio from that device will be captured when the source is active. These sources can be useful if you only want specific audio devices active in specific scenes, rather than globally through all of OBS.

~ https://obsproject.com/wiki/Sources-Guide

~~~~~~~~~
I've been running a dual mic, multi-camera setup, and have over the course of months tweaked things down to nearly perfect, but for some reason I'm still getting these weird echo moments, where there's a hundredth of a second offset between the two mics, creating an echo effect. -It seems to happen regularly, every six minutes or so, lasts for about fifteen seconds before returning to normal. It can be edited in Davinci Resolve, by clipping the offending 15 second spot in one of the audio streams and shifting it by a hundredth of a second to line up, but this is tedious for a 2 hour podcast.

I'm hoping to get into the studio tomorrow to try out the above tweak.

So far I've tried, and found a lot of problem-solving success with the following tactics:

1. Make sure all capture cards are the same make and model, running the same drivers. This vastly simplifies troubleshooting. This is especially true when setting the microsecond delay to sync up audio and video across all channels.

2. Make sure all the mics and equipment and drivers, etc., are sampling on the same frequency. (I've chosen 48 kHz). If there is any mis-matching across the system, weird problems crop up.

3. Make sure WiFi is turned off and cellphones are in airplane mode during interviews. EM from these devices can create static events in sensitive mics. (This was driving me and my tech crazy until we worked out the source of the problem.) We now use wired internet when it is needed.

4. Give the bulk of CPU processor priority to OBS. The computer doing the recording should be a single task machine and nobody can be allowed to mess with it or update anything. Once it's working, do not touch! To this end, we uninstalled all unnecessary software, locked down anything that might auto-update, turned off all unnecessary background processes. This includes, especially, virus scans! (The amount of crap trying to run in the background in Windows 10 is ridiculous). If any of these systems are running without permission, it can easily result in choppy video.

5. Physically unplug the internet during recording. -We use a version of Windows 10 which never phones home and never tries to update itself. (This was very difficult, but after a lot of research, we were able to achieve it.) But just to be safe, we've decided to kill the internet connection to the OBS machine altogether. If we want to include webpages as inset screens in video, then it's safest to have a second computer outputting HDMI to a capture card and integrate that as a separate video source.


In the beginning, our audio was garbage and no single solution solved all the problems. It's been a matter of carving down the garbage. We're about 95% there. I'm hoping that the little nugget at the top of this post will put us over the top.
 
Top