Bug Report [SOLVED] Window Capture Black Screen

Monmon

New Member
Good day,

I'm having trouble setting up Window Capture (Xcomposite) on my desktop. All I'm having is a black screen and it captures the mouse but if I add Screen Capture (XSHM) everything works. Although in my laptop Window Capture works fine and the os is also xubuntu 16.04.

My system is:
OS: Xubuntu 16.04
Proc: AMD FX 8150
GPU: Sapphire 7750
RAM: 8GB

Thank you in advance.

EDIT: Solved by checking "Use alpha-less texture format (Mesa workaround)
 
Last edited:

gr78erw

New Member
I updated my laptop to Ubuntu 16.04 and I now have this same problem. Screen capture works but window capture is all black. On Ubuntu 15.10 everything worked fine.

System:
Processor: AMD E1-2500 APU with Radeon(TM) HD Graphics
Physical Memory: 3219MB Total
Kernel Version: Linux 4.4.0-21-generic
Distribution: "Ubuntu" "16.04"
OBS 0.14.1 (linux)

My log file is full of these errors messages:
Code:
error: glCopyImageSubData failed, glGetError returned 0x502
error: device_copy_texture (GL) failed
Seems like an OpenGL error so I assume it's a driver issue? But as far as I can tell I just have a newer version of the same Mesa driver on 16.04. Here's the outputs of 'glxinfo | grep OpenGL' from both Ubuntu 16.04 and 15.10:

Ubuntu 16.04
Code:
$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD KABINI (DRM 2.43.0, LLVM 3.8.0)
OpenGL core profile version string: 4.1 (Core Profile) Mesa 11.2.0
OpenGL core profile shading language version string: 4.10
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 11.2.0
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.2.0
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Ubuntu 15.10
Code:
$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD KABINI (DRM 2.43.0, LLVM 3.6.2)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.0.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 11.0.2
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.0.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Any help would be greatly appreciated!
 

Attachments

giacecco

New Member
NOT SOLVED!!!

I've tried the "Use alpha-less" option with OBS 0.14.1 but I still see black windows. I'm using Fedora 23 on a Lenovo T450s (Intel graphics). Is there some other trick I should know about? Capturing the entire screen works fine.
 

Leseratte10

New Member
I'm using Ubuntu and I have the same issue. With OBS 0.13.1, the window was red, with the newest 0.14.1 it is black. The cursor is visible, but the window itself not, no matter if I enable or disable the Mesa fix.

Any idea why? Using screen capture and cutting it is not a good solution when I need to re-order my windows ...
 

KynikossDragonn

New Member
I had to do the following:

$ export MESA_EXTENSION_OVERRIDE="-GL_ARB_copy_image"

in order to get Xcomposite to work, this masks away that extension so OBS Studio can't even access or know it's there, I wasn't expecting this to work but it does for me.

I'm running Linux Mint 17.3 Rosa and a AMD BARTS (HD 6870), my driver comes from the ppa:oibaf/graphics-drivers

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD BARTS (DRM 2.40.0, LLVM 3.8.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.3.0-devel (git-9f8867d 2016-05-14 trusty-oibaf-ppa)
OpenGL core profile shading language version string: 3.30
 

raptur

New Member
Neither fix (checking the alpha-less option or the MESA_EXTENSION_OVERRIDE export), together or in isolation, works for me on Arch Linux with an Nvidia GTX 750 Ti, nvidia driver 364.19, and mesa 11.2.1
 

Srinath

New Member
Same as raptur here. On Arch:
GeForce GT 620
nvidia 364.19-3
obs-studio 0.14.2-1 (also tried obs-studio-git)
mesa 11.2.2-1
 
Top