OBS super laggy after changing output settings from simple to advanced

Salulo

New Member
Hi! I've been using OBS for almost a month now and haven't run into any trouble. However, today I learned that in order to have two audio tracks (one for game audio and one for my mic) I had to change the output settings. I followed the instructions on a youtube video on how to do it. So I went to settings>output>output mode and changed it from simple to advanced so I could be able to set more than one audio track. After that, every recording is super laggy, as if I was trying to play witcher in utra settings on a 1970s computer. The fps of the recording must have been like 10-15. I tried changing the output mode back to simple and boom, the recording were perfect as before. So, what may be the problem?
 

Attachments

carlmmii

Active Member
Switch to Nvenc for your encoder, and turn off Psychovisual Tuning. That will fix the simple vs advanced issue. (you were trying to use x264 in advanced mode, which overloaded your CPU)
 

Salulo

New Member
Switch to Nvenc for your encoder, and turn off Psychovisual Tuning. That will fix the simple vs advanced issue. (you were trying to use x264 in advanced mode, which overloaded your CPU)
Thanks for your reply! I had tried that, the thing was that using Nvenc caused the recordings to be super pixelated, that's when I switched to x264. I just tried again as you said, but again, good fps, super pixelated. Anyways, if I can't get a solution I'll just go back to the simple output mode, it's not extremely essential to have 2 audio tracks.
 

carlmmii

Active Member
Make sure your rate control is set to CQP, and set your CQ Level depending on the quality you want (lower is better, but larger file size). From the simple recordings, that was using a CQ Level of 20, so use that as your baseline.
 
Top