Question / Help OBS Studio 24.0.6 (24.0.6) macOS Catalina crash

BobsTheDude

New Member
1. Start OBS Studio by double click the icon, wait about 10 minutes then crash.
2. Start OBS Studio via command line(open /Applications/OBS.app --args -picture), wait about 10 minutes then crash.

Crash Log [click]->Pastbin

Configuration:
  • macOS Catalina Version 10.15.2 (18C57)
  • Mac mini (2018)
  • 3 GHz 6-Core Intel Core i5
  • 16 GB 2667 MHz DDR4
  • Intel UHD Graphics 630 1536 MB
  • OBS Studio 24.0.6 (24.0.6)
  • OBS Link 1.0.1 (159)
  • OBS NDI 4.7.1

Error:
Segmentation fault: 11 IOHIDLib
 

dodgepong

Administrator
Forum Admin
Does it still crash if you just run OBS normally, not from the command line?

Do you happen to know if you were pressing a hotkey at the time of crash, or entering in a system password?
 

Arkaeic

New Member
I am experiencing this same problem. Crashing with OBS running normally and not from command line. Also crashing if the command line is being used. No hotkeys configured for use. OBS seems to run normally up until the point where PS4 is turned on and OBS Link engages Display Capture. As soon as Display Capture becomes active, OBS crashes. OBS can be used successfully in all other scenes, including with Webcam and active mic.

MacOS Catalina 10.15.2 (19C57)
Mac mini (2018)
3.2 GHz 6-Core Intel Core i7
64 GB 2667 MHz DDR4
Radeon RX 580 8 GB
OBS Link 1.0.1 (159)
OBS NDI 4.7.1

Tried to revert to the fix in https://obsproject.com/forum/threads/macos-10-15-catalina-support-status.111343/ but no resolution.
 

Attachments

  • 2019-12-18 21-33-38.txt
    11 KB · Views: 50
  • 2019-12-18 21-37-38.txt
    5.5 KB · Views: 17
  • 2019-12-18 21-39-38.txt
    12 KB · Views: 17
  • 2019-12-18 21-52-30.txt
    11.1 KB · Views: 16
  • 2019-12-18 21-56-52.txt
    5.5 KB · Views: 13
  • 2019-12-18 21-59-08.txt
    12 KB · Views: 20

BobsTheDude

New Member
I have tried both the command line and the normal starting of OBS. I should have checked this before opening but it seems when typing in my password it happens. OBS can be running, I go to Security & Privacy, make any change that requires me to type in my password to unlock padlock and OBS will crash. Also crashes when tying in password to unlock screen saver.
 

Arkaeic

New Member
Are you sure that is a Radeon RX 580 8 GB in your mac Mini and not an Intel UHD Graphics 630? I want one of those Mac Mini's ;)

Quite certain- though, it's not in it, but rather next to. Everything runs through my GPU - I need it for video editing and streaming.
 

StreamPanel

New Member
Similar problem as mentioned by other 2 users. What we all have in common: 6-core intel CPU, Catalina, latest OBS. I also have an rx 580, but the first guy doesnt, so I dont know if it matters. Same issue, it crashes when im prompted for a password by the OS.
 
Top