OBS' GUI completely messed up

Zom-B

New Member
I reinstalled Linux (went from Ubuntu 18.04 to Mint 20.04, both using unity-desktop) and now OBS looks like this. I have no idea what's going on. It worked before with 27.1, but now both 25.0 and 27.2 are unusable.

1660162823502.png


Curiously, and at the same time worryingly, all visible controls are also functional.
The Scene Properties dialog is even more interesting, with triple the amount of controls, and all of them functional:
1660162901702.png

It gets even weirder with the Settings dialog, which is completely fine and has no strangeness whatsoever.
 

Attachments

  • 2022-08-10 22-11-26.txt
    7.9 KB · Views: 3
Last edited:

Neigdoig

New Member
I've not used the Unity desktop, because of how unstable it is. I'd recommend something like GNOME, KDE, Xfce, or Cinnamon (yes, there is an Ubuntu spin with Mint's desktop, Cinnamon). Those four environments worked very well for my needs as a content creator.
 

Zom-B

New Member
Sorry I didn't see the reply (and there was no email either, even though this thread is 'watched')

I don't know what you mean, Unity has been stable since at least 2018. I need certain features of it so I can't use anything else. (Believe me, I tried all those you mentioned, and more). I have lots and lots of applications and none show any issues (both normal and HiDPI programs).

I just remember smplayer had a similar issue and it was solved by disabling HiDPI support in the settings. (Leaving it on, even when set to 1.0 causes this.) It's caused by bugs in QT 5.6.
 
Top