Resource icon

New ClockSource.Lua script 2020-08-17

DCStrato

Member
DCStrato submitted a new resource:

New ClockSource.Lua script - Updated Analog Clock Lua Script offering 4 additional clock faces and two additional hand options

Updated Analog Clock Lua Script offering 4 additional clock faces and two additional hand options beyond the original face and hands. Also an option to increment second hand in 1/4 second increments. Extract to Program Files/obs-studio/data/obs-plugins/frontend-tools/scripts. Add New-clock-source.lua script.

Read more about this resource...
 

lcalder

Member
original clock-source works by adding a "Lua Clock" source, but this one doesn't do anything... Also no options are given/shown in the tools->scripts dialog... how to change clock faces?
 

DCStrato

Member
It is mostly the exact same code from Lua Clock and works exactly the same way. However, there should be two options for each clock-source you add to scenes that allow each to choose Face Style and Hand Style. The new lua file goes in C:\Program Files\obs-studio\data\obs-plugins\frontend-tools\scripts, and the new clock source files in C:\Program Files\obs-studio\data\obs-plugins\frontend-tools\scripts\clock-source. Add a Lua-Clock source to a scene as before, and then select face and hand options as properties for that source.

clockcapture.png
 

BoXjumP

New Member
I have no idea but it does not work I even uninstall and reinstated obs. but it still doesn't work.
can someone help me?
 

Videobuff

Member
If the issue is only caused by an overwrite, might be worth try reinstalling the LUA clock with multiple faces script again….
 

DCStrato

Member
Banyarola, I loaded the new version of OBS and didn't get a problem with the new clock script. I can't seem to reproduce your error.
Did you try loading JUST a new clock source into a single scene? That crash log might help with the isolation.

Thanks
DC
 

Banyarola

Active Member
Like I said DC, I have tried everything. I deleted the old clock lua and added the new one and none of the new clock faces are in the properties list when the clock is source is selected in OBS. They are in the folder but they don't show in OBS..
Everything was fine until the last update.
The log is in my first post.
 

DCStrato

Member
Like I said DC, I have tried everything. I deleted the old clock lua and added the new one and none of the new clock faces are in the properties list when the clock is source is selected in OBS. They are in the folder but they don't show in OBS..
Everything was fine until the last update.
The log is in my first post.
Thanks Banyarola,
 

DCStrato

Member
Can't find anything that changed. Attached is the same script I am using to test with. Just so we can be sure we are on the same page.

D.C.
 

Attachments

  • newclocksource.zip
    1.5 KB · Views: 81

Banyarola

Active Member
Can't find anything that changed. Attached is the same script I am using to test with. Just so we can be sure we are on the same page.

D.C.
Lets just forget it...Thanks for the effort...I'll just keep using the original one...
Thanks for the zip but, nothing personal, I don't d/l and open ZIP files..
 
Top