Question / Help My Desktop Audio isn't working properly...

MajorFunky

New Member
My microphone audio is working perfectly but my desktop audio sounds like it's in a tunnel and doesn't sound good at all.
These are my audio settings:


I can send the audio file because the forums don't allow videos ;-;

can anyone help me?
 

Narcogen

Active Member
Check what audio device is set for monitoring in Settings > Advanced > Audio Monitoring, and which sources (if any) are set to Monitor Only or Output and Monitor in Edit > Advanced Audio Properties.

Echoes like this can be caused by having OBS monitor a default system audio device that's being captured, or by having OBS set to send its monitoring audio to the default system device.

Also check that the sampling rate in OBS (set to 44.1 khz in your screencap) is the same as that being used by your Windows devices as set in their Properties pane in the Sound control panel.
 

MajorFunky

New Member
I can't turn off my Game Mode because there is no button but everything else is off. but I'm not quite understanding how to do this,"
Check what audio device is set for monitoring in Settings > Advanced > Audio Monitoring, and which sources (if any) are set to Monitor Only or Output and Monitor in Edit > Advanced Audio Properties."
 

Narcogen

Active Member
The lower screen capture says you have set your audio monitoring device to your default device.

If you are also capturing from that device, you will get echo.

"which sources (if any) are set to Monitor Only or Output and Monitor in Edit > Advanced Audio Properties."

This means go to the Edit menu, choose the Advanced Audio Properties item, and in the list their of your audio devices, check which are set for one of the following options:

Monitor Only
Output Only
Monitor & Output

Sources that are set for "monitor only" will not be heard in your stream, but will be sent to your monitoring device (in your case, the default device) and sources that are set for "monitor & output" will both be heard in your stream AND be sent to the monitoring device.

Start by making sure monitoring is NOT on for any device. If set that way you can hear audio from your computer normally and it can be heard in the stream without echo, then you're set.

If you can't hear anything, you may need to turn monitoring on, but if you're trying to capture your default device you can't also monitor to it-- this will cause an echo. For that kind of setup you generally need a virtual device, or a second device to use for monitoring.
 

MajorFunky

New Member
I checked the Advanced Audio Properties and both of them said 'Monitor Off'

Sorry for wasting your time, I know I'm being a hassle.
 
Last edited:

Narcogen

Active Member
Okay, so the problem is not monitoring.

Two other potential problems: You're using a 7.1 surround device, but OBS is set to Stereo;
Or you have a setting mismatch between OBS Audio Sample Rate, which is currently set to 44.1, and some other device.

Also check the Settings > Output > Audio tab to see what bitrates you have selected for your audio devices.
 

MajorFunky

New Member
I fix some settings and change my headset to stereo and the desktop audio is working fine, thank you for all your help and time.
I really do appreciate it.
 
Top