Question / Help Mic Audio picked up fine in recording, in game audio not captured/very low

#1
I've finally gotten my recordings all set to where there is almost no lag, and I can actually record things. Now I'm having trouble with the audio, which hasn't happened before.

In my recordings my voice and any noise near the mic (my readjusting, the mouse moving on the mouse pad) is picked up loud and clear. The in game audio though, is so low that it isn't even understandable. It's so tiny that my voice or even a mouse click covers it. None of the music can be heard and the characters speaking are completely not understandable. I think it's just my mic picking up the game sounds coming from my headphones.

This happens with headphones on. When I take my headphones off the recordings do pick up audio, but it's more like it's recording the audio because my mic is picking it up.

Here's my latest log: https://obsproject.com/logs/zra8_g86794gyXtE
 
#2
16:29:19.533: WASAPI: Device 'Speakers (Realtek High Definition Audio)' initialized
16:29:19.612: WASAPI: Device 'Microphone (Realtek High Definition Audio)' initialized

Are the speakers above your default windows system device? Because if they aren't, the only audio you'll get here is from your microphone.
 
#3
They should be the default windows device, yes. I tried putting the speakers on default as well and had the same issue.

I did a few recordings today and sometimes I'm getting no in game audio, and other times I'm getting audio in the recording and it seems fine until suddenly both the in game audio and my voice speed up to a crazy degree and it freezes.

I think I just really need to get a more powerful device, this poor little laptop wasn't meant for this.
 
#4
That sounds like sample rate mismatch, although I suppose it could be related to high CPU load.

16:54:06.729: adding 42 milliseconds of audio buffering, total audio buffering is now 85 milliseconds
16:54:06.737: adding 42 milliseconds of audio buffering, total audio buffering is now 128 milliseconds

17:02:56.007: Stopping recording due to hotkey
17:03:16.981: [ffmpeg muxer: 'adv_file_output'] Output of file 'C:/Users/Emelia/Videos/2019-02-09 16-34-21.mp4' stopped
17:03:16.981: Output 'adv_file_output': stopping
17:03:16.981: Output 'adv_file_output': Total frames output: 51431
17:03:16.981: Output 'adv_file_output': Total drawn frames: 51907 (52059 attempted)
17:03:16.981: Output 'adv_file_output': Number of lagged frames due to rendering lag/stalls: 152 (0.3%)
17:03:16.981: ==== Recording Stop ================================================
00:55:47.421: Max audio buffering reached!
00:55:47.428: adding 832 milliseconds of audio buffering, total audio buffering is now 960 milliseconds

The increasing audio buffering is usually caused by a system that is being overloaded.

The pitch shift and other issues could be that, or a problem of having audio devices at different sample rates. Check OBS' sample rate setting in Settings > Audio as well as the sample rates in the WIndows audio device settings for your mic and speakers and make sure all are the same.
 
#6
Not sure. You don't have rendering lag, so GPU capacity is not really the issue. You could try reducing your canvas resolution to 720p.

You're using QuickSync, so it's not encoding that is loading the CPU.

16:29:20.059: Loaded scenes:
16:29:20.059: - scene 'Scene':
16:29:20.060: - source: 'Desktop Capture' (monitor_capture)
16:29:20.060: - source: 'Game Capture' (game_capture)


I would separate these into two scenes, having game and display capture in the same scene can negatively impact performance.
 
Top