LUA Comment Removal

LUA Comment Removal 0.2

DA_iNFAMOUS_DRE

New Member
I am sorry to hear that DA_iNFAMOUS_DRE, but let me see if I can help. If you have a moment, could you please help me by describing what obstacles or issues you encountered and I will do my best to help address and resolve them.
Hi, sorry for the late reply. I had deleted the files since i couldn't get it fixed, but i just redownloaded it and added it back to hopefully try to fix it. This is the error i get after adding them as scripts. The non edited version and the version after i put it through "Remove Comment".


[Find Source Location.lua] Error loading file: ...-plugins/frontend-tools/scripts/Find Source Location.lua:8: unexpected symbol near '<'
[Find Source Location no-comments (03.10.2022.14.49.40.957).lua] Error loading file: ...ource Location no-comments (03.10.2022.14.49.40.957).lua:7: unexpected symbol near '<'


Both are blank and don't display the options to find sources, saying "No Properties Availible". Also i'm on OBS 28.0.2. It used to work a few months ago, but stopped. I'm guessing it's a OBS 28.0 issue and broke like the pluggins broke for this update
 

GrumpyDog

Member
Hi, sorry for the late reply. I had deleted the files since i couldn't get it fixed, but i just redownloaded it and added it back to hopefully try to fix it. This is the error i get after adding them as scripts. The non edited version and the version after i put it through "Remove Comment".


[Find Source Location.lua] Error loading file: ...-plugins/frontend-tools/scripts/Find Source Location.lua:8: unexpected symbol near '<'
[Find Source Location no-comments (03.10.2022.14.49.40.957).lua] Error loading file: ...ource Location no-comments (03.10.2022.14.49.40.957).lua:7: unexpected symbol near '<'


Both are blank and don't display the options to find sources, saying "No Properties Availible". Also i'm on OBS 28.0.2. It used to work a few months ago, but stopped. I'm guessing it's a OBS 28.0 issue and broke like the pluggins broke for this update
I teseted and found an issue. Please see if the update resolves your issue.
 

DA_iNFAMOUS_DRE

New Member
I teseted and found an issue. Please see if the update resolves your issue.
Hi, thanks for your help, i added the updated remove-comments.lua but it's now giving me a similar error and shows no properties in OBS, it was at least giving me the option to use it in the previous version. I also noticed it with the Stop Watch Lua that was recently updated from you (that i just updated to now does the same thing)



I currently have 18 scripts & only these 3 produce this error, I’m also on OBS 28.0.3 if that matters / helps.



[Find Source Location.lua] Error loading file: ...-plugins/frontend-tools/scripts/Find Source Location.lua:8: unexpected symbol near '<'

[Remove Comments.lua] Error loading file: ...a/obs-plugins/frontend-tools/scripts/Remove Comments.lua:8: unexpected symbol near '<'

[Stop Watch.lua] Error loading file: ...o/data/obs-plugins/frontend-tools/scripts/Stop Watch.lua:8: unexpected symbol near '<'
 

GrumpyDog

Member
Try this, open the script in an editor and find the variable 'desc' and then directly after that on a new line, add the following line:

Lua:
desc  = ''

Alternatively, delete the content of 'desc'

Let's see if that fixes the issue.
 

DA_iNFAMOUS_DRE

New Member
Try this, open the script in an editor and find the variable 'desc' and then directly after that on a new line, add the following line:

Lua:
desc  = ''

Alternatively, delete the content of 'desc'

Let's see if that fixes the issue.
Hi, I tried both methods but the same error still pops up
 

GrumpyDog

Member
Okay, please take all 3 files you use that gives you the errors, zip them and attach them in here or in a DM.

Also, can you please let me know what OS version you use.
 
Last edited:

DA_iNFAMOUS_DRE

New Member
Okay, please take all 3 files you use that gives you the errors, zip them and attach them in here or in a DM.

Also, can you please let me know what OS version you use.
Hi, yes here are the 3 scripts. Also, I'm on Windows 11.
 

Attachments

  • Scripts.zip
    230.9 KB · Views: 11

GrumpyDog

Member
Hi, yes here are the 3 scripts. Also, I'm on Windows 11.

None of the files contained in this zip file are valid LUA Script Files.


You need to hit the "RAW" button and then right click and then save as with extenstion ".lua"

1665137949818.png


See this for help

 
Last edited:

DA_iNFAMOUS_DRE

New Member
None of the files contained in this zip file are valid LUA Script Files.


You need to hit the "RAW" button and then right click and then save as with extenstion ".lua"

View attachment 87404

See this for help

Thank you so much for your help, that fixed all of them. I was right clicking and saving them when updating all my plugins. I forgot i had to save them by going to raw first!
 
Top