Question / Help Live streaming on YouTube using Skype and OBS

mvalente429

New Member
I followed your instructions and I get a black screen for the NDI despite selecting the correct source. Why is that?
 

MediaFlamengo

New Member
I followed your instructions and I get a black screen for the NDI despite selecting the correct source. Why is that?
If you select Bandwidth = Audio Only, you will see a black screen.
If you select Bandwidth = Highest or Lowest, you will see a box per call inside the black screen, since it is a video call

Please ensure you do have a valid NDI stream that can be captured by OBS.

Test it by installing Skype for content creators to generate NDI stream, and follow the instructions below:

4/ Skype for content creators configuration
4.1/ To ensure Skype produces NDI streams to be consumed by OBS, some host computers might need to fire up Skype with "--disable-gpu --disable-gpu-compositing".
Create a Skype shortcut on your host computer desktop and modify its properties as follows:
Target:
"C:\Program Files (x86)\Microsoft\Skype for Desktop\Skype.exe" --disable-gpu --disable-gpu-compositing
The above modification is only required if Skype running on your host computer is unable to produce NDI streams to be consumed by OBS.

Hope This Helps (HTH)
 
Last edited:

mvalente429

New Member
Sorry, I did that and still get a black screen.

Here's my log:
06:23:12.493: CPU Name: Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
06:23:12.493: CPU Speed: 3392MHz
06:23:12.493: Physical Cores: 4, Logical Cores: 8
06:23:12.493: Physical Memory: 16337MB Total, 7001MB Free
06:23:12.493: Windows Version: 10.0 Build 17134 (revision: 885; 64-bit)
06:23:12.493: Running as administrator: false
06:23:12.493: Aero is Enabled (Aero is always on for windows 8 and above)
06:23:12.493: Windows 10 Gaming Features:
06:23:12.493: Game DVR: On
06:23:12.495: Sec. Software Status:
06:23:12.497: Windows Defender Antivirus: disabled (AV)
06:23:12.497: AVG Antivirus: temporarily disabled (AV)
06:23:12.511: AVG Antivirus: disabled (FW)
06:23:12.511: Windows Firewall: disabled (FW)
06:23:12.512: Windows Defender Antivirus: disabled (ASW)
06:23:12.512: AVG Antivirus: temporarily disabled (ASW)
06:23:12.512: Browser Hardware Acceleration: true
06:23:12.512: Portable mode: false
06:23:12.626: OBS 22.0.2 (64-bit, windows)
06:23:12.626: ---------------------------------
06:23:12.683: ---------------------------------
06:23:12.683: audio settings reset:
06:23:12.683: samples per sec: 44100
06:23:12.683: speakers: 2
06:23:12.684: ---------------------------------
06:23:12.684: Initializing D3D11...
06:23:12.684: Available Video Adapters:
06:23:12.686: Adapter 1: NVIDIA GeForce GT 640
06:23:12.686: Dedicated VRAM: 4249288704
06:23:12.686: Shared VRAM: 4270473216
06:23:12.686: output 1: pos={0, 0}, size={1920, 1080}, attached=true
06:23:12.690: Loading up D3D11 on adapter NVIDIA GeForce GT 640 (0)
06:23:12.767: D3D11 loaded successfully, feature level used: 45056
06:23:13.450: ---------------------------------
06:23:13.450: video settings reset:
06:23:13.450: base resolution: 1920x1080
06:23:13.450: output resolution: 1920x1080
06:23:13.450: downscale filter: Bicubic
06:23:13.450: fps: 30000/1001
06:23:13.450: format: NV12
06:23:13.450: YUV mode: 601/Partial
06:23:13.453: Audio monitoring device:
06:23:13.453: name: Default
06:23:13.453: id: default
06:23:13.453: ---------------------------------
06:23:13.455: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/chrome_elf.dll' not found, loading of module failed
06:23:13.457: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
06:23:13.489: [AMF] AMF Test failed due to one or more errors.
06:23:13.489: Failed to initialize module 'enc-amf.dll'
06:23:13.501: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libcef.dll' not found, loading of module failed
06:23:13.502: LoadLibrary failed for '../../obs-plugins/64bit/libEGL.dll': The specified procedure could not be found.
06:23:13.502: (127)
06:23:13.502: Module '../../obs-plugins/64bit/libEGL.dll' not loaded
06:23:13.503: Required module function 'obs_module_load' in module '../../obs-plugins/64bit/libGLESv2.dll' not found, loading of module failed
06:23:13.504: [obs-browser]: Version 2.1.5
06:23:13.508: NVENC supported
06:23:13.510: [obs-ndi] hello ! (version 4.6.0)
06:23:13.510: [obs-ndi] Trying 'C:\Program Files\NewTek\NewTek NDI 3.8 Tools\Runtime'
06:23:13.510: [obs-ndi] Found NDI library at 'C:/Program Files/NewTek/NewTek NDI 3.8 Tools/Runtime/Processing.NDI.Lib.x64.dll'
06:23:13.513: [obs-ndi] NDI runtime loaded successfully
06:23:13.520: [obs-ndi] NDI library initialized successfully (NDI SDK WIN64 18:40:40 May 10 2019 3.8.2.0)
06:23:13.539: Tried to register obs_output_info with size 184 which is more than libobs currently supports (176)
06:23:13.539: Output ID 'ndi_output' not found
06:23:13.539: Failed to create output 'NDI Main Output'!
06:23:13.539: Output ID 'ndi_output' not found
06:23:13.539: Failed to create output 'NDI Preview Output'!
06:23:13.591: VLC found, VLC video source enabled
06:23:13.595: No blackmagic support
06:23:13.599: ---------------------------------
06:23:13.599: Loaded Modules:
06:23:13.599: win-wasapi.dll
06:23:13.599: win-mf.dll
06:23:13.599: win-dshow.dll
06:23:13.600: win-decklink.dll
06:23:13.600: win-capture.dll
06:23:13.600: vlc-video.dll
06:23:13.600: text-freetype2.dll
06:23:13.600: rtmp-services.dll
06:23:13.600: obs-x264.dll
06:23:13.600: obs-vst.dll
06:23:13.600: obs-transitions.dll
06:23:13.600: obs-text.dll
06:23:13.600: obs-qsv11.dll
06:23:13.600: obs-outputs.dll
06:23:13.600: obs-ndi.dll
06:23:13.600: obs-filters.dll
06:23:13.600: obs-ffmpeg.dll
06:23:13.600: obs-browser.dll
06:23:13.600: image-source.dll
06:23:13.600: frontend-tools.dll
06:23:13.600: enc-amf.dll
06:23:13.600: coreaudio-encoder.dll
06:23:13.600: ---------------------------------
06:23:13.600: ==== Startup complete ===============================================
06:23:13.600: Encoder ID 'jim_nvenc' not found
06:23:13.610: Switched to Preview/Program mode
06:23:13.610: ------------------------------------------------
06:23:13.612: All scene data cleared
06:23:13.612: ------------------------------------------------
06:23:13.624: [WASAPISource::TryInitialize]:[Speakers / Headphones (IDT High Definition Audio CODEC)] Failed to activate client context: 88890004
06:23:13.624: [WASAPISource::WASAPISource] Device '{0.0.0.00000000}.{5b1f5655-0657-4d5a-81a0-abcf28210207}' not found. Waiting for device
06:23:13.671: WASAPI: Device 'Microphone (8- Scarlett 2i2 USB)' initialized
06:23:13.671: Source ID 'limiter_filter' not found
06:23:13.671: Failed to create source 'Limiter'!
06:23:13.672: [WASAPISource::TryInitialize]:[Digidesign Mbox2 Analog 1/2 (5- Digidesign Mbox 2 Audio)] Failed to activate client context: 88890004
06:23:13.672: [WASAPISource::WASAPISource] Device '{0.0.1.00000000}.{7a163f40-d01e-4e5b-bb7d-fd94ba1c2dbf}' not found. Waiting for device
06:23:13.675: [obs-ndi] started A/V threads for source ''
06:23:13.675: [obs-ndi] A/V thread for 'NDI™ Source 2' started
06:23:13.698: Video Capture Device: data.GetDevice failed
06:23:13.698: Video Capture Device: Video configuration failed
06:23:13.715: adding 46 milliseconds of audio buffering, total audio buffering is now 46 milliseconds
06:23:13.817: warning: deprecated pixel format used, make sure you did set range correctly
06:23:13.817: warning: Warning: data is not aligned! This can lead to a speed loss
06:23:13.859: [obs-ndi] started A/V threads for source 'MICHAEL-EDITPC (Skype - [live]mvalente429)'
06:23:13.859: Source ID 'limiter_filter' not found
06:23:13.860: [obs-ndi] A/V thread for 'NDI™ Source 3' started
06:23:13.860: Failed to create source 'Limiter'!
06:23:13.896: Switched to scene 'Skype'
06:23:13.898: ------------------------------------------------
06:23:13.898: Loaded scenes:
06:23:13.898: - scene 'wide studio':
06:23:13.898: - source: 'NDI™ Source 2' (ndi_source)
06:23:13.898: - filter: 'Dedicated NDI™ output (Audio Only)' (ndi_audiofilter)
06:23:13.898: - source: 'bg' (image_source)
06:23:13.898: - source: 'Video Capture Device' (dshow_input)
06:23:13.898: - filter: 'Crop/Pad' (crop_filter)
06:23:13.898: - filter: 'Chroma Key' (chroma_key_filter)
06:23:13.898: - filter: 'Color Correction' (color_filter)
06:23:13.898: - source: 'GFX' (scene)
06:23:13.898: - scene 'Split':
06:23:13.898: - source: 'GFX' (scene)
06:23:13.898: - source: 'wide studio' (scene)
06:23:13.898: - scene 'GFX':
06:23:13.898: - source: 'sub' (image_source)
06:23:13.898: - source: '@SCPBPodcast' (text_gdiplus)
06:23:13.898: - source: 'Twitter' (image_source)
06:23:13.898: - source: 'LIVE' (text_gdiplus)
06:23:13.898: - scene 'Skype':
06:23:13.898: - source: 'NDI™ Source 3' (ndi_source)
06:23:13.898: ------------------------------------------------
06:23:29.590: [obs-ndi] audio thread for 'NDI™ Source 3' completed
06:23:29.591: [obs-ndi] started A/V threads for source 'MICHAEL-EDITPC (Skype - [live]mvalente429)'
06:23:29.592: [obs-ndi] A/V thread for 'NDI™ Source 3' started
06:23:42.305: [obs-ndi] audio thread for 'NDI™ Source 3' completed
06:23:42.306: [obs-ndi] started A/V threads for source 'MICHAEL-EDITPC (Skype - echo123)'
06:23:42.306: [obs-ndi] A/V thread for 'NDI™ Source 3' started
06:24:48.086: User switched to scene 'wide studio'
06:24:48.451: User switched to scene 'Skype'
06:24:48.853: User switched to scene 'wide studio'
06:24:49.752: User switched to scene 'Skype'
06:24:51.189: User switched to scene 'wide studio'
06:24:52.321: User switched to scene 'Skype'
06:24:52.791: User switched to scene 'wide studio'
06:24:52.989: User switched to scene 'Skype'
06:24:54.125: User switched to scene 'wide studio'
 

Narcogen

Active Member
You can also use the NDI Studio Monitor application to test that Skype is properly producing NDI feeds for an active call, to narrow down whether you're having a problem with Skype or a problem with OBS.

Skype does not produce a feed at all when there is no active call.

At least one user has indicated that NDI feeds have no video in them if you don't have a camera connected when Skype launches.
 

MediaFlamengo

New Member
You can also use the NDI Studio Monitor application to test that Skype is properly producing NDI feeds for an active call, to narrow down whether you're having a problem with Skype or a problem with OBS.

Skype does not produce a feed at all when there is no active call.

At least one user has indicated that NDI feeds have no video in them if you don't have a camera connected when Skype launches.
Correct.

I always make a Skype call from the host computer to another guest computer or iPhone.
When the Skype call is established, start a streaming on OBS to ascertain if the Skype call is present.

Easy as

Regards,

Trajano Roberto
Media Flamengo
 

Dpicado

New Member
Hello I'm using OBS 23.2.1 on Windows 10 but I can't find NDI resource on it, even after trying to reinstall 3 times the plug in
 
Top