I am completely stumped. I'm having 40%-50% OBS GPU usage.

vikinghammer87

New Member
I am completely stumped. I'm having 40%-50% OBS GPU usage with a 2080 TI Ryzen 7 3800x 32gb RAM with OBS running and NOTHING else. I have minimal graphics and transitions running on OBS. Something is wrong. I cant seem to figure this out. Posted my OBS settings. Any and all feedback is greatly appreciated.
Log file data posted below



15:51:49.795: CoInitializeEx succeeded: 0x00000001
15:51:49.795: CPU Name: AMD Ryzen 7 3800X 8-Core Processor
15:51:49.795: CPU Speed: 3900MHz
15:51:49.795: Physical Cores: 8, Logical Cores: 8
15:51:49.795: Physical Memory: 32697MB Total, 27732MB Free
15:51:49.795: Windows Version: 10.0 Build 19041 (release: 2004; revision: 450; 64-bit)
15:51:49.795: Running as administrator: false
15:51:49.795: Aero is Enabled (Aero is always on for windows 8 and above)
15:51:49.796: Windows 10 Gaming Features:
15:51:49.796: Game Bar: Off
15:51:49.796: Game DVR: Off
15:51:49.796: Game DVR Background Recording: Off
15:51:49.796: Game Mode: Off
15:51:49.797: Sec. Software Status:
15:51:49.797: Microsoft Defender Antivirus: enabled (AV)
15:51:49.798: Windows Firewall: enabled (FW)
15:51:49.798: Current Date/Time: 2020-09-03, 15:51:49
15:51:49.798: Browser Hardware Acceleration: true
15:51:49.798: Portable mode: false
15:51:49.975: OBS 25.0.8 (64-bit, windows)
15:51:49.975: ---------------------------------
15:51:49.995: ---------------------------------
15:51:49.995: audio settings reset:
15:51:49.995: samples per sec: 44100
15:51:49.995: speakers: 2
15:51:50.006: ---------------------------------
15:51:50.006: Initializing D3D11...
15:51:50.006: Available Video Adapters:
15:51:50.008: Adapter 0: NVIDIA GeForce RTX 2080 Ti
15:51:50.008: Dedicated VRAM: 2994733056
15:51:50.008: Shared VRAM: 4257972224
15:51:50.008: PCI ID: 10de:1e07
15:51:50.008: Driver Version: 27.21.14.5206
15:51:50.008: output 0: pos={0, 0}, size={2560, 1440}, attached=true, refresh=144, name=AG322QWS4R4
15:51:50.008: output 1: pos={400, -1080}, size={1920, 1080}, attached=true, refresh=144, name=Acer XB241H
15:51:50.010: Loading up D3D11 on adapter NVIDIA GeForce RTX 2080 Ti (0)
15:51:50.063: D3D11 loaded successfully, feature level used: b000
15:51:50.063: DXGI increase maximum frame latency success
15:51:50.063: D3D11 GPU priority setup failed (not admin?)
15:51:50.457: ---------------------------------
15:51:50.457: video settings reset:
15:51:50.457: base resolution: 1920x1080
15:51:50.457: output resolution: 1280x720
15:51:50.457: downscale filter: Bicubic
15:51:50.457: fps: 30/1
15:51:50.457: format: NV12
15:51:50.457: YUV mode: 601/Partial
15:51:50.457: NV12 texture support enabled
15:51:50.458: Audio monitoring device:
15:51:50.458: name: Default
15:51:50.458: id: default
15:51:50.458: ---------------------------------
15:51:50.501: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
15:51:50.513: Failed to load 'en-US' text for module: 'decklink-ouput-ui.dll'
15:51:50.550: [AMF] Unable to load 'amfrt64.dll', error code 126.
15:51:50.551: [AMF] AMF Test failed due to one or more errors.
15:51:50.551: Failed to initialize module 'enc-amf.dll'
15:51:50.728: [obs-browser]: Version 2.8.6
15:51:50.775: NVENC supported
15:51:51.008: Couldn't find VLC installation, VLC video source disabled
15:51:51.147: A DeckLink iterator could not be created. The DeckLink drivers may not be installed
15:51:51.148: No blackmagic support
15:51:51.174: [rtmp-services plugin] Successfully updated file 'services.json' (version 145)
15:51:51.174: [rtmp-services plugin] Successfully updated package (version 145)
15:51:51.185: ---------------------------------
15:51:51.185: Loaded Modules:
15:51:51.185: win-wasapi.dll
15:51:51.185: win-mf.dll
15:51:51.185: win-dshow.dll
15:51:51.185: win-decklink.dll
15:51:51.185: win-capture.dll
15:51:51.185: vlc-video.dll
15:51:51.185: text-freetype2.dll
15:51:51.185: rtmp-services.dll
15:51:51.185: obs-x264.dll
15:51:51.185: obs-vst.dll
15:51:51.185: obs-transitions.dll
15:51:51.185: obs-text.dll
15:51:51.185: obs-qsv11.dll
15:51:51.185: obs-outputs.dll
15:51:51.185: obs-filters.dll
15:51:51.185: obs-ffmpeg.dll
15:51:51.185: obs-browser.dll
15:51:51.185: image-source.dll
15:51:51.185: frontend-tools.dll
15:51:51.185: enc-amf.dll
15:51:51.185: decklink-ouput-ui.dll
15:51:51.185: coreaudio-encoder.dll
15:51:51.185: ---------------------------------
15:51:51.185: ==== Startup complete ===============================================
15:51:51.186: Service '' not found
15:51:51.187: No scene file found, creating default scene
15:51:51.187: All scene data cleared
15:51:51.187: ------------------------------------------------
15:51:51.211: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' [48000 Hz] initialized
15:51:51.227: WASAPI: Device 'Headset Microphone (Arctis Pro Wireless Chat)' [48000 Hz] initialized
15:51:51.227: Switched to scene 'Scene'
15:51:51.227: Failed to glob scene collections
15:51:51.270: adding 46 milliseconds of audio buffering, total audio buffering is now 46 milliseconds (source: Mic/Aux)
15:51:51.270:
15:52:40.873: Switched to scene '(null)'
15:52:40.873: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' Terminated
15:52:40.876: WASAPI: Device 'Headset Microphone (Arctis Pro Wireless Chat)' Terminated
15:52:40.877: All scene data cleared
15:52:40.877: ------------------------------------------------
15:52:40.890: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' [48000 Hz] initialized
15:52:40.895: WASAPI: Device 'Headset Microphone (Arctis Pro Wireless Chat)' [48000 Hz] initialized
15:52:40.895: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' Terminated
15:52:40.897: WASAPI: Device 'Headset Microphone (Arctis Pro Wireless Chat)' Terminated
15:52:40.899: Switched to scene 'Scene'
15:52:40.899: ------------------------------------------------
15:52:40.899: Loaded scenes:
15:52:40.899: - scene 'Scene':
15:52:40.899: ------------------------------------------------
15:52:40.899: Switched to scene collection 'Unknown Streamlabs Import' (Unknown_Streamlabs_Import.json)
15:52:40.899: ------------------------------------------------
15:52:53.330: Switched to scene '(null)'
15:52:53.332: All scene data cleared
15:52:53.332: ------------------------------------------------
15:52:53.343: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' [48000 Hz] initialized
15:52:53.359: WASAPI: Device 'Microphone (HyperX Quadcast)' [48000 Hz] initialized
15:52:53.469: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' Terminated
15:52:53.472: WASAPI: Device 'Microphone (HyperX Quadcast)' Terminated
15:52:53.478: Switched to scene 'Scene'
15:52:53.478: ------------------------------------------------
15:52:53.478: Loaded scenes:
15:52:53.478: - scene 'Scene':
15:52:53.478: - scene 'Vike':
15:52:53.478: - source: 'Image' (image_source)
15:52:53.478: - source: 'Webcam' (dshow_input)
15:52:53.478: - filter: 'Chroma Key' (chroma_key_filter)
15:52:53.478: - scene 'Live':
15:52:53.478: - source: 'Game Capture' (game_capture)
15:52:53.478: - source: 'Webcam' (dshow_input)
15:52:53.478: - filter: 'Chroma Key' (chroma_key_filter)
15:52:53.478: - source: 'Display Capture' (monitor_capture)
15:52:53.478: ------------------------------------------------
15:52:53.479: Switched to scene collection 'Scenes (1)' (Scenes_(1).json)
15:52:53.479: ------------------------------------------------
15:52:53.492: [Media Source 'Viking (Stinger)']: settings:
15:52:53.492: input: C:\Users\Vikin\Downloads\vikinghammer87 01.webm
15:52:53.492: input_format: (null)
15:52:53.492: speed: 100
15:52:53.492: is_looping: no
15:52:53.492: is_hw_decoding: no
15:52:53.492: is_clear_on_media_end: yes
15:52:53.492: restart_on_activate: yes
15:52:53.492: close_when_inactive: no
15:52:53.506: ---------------------------------
15:52:53.506: [DShow Device: 'Webcam'] settings updated:
15:52:53.506: video device: c922 Pro Stream Webcam
15:52:53.506: video path: \\?\usb#vid_046d&pid_085c&mi_00#7&81a0ed6&0&0000#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\global
15:52:53.506: resolution: 640x480
15:52:53.506: flip: 0
15:52:53.506: fps: 30.00 (interval: 333333)
15:52:53.506: format: YUY2
15:52:55.888: User switched to scene 'Live'
15:52:56.892: A sprite cannot be drawn without a width/height
15:54:34.572: Settings changed (outputs)
15:54:34.572: ------------------------------------------------
15:54:57.992: ---------------------------------
15:54:57.992: video settings reset:
15:54:57.992: base resolution: 1920x1080
15:54:57.992: output resolution: 1920x1080
15:54:57.992: downscale filter: Lanczos
15:54:57.992: fps: 30/1
15:54:57.992: format: NV12
15:54:57.992: YUV mode: 601/Partial
15:54:57.992: NV12 texture support enabled
15:54:58.000: Settings changed (video)
15:54:58.000: ------------------------------------------------
15:55:16.360: ---------------------------------
15:55:16.360: video settings reset:
15:55:16.360: base resolution: 1920x1080
15:55:16.360: output resolution: 1920x1080
15:55:16.360: downscale filter: Lanczos
15:55:16.360: fps: 30/1
15:55:16.360: format: NV12
15:55:16.360: YUV mode: 709/Partial
15:55:16.360: NV12 texture support enabled
15:55:16.372: Settings changed (advanced)
15:55:16.372: ------------------------------------------------
17:08:35.228: [game-capture: 'Game Capture'] attempting to hook fullscreen process: Telegram.exe
17:08:35.281: [game-capture: 'Game Capture'] using helper (compatibility hook)
17:08:35.285: [game-capture: 'Game Capture'] hook not loaded yet, retrying..
17:34:08.347: warning: deprecated pixel format used, make sure you did set range correctly
20:34:39.348: warning: deprecated pixel format used, make sure you did set range correctly
20:38:43.296: WASAPI: Device 'Headset Microphone (Arctis Pro Wireless Chat)' [48000 Hz] initialized
20:38:43.297: User added source 'Mic' (wasapi_input_capture) to scene 'Live'
20:38:45.454: WASAPI: Device 'Headset Microphone (Arctis Pro Wireless Chat)' Terminated
20:38:45.470: WASAPI: Device 'Microphone (HyperX Quadcast)' [48000 Hz] initialized
20:39:07.400: User switched to scene 'Vike'
20:39:08.382: User switched to scene 'Live'
20:39:13.495: [Media Source 'clone (Stinger)']: settings:
20:39:13.495: input: C:\Users\Vikin\Downloads\vikinghammer87 01.webm
20:39:13.495: input_format: (null)
20:39:13.495: speed: 100
20:39:13.495: is_looping: no
20:39:13.495: is_hw_decoding: no
20:39:13.495: is_clear_on_media_end: yes
20:39:13.495: restart_on_activate: yes
20:39:13.495: close_when_inactive: no
20:39:19.067: [Media Source 'clone (Stinger)']: settings:
20:39:19.067: input: C:\Users\Vikin\Downloads\vikinghammer87 01.webm
20:39:19.067: input_format: (null)
20:39:19.067: speed: 100
20:39:19.067: is_looping: no
20:39:19.067: is_hw_decoding: no
20:39:19.067: is_clear_on_media_end: yes
20:39:19.067: restart_on_activate: yes
20:39:19.067: close_when_inactive: no
20:39:19.699: [Media Source 'Viking (Stinger)']: settings:
20:39:19.699: input: C:\Users\Vikin\Downloads\vikinghammer87 01.webm
20:39:19.699: input_format: (null)
20:39:19.699: speed: 100
20:39:19.699: is_looping: no
20:39:19.699: is_hw_decoding: no
20:39:19.699: is_clear_on_media_end: yes
20:39:19.699: restart_on_activate: yes
20:39:19.699: close_when_inactive: no
20:39:20.390: User switched to scene 'Vike'
20:39:20.909: User switched to scene 'Live'
20:40:17.394: ---------------------------------
20:40:17.395: video settings reset:
20:40:17.395: base resolution: 1920x1080
20:40:17.395: output resolution: 1920x1080
20:40:17.395: downscale filter: Lanczos
20:40:17.395: fps: 60/1
20:40:17.395: format: NV12
20:40:17.395: YUV mode: 709/Partial
20:40:17.395: NV12 texture support enabled
20:40:17.408: Settings changed (video)
20:40:17.408: ------------------------------------------------
20:40:30.776: User switched to scene 'Vike'
20:40:54.264: User added source 'Mic' (wasapi_input_capture) to scene 'Vike'
20:41:01.139: User switched to scene 'Live'
20:41:01.658: User switched to scene 'Vike'
20:41:03.729: User switched to scene 'Live'
20:41:39.451: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' [48000 Hz] initialized
20:41:43.644: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' Terminated
20:41:43.655: WASAPI: Device 'Headphones (Arctis Pro Wireless Game)' [48000 Hz] initialized
20:42:29.398: User switched to scene 'Vike'
20:42:58.385: User added source 'Audio Output Capture' (wasapi_output_capture) to scene 'Vike'
20:44:15.074: Settings changed (stream 1)
20:44:15.074: ------------------------------------------------
20:45:55.342: [jim-nvenc: 'streaming_h264'] settings:
20:45:55.342: rate_control: CBR
20:45:55.342: bitrate: 5000
20:45:55.342: cqp: 20
20:45:55.342: keyint: 120
20:45:55.342: preset: hq
20:45:55.342: profile: high
20:45:55.342: width: 1920
20:45:55.342: height: 1080
20:45:55.342: 2-pass: false
20:45:55.342: b-frames: 2
20:45:55.342: lookahead: true
20:45:55.342: psycho_aq: true
20:45:55.342:
20:45:55.359: ---------------------------------
20:45:55.359: [FFmpeg aac encoder: 'avc_aac_stream'] bitrate: 160, channels: 2, channel_layout: 3
20:45:55.359:
20:45:55.363: [rtmp stream: 'adv_stream'] Connecting to RTMP URL rtmp://live-jfk.twitch.tv/app...
20:45:55.396: [rtmp stream: 'adv_stream'] Interface: Intel(R) I211 Gigabit Network Connection (ethernet, 1000 mbps)
20:45:56.291: [rtmp stream: 'adv_stream'] Connection to rtmp://live-jfk.twitch.tv/app successful
20:45:56.298: ==== Streaming Start ===============================================
20:49:02.844: User switched to scene 'Live'
20:51:47.978: Settings changed (general)
20:51:47.978: ------------------------------------------------
 

carlmmii

Active Member
Are you having any performance issues, or are you just looking at the usage percentage?

Most likely you aren't stressing your GPU enough to take it out of its idle power state, so the reported "usage" is based on a much lower limit.

If you really want to verify, get GPU-Z and check if perfcap displays idle. If so, then that is the reason, and it is completely normal. As soon as the GPU sees a need to power up, the limits will increase appropriately, and the usage percentage will drop due to the much higher maximum based on the new power state.
 

FerretBomb

Active Member
You should never have a Game (or Window) Capture and a Display Capture in the same scene. Display Capture actually should be avoided at all costs, and only used as an absolute last resort, in its own separate scene. It can absolutely cause interference and performance issues in general.
 

vikinghammer87

New Member
Are you having any performance issues, or are you just looking at the usage percentage?

Most likely you aren't stressing your GPU enough to take it out of its idle power state, so the reported "usage" is based on a much lower limit.

If you really want to verify, get GPU-Z and check if perfcap displays idle. If so, then that is the reason, and it is completely normal. As soon as the GPU sees a need to power up, the limits will increase appropriately, and the usage percentage will drop due to the much higher maximum based on the new power state.
I was having significant performance issues with my stream. Not in game. The stream looked like a PowerPoint presentation when the GPU utilization would approach 100%. OBS would notify me of dropped frames. When opening a game like Modern Warfare, OBS using that 40%+ usage left my 2080TI with only 50% or so usage to run the game.
 

Anubis Mann

Member
I was having significant performance issues with my stream. Not in game. The stream looked like a PowerPoint presentation when the GPU utilization would approach 100%. OBS would notify me of dropped frames. When opening a game like Modern Warfare, OBS using that 40%+ usage left my 2080TI with only 50% or so usage to run the game.
1- Turn ON Game Mode in Windows settings.
2- Run OBS in admin mode.
3- Download codec AAC, link: Apple codec
- No install !, extract with Winrar to any folder.
- Inside folder, install only AppleApplicationSupport64
- Reboot PC

OBS settings for streaming with NVENC encoder:

Output:
Encoder: NVIDIA NVENC (new)
Bitrate for 60 fps 1080p: 6000 kbps (Twitch official recomendations)
Keyframe: 2
Preset: Quality
Profile: high

Audio:
Sample Rate: 48 kHz

Video:
Base: Your monitor resolution
Output: 1080p
Downscale: Bicubic (default)
Common FPS: 60

Advanced:
Network: Check ! - Enable network optimizations and Enable TCP pacing
 

carlmmii

Active Member
I was having significant performance issues with my stream. Not in game. The stream looked like a PowerPoint presentation when the GPU utilization would approach 100%. OBS would notify me of dropped frames. When opening a game like Modern Warfare, OBS using that 40%+ usage left my 2080TI with only 50% or so usage to run the game.
Can you post the full log file from the stream? The one you posted only goes up until the point of starting the stream, but does not include any of the information of frames lost due to rendering or encoding lag.

Based on what is available though:
- Run OBS as administrator
- Turn off Psychovisual Tuning and Lookahead
 

vikinghammer87

New Member
Can you post the full log file from the stream? The one you posted only goes up until the point of starting the stream, but does not include any of the information of frames lost due to rendering or encoding lag.

Based on what is available though:
- Run OBS as administrator
- Turn off Psychovisual Tuning and Lookahead
Hello. Thanks for your help. Apologies for the delay. Log file is attached
 

Attachments

qhobbes

Active Member
1. As Anubis Mann indicated, run OBS as administrator. Right click on the shortcut and select that option or go to Properties, Shortcut tab, [Advanced...], check for "Run as administrator" [OK] [Apply] [OK]
2. As FerretBomb indicated, Display and Game Capture Sources interfere with each other. Never put them in the same scene. If you need to use Display Capture, duplicate the scene by right-clicking on the name (Live), select "Duplicate" and give it a new name such as Live Display. Then remove Display Capture from Live scene and Game Capture from Live Display scene.
3. At least one of your audio devices has a sample rate that doesn't match the rest. This can result in audio drift over time or sound distortion. Check your audio devices in Windows settings (both Playback and Recording) and ensure the Default Format (under Advanced) is consistent. 48000 Hz is recommended.
OBS Sample Rate: 44100 Hz
Headphones (Arctis Pro Wireless Game): 48000 Hz
Microphone (HyperX Quadcast): 48000 Hz

To fix this, go to OBS Settings --> Audio --> General --> Set Sample Rate to 48 kHz [Apply [OK]
4. Your log contains no recording or streaming session. Results of this log analysis are limited. Please post a link to a clean log file.
To make a clean log file, please follow these steps:

1) Restart OBS as administrator and do 2 & 3 from above.
2) Start your stream/recording for about 30 seconds. Make sure you replicate any issues as best you can, which means having any games/apps open and captured, etc.
3) Stop your stream/recording.
4) Select Help > Log Files > Upload Current Log File. Send that link via this troubleshooting tool or whichever support chat you are using.
 

Coxinigo

New Member
Could anyone from here try what I have done?
Go to windows settings - game mode - graphics settings - change to "ON" hardware accelerated (Restart your PC)
Hardware-accelerated-GPU-scheduling.jpg

Just in case I disabled windows 10 animations, because I found out that when OBS was just minimized in the windows taskbar my GPU usage was lower.
Run OBS as administrator.
Please let me know if this works for anyone else.With this configuration I have like 20-30 fps more while gaming with OBS
 
Top