How to split, exclude, seperate Audio sources off your stream or recording

All Versions How to split, exclude, seperate Audio sources off your stream or recording

Jack0r

The Helping Squad
Forum Moderator
#1
Jack0r submitted a new resource:


How to split or exclude Audio sources off your stream or recording

- Use Voicemeeter, Virtual Audio Cable, VB-Cable or your Soundcard capabilities to exclude/split sound.

Its fortunately quite easy to exclude an Audio source from your stream or recording. But there are a few things we cannot do. So let us take a look at the different sources we may have available:
  • Good
    • Voice-Communication (Teamspeak, Skype, etc.)
    • Music/MediaPlayer (software with good Audio options: foobar, winamp, etc.)
    • Game sound (with good Audio options)
    • [External Inputs (Line-In, Digital-In are already excluded unless you add them)]
  • Bad
    • Music/MediaPlayer (software with no Audio options: browser, itunes, etc.)
    • Game sound (with no Audio options)
    • Browser sound (Youtube, Flash stuff, etc.)
    • Application sound (often no Audio options)
Music(no Audio options), Game(no Audio options), Browser(no Audio options) and Application(no Audio options) sounds CANNOT be split (or excluded) from each other, they will always use your default playback device
Read more about this resource...
 
Last edited:
#2
Hello,
Ive tried to use your Stereo Mix guide, as i have the same onboard sound as you do in the video.
However after following the guide exactly 5 times now it does not seem to work as you have stated in the guide.

What im trying to accomplish is to be able to livestream and have mumble or teamspeak not transmit over my livesteam, but at the same time still use the mic connected to my headset to talk to people in mumble/teamspeak and to my livestream (using OBS).

When i setup as your guide shows all of that works except my mic does not work over OBS, so my livestream does not hear mumble/teamspeak but they also do not hear me over my mic.

OBS is set to use the default recording device, if i set it manually to use the realtek mic, then mumble/teamspeak start to play over the livestream again, defeating the whole purpose.

Is what im trying to accomplish not possible?
From what your saying in the guide this should be possible.
 

Jack0r

The Helping Squad
Forum Moderator
#3
Hmm, thats an usual error, if you use the Stereomix with front and back port, normally the back port should be default playback device and used in obs as desktop sound. The stereomix forwards the sound to the front port where you mix in TeamSpeak/Mumble. From your explanation you got that working. Now in OBS you just select the Microphone for Auxillary/Mic input, TS/Mumble will use the same. And thats about it.
Double check that listen to is only active on the stereomix, and the correct device is selected in the dropdown. No other recording device should have listen to active. And double check that Teamspeak/Mumble use the front output, not the back output, and also not the stereomix :)
 

Seb

New Member
#6
Hi,
I spent several days researching this subject of seperate audio channels. I am going to mention an alternative, which is my current setup, and share my experiences.

My setup:
○Asus Xonar pcie soundcard
○Motherboard soundcard
○Rode NT-USB Microphone
○Rolls MX41b four channel stereo mixer
○4 × stereo AUX cables
○Beyerdynamic headphones
○Tannoy studio speakers
○Mp3 player/smartphone/tablet/whatever has my jams.
○Windows 8

How I connect this gear:

○first plug in the AUX cables to devices (soundcards, music device, microphone monitor). Connect the AUX cables to the stereo Rolls mixer. Next connect your speakers or headphones. Never both.*

For example:
Channel1=Asus Soundcard,
Ch2=Motherboard Soundcard,
Ch3=MusicPlayer device,
Ch4=Mic monitoring,
Output = headphones.

○On Windows 8 go to the audio devices window (right click the speaker icon in the system tray and select devices). Right click the soundcard you want to hear game sounds, and select Set as Default Device. Next right click the soundcard you want to hear VoIP, and select Set as Default Communications Device. That is it.

Never both.* If you noticed that the Rolls mixer has both mini jack and TRS jack, do not use an adapter to output to speakers and headphones. The headphones will become a pick up, like a microphone, potentially causing feedback. Maybe use a splitter cable, I stick to unplugging to switch between the 2.

Note: the PCIe soundcard is not necessary if your motherboard has support for seperate channels like: front io sound, rear io sound, and/or an extra line out port. You can set it up for those devices if they appear on your audio device list. (EG: Ch1:FrontIO/LineOut, Ch2:RearIO...)

My experience
Before this setup I had other gear, and I will briefly explain why this is the best out of what I tried. First I had a small Behringer Xenyx mixer and a SE-X1 XLR microphone. I do not recommend mixers like the Behringer Xenyx or anything remotely similar cause of extra power brick, unbalanced TRS, mono audio inputs, etc. Later I traded my mixer for an external soundcard: Focusrite Scarlet 2i2. It was OK, but lacked input and output features.

Then traded that gear for my current setup, and it is a significant improvement, simple, and efficient. (IMO)

BTW, the Rolls stereo mixer I have is the only mini jack stereo mixer I could find without a power brick. The rest were mono, or no longer in production. Rolls is from North America, so if you are in Europe you can find this mixer on the online store: thomann.

Best,
Sebastian

PS: JACK0R, thank you for The Helping Squad, it helped me a lot!
 
Last edited:
#8
Hello i'm trying to revive dead topic, but as Moonboom i have 2nd output but it's not connected. And i dont know what im supposed to do now.
 

Sapiens

Forum Moderator
#10
@iriedraco As explained in support chat, at least one of the programs needs to be able to pick its output device. You can't do that with Pandora, so the game needs to have that option. If your game doesn't have that option either then there's no way to split them since both will always go to the default playback device.
 
L

L4DYSNOW

#11
Hey guys! This is a nice simple guide thaaank you :-) !

But is there a way just to simply lower certain sources volume for the viewers but not for me?
i.e. I just wanna lower the teamspeak volume for my viewers but not for me. My friend is louder/better audible in my stream than myself.

Yes i could lower the TS Sound in general, but thats not the perfect solution since it makes it hard for me to understand while gaming.

I hope you understand what my problem is :-)

Is there any workaround to solve this? Or is there a mixer plugin for obs (like a duplicated Windows Soundmixer just for the OBS output)

Thanks
 
#12
Edit: I watched the YouTube video again and I think I understand - YouTube, being in a Chrome browser, cannot be separated / split at all, so it's impossible to do what I want to do. Please be so kind as to tell me whether I'm understanding this correctly.


I want to be able to watch YouTube videos on a desktop via Chrome, listening via a headset, recording via OBS Studio, but not recording the mic. Basically, this is so my kid can watch on a separate screen, hear the audio, and I have the show recorded in case he really loves it I can save it to a tablet for car rides.

On the other desktop (prob virtual via winkey+tab), I want to just be able to do whatever, like I could be working in another program or even watching my own YouTube likes and listening via the laptop speakers.

I have figured out how to make the video work - OBS will record a window I choose and not switch to the other desktop/Chrome when I do. But the audio from both are mixing together.

I tried to understand this guide, watched two YouTube videos https://www.youtube.com/watch?v=1fMnuimAm-c
https://www.youtube.com/watch?v=tBSeNzcHPoc

I made StereoMix my default device in Recording, but I don't see what that did. Even when I have it listen to the playback device that is making sound / green bars, and the stereomix levels are 100, the stereomix bars never show green.

when I plug in the headset with mic via a USB adapter, that adds a USB PnP Sound Device as both a Mic (record) and Speakers (playback). In playback, I also have the Realtek HDA speakers (that's the laptop speakers). There' s also Realtek Digital Output enabled, but it never shows green when there's sound.

Thanks for any help:)
 

Jack0r

The Helping Squad
Forum Moderator
#13
That is correct. Unfortunately I know of no browser that allows you to use a selected audio device. All Browser Sound will always go to the default playback device in Windows.
 
#15
Ok, so I tried using Voicemeeter to separate my discord from my games, but it just doesnt work. Discord is only going to my speakers, while everything else goes to default device, which is the virtual voicemeet cable. This would be fine except windows seems to still think I want my speakers as a default device. Everything goes to both my speakers and my virtual cable, except discord. Any ideas on how to fix this? It works fine if I set it up using VAC, but that has the annoying trial watermark every time it makes sound. It seems like I need 2 virtual inputs, but I only have 1. Is there any way to add another thru Voicemeet?

Edit: If I set it the other way around, with my speakers being default and virtual cable being used exclusively by discord, I have a different problem. I can separate my voice and discord, but can't separate discord from game audio.
 
Last edited:

Jack0r

The Helping Squad
Forum Moderator
#17
Playback devices never have the option to listen to, but recording devices have.
You activate listen to on the VAC cable under recording for example and set it to output to your playback device (Speakers for example)
 
#19
How do I stop audio reverbing/looping when Skype is being pushed to Facebook Live?

I set up a scene with Skype as a source, and published to Live. It took 10-15 seconds before something said on Skype appeared on Facebook (inconvenient, but not the end of the world)... then it would be picked up by Skype, with the result that the audio would keep looping over itself. This made it impossible for the host to participate.

(Is there any Help from OBS? Or do we just help each other figure it out here?)
 
#20
I've been using VoiceMeeter for a good while now and am under the impression that it causes crashes with looping audio due to not playing nice with Realtek built in audio. Can anyone confirm crashes while using VoiceMeeter?
 
Top