Bug Report Flickering on Arch Linux with a Screen Capture

Advancid

New Member
Hello,

I'm trying to record on Arch Linux with OBS studio (I tried the release and git versions), but when I play the video, I can see that the screen becomes green for one frame. Also in the preview I can see a lot of flickering.

Here is my log file:
http://pastebin.com/raw/JmmwmjQ1
 

DerkerJerker

New Member
I have found that my Compositor, Compton, is causing this issue. I always make sure to disable any compositing before a stream. It increases stream fidelity and also game performance 4/5 times.
 

frol

New Member
I am experiencing the same flickering output with OBS Screen Capture (XSHM) and Zoom.us (screen sharing) on my Arch Linux / Gnome 3 / Intel HD Graphics 4600. Everything is fine when I do single window capturing or use screen sharing in Skype or Meet.jit.si, though.

Any ideas?
 

frol

New Member
ffmpeg -f x11grab -s 1920x1080 -i :0.0+0,0 out_video.mp4

This works absolutely fine, also.
 

lallulli

New Member
I was having the same problem on Manjaro Linux in a KDE Plasma session, using an Intel graphics card.

I solved by setting the option Tearing prevention ("vsync") to Never.
The option is located in: System Settings > Display and Monitor > Compositor
 

jsonMartin

New Member
I was having the same problem on Manjaro Linux in a KDE Plasma session, using an Intel graphics card.

I solved by setting the option Tearing prevention ("vsync") to Never.
The option is located in: System Settings > Display and Monitor > Compositor
OMG, this fixed the issue for me... thank you so much! I just switched from Gnome to KDE and just encountered this issue while trying to record a screencast for the first time. Happy it works now!
 

reoring

New Member
I was having the same problem on Manjaro Linux in a KDE Plasma session, using an Intel graphics card.

I solved by setting the option Tearing prevention ("vsync") to Never.
The option is located in: System Settings > Display and Monitor > Compositor
My environment has exactly the same problems. I've tried your solution and then completely fix that! Thank you so much!

My environment:
* Manjaro Linux KDE Plasma Edition.
* Linux Kernel: 5.9.11-3
* Screen sharing on: Slack and Zoom
 

chovy

New Member
I get this on arch with gnome using OBS and Kazam. How do I disable vsync on Gnome/Xorg?
 

frankbuss

New Member
For me with Debian Linux and KDE, it worked to change "Settings->Display and Monitor->Compositor->Rendering backend" from OpenGL to XRender. Might be a problem with the nvidia driver. The desktop feels faster now, too.
 

dany_wilde

New Member
all right . how do you do this on linux debian (bookworm/sid) gnome ?
searched but didn't find .
AMD RX 6800 card . AMD Ryzen 9 3900 X
using also mangohud .
 
Last edited:

dany_wilde

New Member
all right . how do you do this on linux debian (bookworm/sid) gnome ?
searched but didn't find .
AMD RX 6800 card . AMD Ryzen 9 3900 X
using also mangohud .
i have nearly the same problem like frol .
obs give me a lot of flickering in the "video capture device (v4l2)"
plugged with a "video acquisition unit"
 

jdeep

New Member
i have nearly the same problem like frol .
obs give me a lot of flickering in the "video capture device (v4l2)"
plugged with a "video acquisition unit"
I have the same problem. Only difference is, I am using a Nvidia GPU. But I fixed on Arch Linux runnning Gnome using the following method:

1. First, make sure you have an Nvidia card and nvidia drivers installed using lspci -k | grep -A 2 -E "(VGA|3D)". (I recommend using the proprietary Nvidia drivers since in terms of performance, they perform better than Noveau).

Code:
lspci -k | grep -A 2 -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation WhiskeyLake-U GT2 [UHD Graphics 620] (rev 02)
    DeviceName: VGA
    Subsystem: ASUSTeK Computer Inc. Device 1fbe
    Kernel driver in use: i915
--
02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX250] (rev a1)
    DeviceName: Second VGA
    Subsystem: ASUSTeK Computer Inc. Device 1fbe
    Kernel driver in use: nvidia
2. Install nvidia-settings using your package manager.
Code:
pacman -S nvidia-settings
3. Then, you will get both CLI & GUI for nvidia-settings. Open it from terminal.
Then select `Prefer maximum Performance` under Preferred mode :
Screenshot from 2021-10-21 18-23-02.png
 
Top