Question / Help DOUBLED AUDIO!

iAisui

New Member
Okay, so I just installed OBS. First use of the program the audio was fine. Streamed audio perfectly.
Opened the program back up to stream a second time and the audio settings changed. Now the audio doubles. (Dunno why.)
I have an El Gato HD60 Pro.
I have Desktop audio on because I use discord to chat.
Now when any audio is hear from HD60Pro, it duplicates to the Desktop audio.
I used to use xsplit and this never happened, but it seems to be a common problem with OBS.
How do I get rid of this double audio of my game going to desktop?
 

iAisui

New Member
scroll.PNG
 

Attachments

  • Capturezzzz.PNG
    Capturezzzz.PNG
    18.1 KB · Views: 3,864

Zidakuh

Member
For Desktop audio, set it to "monitor off"
For the capture card, set to "monitor, mute output"
As the capturecard will that way be output to the desktop, you don't need it to send it back through OBS itself, and loop.
 

iAisui

New Member
For Desktop audio, set it to "monitor off"
For the capture card, set to "monitor, mute output"
As the capturecard will that way be output to the desktop, you don't need it to send it back through OBS itself, and loop.
I tested this out, still does not work.
 

Narcogen

Active Member
You added absolutely nothing to the conversation.

Sorry, I had time at that moment to point out you were given less than optimal advice and what the potential negative consequence would have been even if it had done what you wanted, but not enough time to go into more detail.

Audio doubling in OBS usually occurs because of two possible scenarios:

1) Duplicate sources. This is the simple explanation, but less common. It just means that you've added the same source of audio in more than once. Most often this would be because you added a source of audio in Settings > Audio more than once, or configured it in Settings > Audio and then also added it as an audio source directly in a scene. Sometimes users set both "Desktop Audio" and "Mic/Aux" to "default" not realizing that these both mean the Windows default audio device. However I do not think this is your case.

2) Incorrect monitoring setting. When OBS is set up to capture a local application, it is normal for it to capture the default Windows system audio device, and for monitoring to be off in this case. The user can already hear this source, whether through speakers or headphones, and so monitoring is unnecessary. The user may have selected, in Settings > Audio, for the Audio Monitoring Device to be the system default, but until monitoring is turned on for at least once source in Edit > Advanced Audio Properties, this setting has no effect at all and causes no problem, so the user does not notice that this is a mistake.

The mistake becomes noticeable when moving to capturing from an external device like a capture card; this source also generates audio, but the user may not already be set up to hear it. If it sends audio to loudspeakers or a TV in the same room with a microphone, this will double audio. The user could connect headphones to it, perhaps through a splitter, but now they need two sets of headphones-- one for the PC and one for the source connected to the capture device.

OBS' solution to this is Audio Monitoring. This allows audio to pass through from an audio source to a specific audio device so that the user running OBS can hear it. However, OBS assumes that the Audio Monitoring device is either *different* from the default audio device, or that the user knows that one should not be capturing from the default audio device if it is being used for monitoring; the result will be doubled audio, as audio from your capture card is sent by OBS to your system default device (where you are monitoring Discord output) and then it is captured a second time.

Zidakuh's suggestion, had it worked, would have prevented this from happening but in a way that is not really usual or expected and that could have caused other problems-- they suggested turning OFF the output of the capture card (removing its audio from your stream or recording) and turning it's monitor ON.

So now capture card audio isn't recorded directly, but it is sent to the monitor. But since the monitor is likely your default output, that means you can hear it. And desktop audio is being captured because that's where your discord chat is-- so you're not recording your captured audio directly, you're recording the monitor of that output, passed through OBS.

The problem with this is: 1) You now have all audio muxed down to a single track, meaning you can't adjust volume of those sources separately in post-production, if you are planning on doing that, and 2) depending on the load on your PC, you have introduced the possibility of a slight, but potentially noticeable, delay between your video capture footage and your captured audio.

You shouldn't do this and there's no good reason to do this; it's just that if your scenario had been exactly as Zidakuh had presumed, it would have stopped you from hearing an echo with the fewest number of changes in the UI.

What you ought to do is this:

You will need audio monitoring ON in order to hear your capture card, and it should also be recorded/streamed. So your Elgato source should be set to "monitor and output".

You cannot, however, send Discord and monitoring audio to the same device. There are a couple of ways to solve this issue; one involves third party software, and one does not.

The way without other software presumes that you have at least two hardware outputs on your PC that you could use; say, a line out jack for loudspeakers, but also a headphone jack. We'll be using your headphones as your monitoring output, and you just need any other device to use as your system default-- it doesn't really matter what it is because we're not actually going to listen to it. In fact, it's better if either that device is off, or it's a plug that has nothing connected to it.

So let's just say it's a line out for speakers. Set that as default, and turn the speakers off or disconnect them. In your setup, this is used for Discord output.

Now, in OBS' Mixer (Edit > Advanced Audio Properties) set both your system audio and your capture card audio to Output and Monitor.

In Settings > Audio, set the Audio Monitoring Device to be your headphones (in other words, the device that is NOT system default).

You should now be able to both hear and record/stream Discord output and capture card audio. (at least while OBS is running, anyway-- since you're hearing discord through OBS' monitor, in this scenario, you'll stop hearing it when OBS is not running, so you need to remember to change your default system device when not streaming or recording. (This is normal). This also has the effect of stopping you from hearing Discord if you switch to a scene in OBS that does not include Discord audio; if you have all your audio devices in Settings > Audio this is not a problem, since those devices are in all scenes, but if you have transitional scenes, or break scenes, this either means Discord audio is always on unless you mute it in the app or in OBS; and if you add your system audio as a separate source in your scenes, you will only hear monitored output when the active scene includes that source. These drawbacks can be alleviated by performing audio routing/monitoring functions in free 3rd party software instead of in OBS.

The way using 3rd party software is described in this guide:

https://obsproject.com/forum/resour...nagement-for-1-and-2-pc-streaming-setups.397/

In this setup, you gain at least one "virtual" audio device to serve as your default system audio, and Voicemeeter takes the place of the Windows default audio mixer. This allows for separation of chat and game audio even when recording a local game, not just a capture card, and Voicemeeter's own audio routing control can be used for monitoring instead of OBS if desired, and is generally superior to the audio routing controls in Windows. It may be necessary in this scenario to set your audio devices in the Windows sound control panel to non-exclusive mode, because if you have them being configured in both OBS and Voicemeeter, they may interfere if exclusive access is on.

The setup I use myself involves Voicemeeter Potato, which provides for three virtual audio devices.

https://www.vb-audio.com/Voicemeeter/potato.htm
 
Last edited:

iAisui

New Member
Sorry, I had time at that moment to point out you were given less than optimal advice and what the potential negative consequence would have been even if it had done what you wanted, but not enough time to go into more detail.

Audio doubling in OBS usually occurs because of two possible scenarios:

1) Duplicate sources. This is the simple explanation, but less common. It just means that you've added the same source of audio in more than once. Most often this would be because you added a source of audio in Settings > Audio more than once, or configured it in Settings > Audio and then also added it as an audio source directly in a scene. Sometimes users set both "Desktop Audio" and "Mic/Aux" to "default" not realizing that these both mean the Windows default audio device. However I do not think this is your case.

2) Incorrect monitoring setting. When OBS is set up to capture a local application, it is normal for it to capture the default Windows system audio device, and for monitoring to be off in this case. The user can already hear this source, whether through speakers or headphones, and so monitoring is unnecessary. The user may have selected, in Settings > Audio, for the Audio Monitoring Device to be the system default, but until monitoring is turned on for at least once source in Edit > Advanced Audio Properties, this setting has no effect at all and causes no problem, so the user does not notice that this is a mistake.

The mistake becomes noticeable when moving to capturing from an external device like a capture card; this source also generates audio, but the user may not already be set up to hear it. If it sends audio to loudspeakers or a TV in the same room with a microphone, this will double audio. The user could connect headphones to it, perhaps through a splitter, but now they need two sets of headphones-- one for the PC and one for the source connected to the capture device.

OBS' solution to this is Audio Monitoring. This allows audio to pass through from an audio source to a specific audio device so that the user running OBS can hear it. However, OBS assumes that the Audio Monitoring device is either *different* from the default audio device, or that the user knows that one should not be capturing from the default audio device if it is being used for monitoring; the result will be doubled audio, as audio from your capture card is sent by OBS to your system default device (where you are monitoring Discord output) and then it is captured a second time.

Zidakuh's suggestion, had it worked, would have prevented this from happening but in a way that is not really usual or expected and that could have caused other problems-- they suggested turning OFF the output of the capture card (removing its audio from your stream or recording) and turning it's monitor ON.

So now capture card audio isn't recorded directly, but it is sent to the monitor. But since the monitor is likely your default output, that means you can hear it. And desktop audio is being captured because that's where your discord chat is-- so you're not recording your captured audio directly, you're recording the monitor of that output, passed through OBS.

The problem with this is: 1) You now have all audio muxed down to a single track, meaning you can't adjust volume of those sources separately in post-production, if you are planning on doing that, and 2) depending on the load on your PC, you have introduced the possibility of a slight, but potentially noticeable, delay between your video capture footage and your captured audio.

You shouldn't do this and there's no good reason to do this; it's just that if your scenario had been exactly as Zidakuh had presumed, it would have stopped you from hearing an echo with the fewest number of changes in the UI.

What you ought to do is this:

You will need audio monitoring ON in order to hear your capture card, and it should also be recorded/streamed. So your Elgato source should be set to "monitor and output".

You cannot, however, send Discord and monitoring audio to the same device. There are a couple of ways to solve this issue; one involves third party software, and one does not.

The way without other software presumes that you have at least two hardware outputs on your PC that you could use; say, a line out jack for loudspeakers, but also a headphone jack. We'll be using your headphones as your monitoring output, and you just need any other device to use as your system default-- it doesn't really matter what it is because we're not actually going to listen to it. In fact, it's better if either that device is off, or it's a plug that has nothing connected to it.

So let's just say it's a line out for speakers. Set that as default, and turn the speakers off or disconnect them. In your setup, this is used for Discord output.

Now, in OBS' Mixer (Edit > Advanced Audio Properties) set both your system audio and your capture card audio to Output and Monitor.

In Settings > Audio, set the Audio Monitoring Device to be your headphones (in other words, the device that is NOT system default).

You should now be able to both hear and record/stream Discord output and capture card audio. (at least while OBS is running, anyway-- since you're hearing discord through OBS' monitor, in this scenario, you'll stop hearing it when OBS is not running, so you need to remember to change your default system device when not streaming or recording. (This is normal). This also has the effect of stopping you from hearing Discord if you switch to a scene in OBS that does not include Discord audio; if you have all your audio devices in Settings > Audio this is not a problem, since those devices are in all scenes, but if you have transitional scenes, or break scenes, this either means Discord audio is always on unless you mute it in the app or in OBS; and if you add your system audio as a separate source in your scenes, you will only hear monitored output when the active scene includes that source. These drawbacks can be alleviated by performing audio routing/monitoring functions in free 3rd party software instead of in OBS.

The way using 3rd party software is described in this guide:

https://obsproject.com/forum/resour...nagement-for-1-and-2-pc-streaming-setups.397/

In this setup, you gain at least one "virtual" audio device to serve as your default system audio, and Voicemeeter takes the place of the Windows default audio mixer. This allows for separation of chat and game audio even when recording a local game, not just a capture card, and Voicemeeter's own audio routing control can be used for monitoring instead of OBS if desired, and is generally superior to the audio routing controls in Windows. It may be necessary in this scenario to set your audio devices in the Windows sound control panel to non-exclusive mode, because if you have them being configured in both OBS and Voicemeeter, they may interfere if exclusive access is on.

The setup I use myself involves Voicemeeter Potato, which provides for three virtual audio devices.

https://www.vb-audio.com/Voicemeeter/potato.htm
DO you have discord? I dont understand actually. I'm new to all this. I'd love it if you'd show me.
 

SGTDRE

New Member
Sorry, I had time at that moment to point out you were given less than optimal advice and what the potential negative consequence would have been even if it had done what you wanted, but not enough time to go into more detail.

Audio doubling in OBS usually occurs because of two possible scenarios:

1) Duplicate sources. This is the simple explanation, but less common. It just means that you've added the same source of audio in more than once. Most often this would be because you added a source of audio in Settings > Audio more than once, or configured it in Settings > Audio and then also added it as an audio source directly in a scene. Sometimes users set both "Desktop Audio" and "Mic/Aux" to "default" not realizing that these both mean the Windows default audio device. However I do not think this is your case.

2) Incorrect monitoring setting. When OBS is set up to capture a local application, it is normal for it to capture the default Windows system audio device, and for monitoring to be off in this case. The user can already hear this source, whether through speakers or headphones, and so monitoring is unnecessary. The user may have selected, in Settings > Audio, for the Audio Monitoring Device to be the system default, but until monitoring is turned on for at least once source in Edit > Advanced Audio Properties, this setting has no effect at all and causes no problem, so the user does not notice that this is a mistake.

The mistake becomes noticeable when moving to capturing from an external device like a capture card; this source also generates audio, but the user may not already be set up to hear it. If it sends audio to loudspeakers or a TV in the same room with a microphone, this will double audio. The user could connect headphones to it, perhaps through a splitter, but now they need two sets of headphones-- one for the PC and one for the source connected to the capture device.

OBS' solution to this is Audio Monitoring. This allows audio to pass through from an audio source to a specific audio device so that the user running OBS can hear it. However, OBS assumes that the Audio Monitoring device is either *different* from the default audio device, or that the user knows that one should not be capturing from the default audio device if it is being used for monitoring; the result will be doubled audio, as audio from your capture card is sent by OBS to your system default device (where you are monitoring Discord output) and then it is captured a second time.

Zidakuh's suggestion, had it worked, would have prevented this from happening but in a way that is not really usual or expected and that could have caused other problems-- they suggested turning OFF the output of the capture card (removing its audio from your stream or recording) and turning it's monitor ON.

So now capture card audio isn't recorded directly, but it is sent to the monitor. But since the monitor is likely your default output, that means you can hear it. And desktop audio is being captured because that's where your discord chat is-- so you're not recording your captured audio directly, you're recording the monitor of that output, passed through OBS.

The problem with this is: 1) You now have all audio muxed down to a single track, meaning you can't adjust volume of those sources separately in post-production, if you are planning on doing that, and 2) depending on the load on your PC, you have introduced the possibility of a slight, but potentially noticeable, delay between your video capture footage and your captured audio.

You shouldn't do this and there's no good reason to do this; it's just that if your scenario had been exactly as Zidakuh had presumed, it would have stopped you from hearing an echo with the fewest number of changes in the UI.

What you ought to do is this:

You will need audio monitoring ON in order to hear your capture card, and it should also be recorded/streamed. So your Elgato source should be set to "monitor and output".

You cannot, however, send Discord and monitoring audio to the same device. There are a couple of ways to solve this issue; one involves third party software, and one does not.

The way without other software presumes that you have at least two hardware outputs on your PC that you could use; say, a line out jack for loudspeakers, but also a headphone jack. We'll be using your headphones as your monitoring output, and you just need any other device to use as your system default-- it doesn't really matter what it is because we're not actually going to listen to it. In fact, it's better if either that device is off, or it's a plug that has nothing connected to it.

So let's just say it's a line out for speakers. Set that as default, and turn the speakers off or disconnect them. In your setup, this is used for Discord output.

Now, in OBS' Mixer (Edit > Advanced Audio Properties) set both your system audio and your capture card audio to Output and Monitor.

In Settings > Audio, set the Audio Monitoring Device to be your headphones (in other words, the device that is NOT system default).

You should now be able to both hear and record/stream Discord output and capture card audio. (at least while OBS is running, anyway-- since you're hearing discord through OBS' monitor, in this scenario, you'll stop hearing it when OBS is not running, so you need to remember to change your default system device when not streaming or recording. (This is normal). This also has the effect of stopping you from hearing Discord if you switch to a scene in OBS that does not include Discord audio; if you have all your audio devices in Settings > Audio this is not a problem, since those devices are in all scenes, but if you have transitional scenes, or break scenes, this either means Discord audio is always on unless you mute it in the app or in OBS; and if you add your system audio as a separate source in your scenes, you will only hear monitored output when the active scene includes that source. These drawbacks can be alleviated by performing audio routing/monitoring functions in free 3rd party software instead of in OBS.

The way using 3rd party software is described in this guide:

https://obsproject.com/forum/resour...nagement-for-1-and-2-pc-streaming-setups.397/

In this setup, you gain at least one "virtual" audio device to serve as your default system audio, and Voicemeeter takes the place of the Windows default audio mixer. This allows for separation of chat and game audio even when recording a local game, not just a capture card, and Voicemeeter's own audio routing control can be used for monitoring instead of OBS if desired, and is generally superior to the audio routing controls in Windows. It may be necessary in this scenario to set your audio devices in the Windows sound control panel to non-exclusive mode, because if you have them being configured in both OBS and Voicemeeter, they may interfere if exclusive access is on.

The setup I use myself involves Voicemeeter Potato, which provides for three virtual audio devices.

https://www.vb-audio.com/Voicemeeter/potato.htm

I just want to give a thank you, this helped me correct the Audio echo, and I'm using the MiraBox HD USB to capture my XB game(s) to my PC.
 

STEPHANVS

Member
1) Duplicate sources. This is the simple explanation, but less common. It just means that you've added the same source of audio in more than once. Most often this would be because you added a source of audio in Settings > Audio more than once, or configured it in Settings > Audio and then also added it as an audio source directly in a scene. Sometimes users set both "Desktop Audio" and "Mic/Aux" to "default" not realizing that these both mean the Windows default audio device. However I do not think this is your case.

Had this issue today, ASIO capture was present in a nested scene twice, without showing twice in the mixer section. Audio signals were perfect in OBS, but distorted on the stream.
 

Mudkip

New Member
Audio doubling in OBS usually occurs because of two possible scenarios:
Hello there! I realize its been more than 2 years since you made this post so I'm sorry to bring it up again. I've been having similar problems. Your process helped me significantly. I got it to work where nothing else was coming through the desktop finally. It worked with a decent amount of testing. However, i then went to install Stream Elements to OBS. After I did, the process got messed up again, and despite going through your steps a second time, whenever I switch over my system audio device to my headphones for streaming, the audio goes back to doubling in the system audio again. It remains separate when the current system audio is the speakers (in my case just the monitor at the moment), but it also is coming out of both the monitor and my headphones now. Man this is confusing.
 
Top