Question / Help Display Capture Issue. Mouse cursor must be moving to get a "smooth-like" capture.


New Member
Title says it basically. I have blender open(window full screen mode) and I am also trying to play a video over, and capture the screen. I had done this about 2 years ago on the same hardware. Will post a link to both videos. The old (just fine) and the current problem.

The old: The lag in blender is from real-time rendering. The actual render plays in the middle window, just fine, all is right with my small world.

The current fun: the video (display) capture essentially stops if I am not using the mouse.

Log UPLOAD link

So, is there some setting I am missing somehow? This is video recording, but do I need to change a stream setting perhaps? No idea.
I guess it should in the log but I don't know if having my Wacom Cintiq on has anything to do with the issue? Maybe and AMD driver issue? imagine that haha. My guess is there is some stupid windows setting I need to change.


Active Member
09:14:26.362: [ffmpeg muxer: 'adv_file_output'] Writing file 'D:/Video/2020-05-22'...
09:15:01.537: [ffmpeg muxer: 'adv_file_output'] Output of file 'D:/Video/2020-05-22' stopped
09:15:01.537: Output 'adv_file_output': stopping
09:15:01.537: Output 'adv_file_output': Total frames output: 2028
09:15:01.537: Output 'adv_file_output': Total drawn frames: 2111
09:15:01.538: ==== Recording Stop ================================================
09:15:01.570: Video stopped, number of skipped frames due to encoding lag: 1525/2078 (73.4%)
All frames lost are due to encoding lag.

09:14:05.580: video settings reset:
09:14:05.580: base resolution: 3840x2160
09:14:05.580: output resolution: 3840x2160
09:14:05.580: downscale filter: Bicubic
09:14:05.580: fps: 60/1
09:14:05.580: format: RGBA
09:14:05.580: YUV mode: None
This forces CPU handling of image compositing. Switch this back to NV12 so that your GPU can handle image compositing.

09:14:26.343: [x264 encoder: 'recording_h264'] preset: veryfast
09:14:26.343: [x264 encoder: 'recording_h264'] settings:
09:14:26.343: rate_control: CBR
09:14:26.343: bitrate: 2500
09:14:26.343: buffer size: 2500
09:14:26.343: crf: 0
09:14:26.343: fps_num: 60
09:14:26.343: fps_den: 1
09:14:26.343: width: 1920
09:14:26.343: height: 1080
09:14:26.343: keyint: 250
Your encoder output doesn't match your scaled output resolution, so it appears that you are using the "rescale output" option in your encoder section -- this uses the CPU to rescale instead of your GPU. Turn "rescale output" off, and in the Video tab, set your Output (Scaled) resolution to 1920x1080.

You may also want to check that your OBS process priority is set to High in the advanced tab.


New Member
So, I decided to use the AMD clean up utility and reinstall. No more issue. The thing that bugs me about this is, I changed from the "gaming-driver" which gives the real-time viewport render in Blender a small boost in performance … to the enterprise set for workstations …Wonder in Warzone will not be as pretty … haha … maybe I can get a nice shiny RTX card for Christmas … so tired of AMD gpu bs … love the CPUs though.


New Member
The edit post option seems to vanish quickly. Anyhoo, sorry for the multiple. I didn't have any sort of issues anywhere else, with anything else I was running only OBS, just incase anyone else might stumble into the same issue with a similar setup.

Radeon Pro Settings Version - 2020.0407.1819.32973
View Release Notes -
Driver Packaging Version -
Provider - Advanced Micro Devices, Inc.
2D Driver Version -
Direct3D® Version -
OpenGL® Version - 26.20.11000.13587
AMD Audio Driver Version -
Vulkan™ Driver Version - 2.0.116
Vulkan™ API Version - 1.1.125