Question / Help Audio Monitoring doesn't work at all

Aisopos

New Member
I've just started trying out OBS and love everything so far except for one huge problem - audio monitoring doesn't work at all.

<Problem>
- When I add a capture card, I see the volume bar going up and down so I guess it'll output to stream/recording, but I cannot hear it even if I turn monitoring on from the OBS mixer.

<What I've Tried>
- Run OBS as admin
- Try all of the options in audio monitoring (monitoring off / monitor only / monitor and output)
- To see if this is problem limited to my capture card, try and monitor other audio sources such as my mic but still nothing

※ If I go into my capture card's properties and change the audio output method from [capture audio only] to [output to desktop audio] THEN I can hear the sound from my capture card but this is obviously not what I want - I wish to be able to separate the audios of my capture card and desktop audio into different tracks.

<My environment>
- Windows 10 64 bit
- OBS Studio 23.1.0 (64-bit)

※ I don't know if it may be worth pointing out that I'm using OBS.Live (to utilize the StreamElements features), but as far as I know this is just an extra plugin over OBS Studio AND I've also tried out the vanilla OBS to confirm that it doesn't work as well.

Any and all help is greatly appreciated, thank you in advance
 

Attachments

koala

Active Member
If you see activity in the meter, you have sound. If you activate monitoring for that source in the enhanced audio properties (Edits->Advanced audio properties), the source will be output to the monitoring audio device. The monitoring audio device can be set in Settings->Advanced->Audio->Audio Monitoring Device.

Usually, you want to change the Audio Monitoring Device from "default" to your headset. General rule for the audio monitoring device is that you cannot use any device that is also captured by OBS. You would create a feedback loop. For example, if you capture the desktop audio and also use desktop audio as monitoring device. In this case, OBS simply doesn't output the monitored source to that device to break the loop.
 

Aisopos

New Member
If you see activity in the meter, you have sound. If you activate monitoring for that source in the enhanced audio properties (Edits->Advanced audio properties), the source will be output to the monitoring audio device. The monitoring audio device can be set in Settings->Advanced->Audio->Audio Monitoring Device.

Usually, you want to change the Audio Monitoring Device from "default" to your headset. General rule for the audio monitoring device is that you cannot use any device that is also captured by OBS. You would create a feedback loop. For example, if you capture the desktop audio and also use desktop audio as monitoring device. In this case, OBS simply doesn't output the monitored source to that device to break the loop.
Thanks for the helping hand!

First of all, I had already set the monitoring device to my headset/earphones but it didn't work.

Second, I don't quite get what you mean when you say "use desktop audio as monitoring device." How can you use desktop audio as monitoring device? Do you mean the audio device I use to hear my desktop audio? If that's what you mean, are you saying that if I use a headset to hear my desktop audio and also set the monitoring audio device as that exact headset, obs won't let me monitor desired sounds? If that's actually true than I can't understand what horrible nonsense this is, and if that's not what you meant I would like to ask for your kind elaboration on what you actually meant.

I'm especially confused because I'm coming from Streamlabs OBS with which I could monitor audio sources just fine, but am now seeing that identical settings are not working with OBS. Surely their difference can't be that great and something else must be a problem - or at least that's my guess..
 

koala

Active Member
You can use your headset to hear your desktop audio fine, but as soon as you also capture desktop audio with OBS, OBS will not use this as monitoring device. You might not be aware of OBS activating the capture for your headset. Windows probably sets your headset as default audio device as soon as you plug it in. And in the default setup, OBS captures the default device in Settings->Audio. Configure your audio devices explicitly in that dialog, and not use "default". This way you know exactly what devices OBS will use for which purpose.
 

Aisopos

New Member
You can use your headset to hear your desktop audio fine, but as soon as you also capture desktop audio with OBS, OBS will not use this as monitoring device. You might not be aware of OBS activating the capture for your headset. Windows probably sets your headset as default audio device as soon as you plug it in. And in the default setup, OBS captures the default device in Settings->Audio. Configure your audio devices explicitly in that dialog, and not use "default". This way you know exactly what devices OBS will use for which purpose.
I still have no idea where you're going with this... so let me try and narrow down my settings and questions as much as I can so you can give me a very specific instruction.

1) I had and have both audio devices set specifically to my headset
: audio - desektop audio device - my headset
: advanced - audio monitoring device - my headset

2) There are 3 audio sources in my OBS mixer
: capture card - monitor and output
: desktop audio - no monitoring
: mic - no monitoring

Q) Are you saying that I shouldn't set the two audio devices in 1) as the same device? In which case I would need to have a second pair of headset or speakers?? If not, please tell me what I'm doing wrong and should be doing.
 

Narcogen

Active Member
Yes, you can't have the same device set in #1. If it worked, this would result in echoing-- Windows would make a sound, OBS would hear it and encode it for your stream, and then if monitoring was on, it would send it to the monitor, which is system default-- which causes OBS to pick it up again.

The usual method to avoid this is to either set the Windows default output device to something that isn't connected-- say, a line out jack with nothing plugged into it-- and then turn monitoring ON for that source, and set your headphones to be the monitoring device.

Another method is to use Voicemeeter Banana, which gives you a virtual output to replace the system default, and gives you other controls that Windows doesn't. This is what I do. (I actually use Voicemeeter Potato which has extra features but you get the idea.)

https://obsproject.com/forum/resour...nagement-for-1-and-2-pc-streaming-setups.397/
 

Aisopos

New Member
Thank you all for your kindness and help - I've fortunately got things to work partially.

1) I still have both the desktop audio device and audio monitoring device set as my headset
2) What I DID change and give up was a separate audio track for my capture card - I'm sending it out to my desktop instead of trying to get it on its own audio track and monitor the sound, so now everything's working kind of the way I want it to.

All in all, I think I'll stick with these settings for now until I can get some proper equipment to be able to do completely what I want - separate tracks for all audio sources while still being able to hear them all.

As for the voicemeeter recommendation, I've used it for about half a year in the past but decided not to make use of it due to several reasons that kept causing problems. But thank you for your recommendation and help!
 

koala

Active Member
Apropos separate tracks for all audio sources. In advanced audio properties, you are able to assign each audio source to each track individually. You can assign a source to multiple tracks. If you have 3 audio sources for example, record 4 audio tracks with OBS. Assign all 3 sources to track 1, so they get mixed by OBS and you can quickly hear everything with your media player. In addition, assign audio source 1 to track 2, audio source 2 to track 3, audio source 3 to track 4. So you have each source not only mixed but separate as well and you are free to postprocess whatever you like.

An example of how such a setup looks like:
1560340238200.png

To make this work, you need to activate the first 5 tracks in Settings->Output->Recording->audio track of course.
 
Top