Question / Help Audio isn't being recorded?

Canadian_Moose

New Member
When I re-watched a stream recording of mine, I realized that my audio wasn't being transferred. I was able to fix it to a point where only my microphone audio is being transmitted to the stream.
I have the correct playback devices set to default in the playback and recording devices. But for some reason when I use the same devices on OBS studio only my microphone is being transmitted to the stream and not my headphone audio.
 

AtomGrounder

New Member
Do you have a source on your list for AUDIO OUTPUT?

You also need AUDIO INPUT for either your desktop or whatever.

I had all INPUT but had forgot to OUTPUT the audio I was inputting.
 

MrGhostO1O

New Member
Make sure you have selected the correct output and input devices in OBS "Settings" => "Audio" (see audio.png below).
This is a common mistake that users make when regularly switching between headphones and speakers. You basically tell OBS which devices are to be recorded. If your sound goes through your headphones but you have selected speakers in the OBS settings then it will record nothing, as there is no sound being transmitted to the speakers.

Right click on the settings icon of any audio track in the "Mixer" box and click on "Advanced Audio Properties" (see RMB.png below).
Here you can find a little bit more advanced audio settings and tools that you can play with to optimize your recorded audio from the selected devices and/or added mediasources, which can be music files or videos.


Then for you "Mic" and "Desktop Audio" select "Monitor off" under the "Monitoring" tab.
In this drop down menu you have "Monitor off", "Monitor only (mute output)" and "Monitor and Output". "Monitor" means the sound that you hear through your headphone or speaker. "Output" means the sound that will be heard in the stream or video. So you basically tell OBS what the stream/video should record and what should be heard only by you or the stream/video.

Lastly, uncheck every "Track" box of both "Mic" and "Desktop Audio" except "Track" box "1" (see advancedAudio.png below)

The "Track" boxes determine on which audio track the sound, coming from the selected device, is to be recorded on. So if you select for both "Mic" and "Desktop Audio" box "1" then both of the audio will be merged into one track. If you select box "2" for "Mic" then what you hear from the desktop or game will be recorded on the first track and what you say through the microphone will be recorded on a second track. When streaming and recording, having selected the wrong file format as output and having multiple tracks can make sound "disappear". So always make sure all your audio is merged in one track.



If everything above did not help then please send a screenshot of all your settings and devices, a video/stream example and the log file related to the video/stream.
You can open a log file by clicking on "Help" at the top bar of the OBS window then "Log Files" and then "Show Log Files". It will open a explorer window showing all your log files. Find the one with the correct date and time and upload it here.
 

Attachments

  • advancedAudio.PNG
    advancedAudio.PNG
    12.2 KB · Views: 55,968
  • audio.PNG
    audio.PNG
    63.6 KB · Views: 57,146
  • RMB.png
    RMB.png
    346.6 KB · Views: 49,080
Make sure you have selected the correct output and input devices in OBS "Settings" => "Audio" (see audio.png below).
This is a common mistake that users make when regularly switching between headphones and speakers. You basically tell OBS which devices are to be recorded. If your sound goes through your headphones but you have selected speakers in the OBS settings then it will record nothing, as there is no sound being transmitted to the speakers.

Right click on the settings icon of any audio track in the "Mixer" box and click on "Advanced Audio Properties" (see RMB.png below).
Here you can find a little bit more advanced audio settings and tools that you can play with to optimize your recorded audio from the selected devices and/or added mediasources, which can be music files or videos.


Then for you "Mic" and "Desktop Audio" select "Monitor off" under the "Monitoring" tab.
In this drop down menu you have "Monitor off", "Monitor only (mute output)" and "Monitor and Output". "Monitor" means the sound that you hear through your headphone or speaker. "Output" means the sound that will be heard in the stream or video. So you basically tell OBS what the stream/video should record and what should be heard only by you or the stream/video.

Lastly, uncheck every "Track" box of both "Mic" and "Desktop Audio" except "Track" box "1" (see advancedAudio.png below)
The "Track" boxes determine on which audio track the sound, coming from the selected device, is to be recorded on. So if you select for both "Mic" and "Desktop Audio" box "1" then both of the audio will be merged into one track. If you select box "2" for "Mic" then what you hear from the desktop or game will be recorded on the first track and what you say through the microphone will be recorded on a second track. When streaming and recording, having selected the wrong file format as output and having multiple tracks can make sound "disappear". So always make sure all your audio is merged in one track.



If everything above did not help then please send a screenshot of all your settings and devices, a video/stream example and the log file related to the video/stream.
You can open a log file by clicking on "Help" at the top bar of the OBS window then "Log Files" and then "Show Log Files". It will open a explorer window showing all your log files. Find the one with the correct date and time and upload it here.
I know it's been a couple years, but could you help me?
log file

Image 2-28-20 at 11.06 PM.jpeg


video stream link
 

Jeeperz2

New Member
After about 4 hours of extensive research I figured my problem out. You have to enable both audios on default in the audio settings for audio 1 and 2. I had 2 disabled.
 

blaccowboy88g

New Member
When I re-watched a stream recording of mine, I realized that my audio wasn't being transferred. I was able to fix it to a point where only my microphone audio is being transmitted to the stream.
I have the correct playback devices set to default in the playback and recording devices. But for some reason when I use the same devices on OBS studio only my microphone is being transmitted to the stream and not my headphone audio.
 

SabyTheGod

New Member
Hey guys, just made an account to see if you guys were in the same predicament as me. I had installed Voicemetter banana to have my audio tracks separated, and after setting it up I lost audio in recordings, streams, and I could not monitor sound as well. I kept searching and found a fix for it. I went into the sound setting and disabled audio exclusivity for the voice meeter virtual cables, but I'm assuming you can just do this for the audio device you are using.

Link to the setting.
 

PeaceFire

New Member
When I re-watched a stream recording of mine, I realized that my audio wasn't being transferred. I was able to fix it to a point where only my microphone audio is being transmitted to the stream.
I have the correct playback devices set to default in the playback and recording devices. But for some reason when I use the same devices on OBS studio only my microphone is being transmitted to the stream and not my headphone audio.
So what I had to do was uninstall (uninstall user settings too) and start from scratch. I would save things like images and very complicated overlays before uninstalling.
 

rajasinh

New Member
My desktop audio was also not being recorded and I figured out it was because only OBS studio was muted in Windows volume mixer.

obs-desktop-audio-not-working.png
 

jcpluzpluz

New Member
I also went through several hours of research (and attempting all the solutions suggested in this forum and elsewhere), to no avail... but I finally figured out what my problem was. I'm posting here in case it helps anyone else. I'm using Soundflower to route audio from my DAW (Ableton Live) and have it play alongside my microphone input.

My audio meters were moving in OBS and I *thought* it wasn't recording my DAW audio to the output video file, but it was actually just recording it too quiet (compared to my microphone input). If you go into your Sound Preferences (on Mac OS), you can click on "Soundflower (2ch)" and adjust the left-right slider on the "Output volume". After adjusting, watch the sound meters in OBS so that your microphone and Soundflower levels are roughly the same.

Screenshots attached.
 

Attachments

  • Sound Menu.png
    Sound Menu.png
    242.5 KB · Views: 421
  • Sound Preferences.png
    Sound Preferences.png
    236 KB · Views: 429
  • OBS Mixer Meters.png
    OBS Mixer Meters.png
    44.5 KB · Views: 401

ChrisLive

New Member
After about 4 hours of extensive research I figured my problem out. You have to enable both audios on default in the audio settings for audio 1 and 2. I had 2 disabled.
This solved my problem, thank you!
File -> Settings -> Audio -> Track 1 and 2, set to Default.
Also in "Source Record" filter, checked, "Different Audio" Track 1 (or 2).
 
Last edited:

Leighann

New Member
I’ve recorded my gameplay like normal but this time around when I go into my videos and open up I can’t hear my audio. But from my old ones I still can hear them just fine. I was wondering if there is a way I can get the Audio from the recordings? Or is there no hope?
 
Top