ASIO 4 all v2 and RCPII - Multitrack option not showing up


New Member

I have been trying to find answers to this question everywhere, but it seems like there aren't any with the same problems as me.

I have the RCPII and use it with OBS Studio to record and livestream podcasts.

Yesterday everything was fine. I had the ASIO input capture setup with my different multitracks (Channels: 3, 4, 7 and 8 on the RCPII) and it worked perfectly. As I opened OBS Studio today - none of the channel outputs were being received by RCPII. I tried to fix it through the ASIO input capture settings, but the "OBS Channel 1" and "OBS Channel 2" were both empty. I then looked in the control panel and I noticed that my RCPII had had a name change on the WDM Device list.

Instead of "RødeCasterPro II Main multitrack" it is just called "RødeCaster Pro II Main, and I am not able to set it up with any of the output channels I would like.

I haven't changed anything on the RCPII it self, so I am very confused with regards to this sudden problem.
I hope someone will be able to help - I would be very grateful

Thank you in advance,
Best regards,