Question / Help AJA KONA LHi - Could it work with OBS?

#1
Long story short - I'm trying to get my AJA KONA LHi capture card working with the latest version of OBS-studio for switching/streaming.

The PC here runs Windows Server 2019, and has all the AJA drivers and DirectShow filters installed. Also not sure if this would be relevant, but on this same machine I've also installed Blackmagic's desktop video suite (for my Intensity Pro cards) and NewTek's NDI drivers/software.

For testing, I have connected a known-good, 1080p60 HDMI source with no HDCP (a Cisco TelePresence C60) to the AJA's HDMI in port. I'm able to get a signal just fine:

003.png


I was also able to grab the video feed just fine from AJA's own ControlRoom application. However, things started going awry once I fired up OBS and added a DirectShow capture source. No output could be grabbed through OBS, and it kinda drags ControlRoom along with it - I was unable to get any output from the card in any application until I do a full system reboot.

Now there are two things that could happen to OBS. One is that I just get a black input, and the other is that OBS crashes. Here's the crash log, btw.

Toggled around all the formats within AJA ControlPanel: ARGB-8, YUV-8, YUV-10, RGB-10, RGB-12, none worked. Also tried the same in OBS, to no avail. Not sure what FourCC does, but switching it to anything within OBS doesn't seem to work as it'll just bounce back to UYVY. That being said, OBS seems to at least know the source resolution, but each time I restart OBS the video source will also go back to SDI (although I have the default set to HDMI within AJA Multi-Channel Config tool):

1549511341285.png


Edit 1 - after a reboot, I was able to get the card to at least throw out something to OBS:

OBS-Crash-But-With-Pic.png


Now, this still seems to crash. Upon seeing the log, it seems that something is going on with the audio:

Code:
Unhandled exception: c0000094
Date/Time: 2019-02-06, 20:17:38
Fault address: 7FFC5747ABD9 (c:\program files\obs-studio\obs-plugins\64bit\win-dshow.dll)
libobs version: 22.0.2 (64-bit)
Windows version: 10.0 build 17763 (revision: 107; 64-bit)
CPU: AMD Ryzen 7 1800X Eight-Core Processor        


Thread 4C8 (Crashed)
Stack            EIP              Arg0             Arg1             Arg2             Arg3             Address
000000010502F890 00007FFC5747ABD9 0000014EF1EB0F58 00007FFC8E73A82D 0000014E9F7B61F0 00007FFC8E96D288 win-dshow.dll!DShowInput::OnAudioData+0x179
000000010502F8D0 00007FFC574880AD 0000000000000000 0000000000000000 0000000000000000 0000000000028B0A win-dshow.dll!DShow::HDevice::SendToCallback+0x9d
000000010502F930 00007FFC57487E8D 0000000000000048 0000014E00000001 0000000000000000 0000000000028B0A win-dshow.dll!DShow::HDevice::Receive+0x1dd
000000010502F9C0 00007FFC57481787 0000014E86D091C0 0000014E86CB92E0 0000000000000000 00007FFC8F0DE93D win-dshow.dll!DShow::CapturePin::Receive+0x37
000000010502F9F0 00007FFC4E69DC5A 0000014EF1EB0F58 0000014E86D0A500 0000014E86CB9498 0000014E86CB9470 ajacapture64.dll!0x7ffc4e69dc5a
000000010502FA30 00007FFC4E6B1C28 0000014E86D091C0 0000014E86CB9470 0000000000000000 0000000000000000 ajacapture64.dll!0x7ffc4e6b1c28
000000010502FAB0 00007FFC4E6B2649 0000014E86D0A510 0000000000000000 0000000000000000 0000000000000000 ajacapture64.dll!0x7ffc4e6b2649
000000010502FAE0 00007FFC4E7409D7 00007FFC4E7D2DC0 0000014E86D0A510 0000000000000000 0000000000000000 ajacapture64.dll!0x7ffc4e7409d7
000000010502FB10 00007FFC4E740A6B 0000000000000000 0000000000000000 0000000000000000 0000000000000000 ajacapture64.dll!0x7ffc4e740a6b
000000010502FB40 00007FFC8CB97E94 0000000000000000 0000000000000000 0000000000000000 0000000000000000 kernel32.dll!0x7ffc8cb97e94
000000010502FB70 00007FFC8F137AD1 0000000000000000 0000000000000000 0000000000000000 0000000000000000 ntdll.dll!0x7ffc8f137ad1
With that, I went into the settings menu again, this time checking "Use custom audio device" and pointing it to something else (in my case, "Line (NewTek NDI Audio)". Now OBS doesn't crash anymore. But while I'm able to get a live feed in the properties box, The feed still doesn't properly go into the scene (still getting a black screen there)...

Oh, and another problem: the "input source" within OBS seems to keep bouncing back to SDI. Every. Single. Time.

Any ideas why this is not working? Color space issues? Video format issues? Something else? I've tried searching around everywhere and while there are a few mentions of OBS + AJA Kona cards (some claimed that they work), I could not find any specific technical information on how to make this happen. So, any ideas? (Thanks!)
 
Last edited:
#2
Hi
I work for AJA Video Systems and I am very sorry that you are having issues with our Kona LHi product. I will try to pass this post up to the software engineering team and see if they can figure out whats going on (sounds to me like OBS is reading the wrong frame buffer). We are very proud of our compatibility with FOSS software and I will do my best to see that this issue gets addressed. At this point the issue could be a problem with obs and if that's the case then I am afraid that it would requitre someone that is active on the OBS project to make the code changes as we only develop the drivers.

I would recommend giving our customer support a call at this may help move your case along quicker.
https://www.aja.com/products/kona-lhi#support

~ your neighborhood nerd
 
Top