Resource icon

OBS Virtualcam 2.0.5

Fenrir

Forum Admin
Hi does this also route audio from OBS to a virtual audio source? how can I get OBS audio in zoom, for example?

thanks
Unfortunately, this is outside the scope of the current virtualcam offering.

Hi this sounds awesome a just what I need but really struggling to download the installer just now, (Had 3 back to back downloads failed?)

Anything I'm missing or is the server just being smashed just now?
Downloads are working fine here for me, could be something specific to your region. I would wait just a little bit and try again, the downloads are hosted by GitHub on AWS.

Solved!! at least for my issue
Alright, I had the same issue of the "virtual cam" not showing up in tools!
After many reinstalls(.exe and .zip) and restarts, I found the issue (for me)

I had OBS pinned to my taskbar so I just kept opening it like that.
The one in my taskbar though was the in appdata/roaming folder hierarchy for some reason
BUT the one it was installing to was C:\program files
Once I finally opened the OBS one from inside there it showed up...
SOOOOO stupid but glad I figured it out on time before my live stream performance
hope this helps somebody out there.


WHY TF is there a separate OBS in app data?
Not sure why there would be a separate install, sounds like a mistake when installing it at some point where you did not have permissions for program files, so it selected a user-writable directory instead. Hard to say for sure, but definitely not a normal thing.
 

nadia349

New Member
I install all file (obs 25.0.8 +webcam 2.0.5+ c++ )
But I still can't see obs-camera view in google meet
Please help me!!!!


LOG
=============
11:50:04.778: CoInitializeEx succeeded: 0x00000001
11:50:04.778: CPU Name: Intel(R) Core(TM) i5-1035G4 CPU @ 1.10GHz
11:50:04.778: CPU Speed: 1498MHz
11:50:04.778: Physical Cores: 4, Logical Cores: 8
11:50:04.778: Physical Memory: 7782MB Total, 2628MB Free
11:50:04.778: Windows Version: 10.0 Build 18363 (release: 1909; revision: 778; 64-bit)
11:50:04.778: Running as administrator: false
11:50:04.778: Aero is Enabled (Aero is always on for windows 8 and above)
11:50:04.778: Windows 10 Gaming Features:
11:50:04.778: Game DVR: On
11:50:04.780: Sec. Software Status:
11:50:04.781:
11:50:04.781:
11:50:04.782: Current Date/Time: 2020-05-10, 11:50:04
11:50:04.782: Browser Hardware Acceleration: true
11:50:04.782: Portable mode: false
11:50:05.122: OBS 25.0.8 (64-bit, windows)
11:50:05.122: ---------------------------------
11:50:05.123: ---------------------------------
11:50:05.123: audio settings reset:
11:50:05.123: samples per sec: 44100
11:50:05.123: speakers: 2
11:50:05.125: ---------------------------------
11:50:05.125: Initializing D3D11...
11:50:05.125: Available Video Adapters:
11:50:05.128: Adapter 0: Intel(R) Iris(R) Plus Graphics
11:50:05.128: Dedicated VRAM: 134217728
11:50:05.128: Shared VRAM: 4080287744
11:50:05.128: PCI ID: 8086:8a5a
11:50:05.128: Driver Version: 26.20.100.7641
11:50:05.128: output 0: pos={0, 0}, size={2736, 1824}, attached=true, refresh=59, name=
11:50:05.130: Loading up D3D11 on adapter Intel(R) Iris(R) Plus Graphics (0)
11:50:05.145: D3D11 loaded successfully, feature level used: b000
11:50:05.145: DXGI increase maximum frame latency success
11:50:05.585: ---------------------------------
11:50:05.586: video settings reset:
11:50:05.586: base resolution: 1920x1080
11:50:05.586: output resolution: 1280x720
11:50:05.586: downscale filter: Bicubic
11:50:05.586: fps: 30/1
11:50:05.586: format: NV12
11:50:05.586: YUV mode: 601/Partial
11:50:05.586: NV12 texture support enabled
11:50:05.586: Audio monitoring device:
11:50:05.586: name: 預設裝置
11:50:05.586: id: default
11:50:05.586: ---------------------------------
11:50:05.589: [CoreAudio encoder]: CoreAudio AAC encoder not installed on the system or couldn't be loaded
11:50:05.590: Failed to load 'en-US' text for module: 'decklink-ouput-ui.dll'
11:50:05.617: [AMF] Unable to load 'amfrt64.dll', error code 126.
11:50:05.619: [AMF] AMF Test failed due to one or more errors.
11:50:05.619: Failed to initialize module 'enc-amf.dll'
11:50:05.634: [obs-browser]: Version 2.8.6
11:50:05.649: starting virtual-output on VirtualCam'1'
11:50:05.660: Couldn't find VLC installation, VLC video source disabled
11:50:05.667: A DeckLink iterator could not be created. The DeckLink drivers may not be installed
11:50:05.667: No blackmagic support
11:50:05.672: ---------------------------------
11:50:05.672: Loaded Modules:
11:50:05.672: win-wasapi.dll
11:50:05.672: win-mf.dll
11:50:05.672: win-dshow.dll
11:50:05.672: win-decklink.dll
11:50:05.672: win-capture.dll
11:50:05.672: vlc-video.dll
11:50:05.672: text-freetype2.dll
11:50:05.672: rtmp-services.dll
11:50:05.672: obs-x264.dll
11:50:05.672: obs-vst.dll
11:50:05.672: obs-virtualoutput.dll
11:50:05.672: obs-transitions.dll
11:50:05.672: obs-text.dll
11:50:05.672: obs-qsv11.dll
11:50:05.672: obs-outputs.dll
11:50:05.672: obs-filters.dll
11:50:05.672: obs-ffmpeg.dll
11:50:05.672: obs-browser.dll
11:50:05.672: image-source.dll
11:50:05.672: frontend-tools.dll
11:50:05.672: enc-amf.dll
11:50:05.672: decklink-ouput-ui.dll
11:50:05.672: coreaudio-encoder.dll
11:50:05.672: ---------------------------------
11:50:05.672: ==== Startup complete ===============================================
11:50:05.676: All scene data cleared
11:50:05.676: ------------------------------------------------
11:50:05.713: WASAPI: Device 'Headphones (Realtek High Definition Audio(SST))' [48000 Hz] initialized
11:50:05.713: [Loaded global audio device]: '輸出音效 1'
11:50:05.730: WASAPI: Device 'Headset Microphone (Realtek High Definition Audio(SST))' [48000 Hz] initialized
11:50:05.730: [Loaded global audio device]: '麥克風/輸入音效 1'
11:50:05.750: [window-capture: 'chorme-共用簡報'] update settings:
11:50:05.750: executable: chrome.exe
11:50:05.750: [window-capture: 'iphone'] update settings:
11:50:05.750: executable: LetsView.exe
11:50:05.751: Switched to scene '場景 2 講者+簡報'
11:50:05.751: ------------------------------------------------
11:50:05.751: Loaded scenes:
11:50:05.751: - scene '場景 1 講者+老師+全班':
11:50:05.751: - source: '老師(前鏡頭)' (dshow_input)
11:50:05.751: - filter: '影像遮罩/混合' (mask_filter)
11:50:05.751: - source: 'iphone' (window_capture)
11:50:05.751: - source: '去背-講者(後鏡頭)' (dshow_input)
11:50:05.751: - filter: '色度鍵' (chroma_key_filter)
11:50:05.751: - scene '場景 2 講者+簡報':
11:50:05.751: - source: 'chorme-共用簡報' (window_capture)
11:50:05.751: - source: '去背-講者(後鏡頭)' (dshow_input)
11:50:05.751: - filter: '色度鍵' (chroma_key_filter)
11:50:05.751: - scene '場景 3老師+全班':
11:50:05.751: - source: 'iphone' (window_capture)
11:50:05.751: - source: '老師(前鏡頭)' (dshow_input)
11:50:05.751: - filter: '影像遮罩/混合' (mask_filter)
11:50:05.751: - scene '場景 4 iphone-全班':
11:50:05.751: - source: 'iphone' (window_capture)
11:50:05.751: - scene '場景 5簡報ppt':
11:50:05.751: - source: 'chorme-共用簡報' (window_capture)
11:50:05.751: ------------------------------------------------
11:50:05.765: adding 46 milliseconds of audio buffering, total audio buffering is now 46 milliseconds (source: 輸出音效 1)
11:50:05.765:
11:50:05.938: Switched to Preview/Program mode
11:50:05.938: ------------------------------------------------
11:50:06.955: ---------------------------------
11:50:06.955: [DShow Device: '老師(前鏡頭)'] settings updated:
11:50:06.955: video device: Surface Camera Front
11:50:06.955: video path: \\?\display#int3480#4&1bd78084&0&uid144512#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{bf89b5a5-61f7-4127-a279-e187013d7caf}
11:50:06.955: resolution: 640x360
11:50:06.955: flip: 0
11:50:06.955: fps: 15.00 (interval: 666667)
11:50:06.955: format: YUY2
11:50:07.094: DShow: Run failed (0xC00D3704): Hardware MFT failed to start streaming due to lack of hardware resources.
11:50:07.145: ---------------------------------
11:50:07.145: [DShow Device: '去背-講者(後鏡頭)'] settings updated:
11:50:07.145: video device: Surface Camera Rear
11:50:07.145: video path: \\?\display#int3480#4&1bd78084&0&uid144512#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{7c9bbcea-909c-47b3-8cf9-2aa8237e1d4b}
11:50:07.145: resolution: 640x360
11:50:07.145: flip: 0
11:50:07.145: fps: 15.00 (interval: 666667)
11:50:07.145: format: YUY2
11:56:11.121: adding 23 milliseconds of audio buffering, total audio buffering is now 69 milliseconds (source: 麥克風/輸入音效 1)
11:56:11.121:
 

feral

New Member
Unfortunately, this is outside the scope of the current virtualcam offering.



Downloads are working fine here for me, could be something specific to your region. I would wait just a little bit and try again, the downloads are hosted by GitHub on AWS.



Not sure why there would be a separate install, sounds like a mistake when installing it at some point where you did not have permissions for program files, so it selected a user-writable directory instead. Hard to say for sure, but definitely not a normal thing.
I had a level of success with Voicemeter Banana, it adds an audio output and virtual input.
 

k3flo

New Member
// EDIT:
Problem solved. It seems like the old virtual cam version was not uninstalled completely.
After deleting the "obs-studio" Folder and reinstalling OBS and virtual cam, everything works fine!

What can I do to improve video quality?
This is a screenshot of my OBS Virtual Cam. :-(

Selected resolution is 1920x1080.

virtualcam.jpg
 
Last edited:

nadia349

New Member
Does the camera show up in other applications? Some services block the use of virtual cameras.
early version it can work.
but when I update it to 25.8.0.5 version. it can't work!
Does the camera show up in other applications? Some services block the use of virtual cameras.
But early version works, until I updated 25.0.8 version.it just can't work!
Does the camera show up in other applications? Some services block the use of virtual cameras.
Yes , it (OBS 25.0.8 version) works on streamyard
OBS early version works,but when I updated obs software 25.0.8 version,it just can't work!
 

Timboxyz

New Member
Hesitating to upgrade from the old version for a couple of reasons. Firstly it still seems to be working fine for me after OBS updated to the latest version. Secondly, there seems to be a significant difference between this new version and the old one from what I read. The old version sent the main output to the Virtual camera, but this version appears to send the Preview output which would not suit my use case.

So is there any option to select between the main and preview output to feed to the virtual camera?

Also am I correct in thinking this version will uninstall the previous one?
 

Fenrir

Forum Admin
Hesitating to upgrade from the old version for a couple of reasons. Firstly it still seems to be working fine for me after OBS updated to the latest version. Secondly, there seems to be a significant difference between this new version and the old one from what I read. The old version sent the main output to the Virtual camera, but this version appears to send the Preview output which would not suit my use case.

So is there any option to select between the main and preview output to feed to the virtual camera?

Also am I correct in thinking this version will uninstall the previous one?
The only changes in this version is that it has been compiled against the latest OBS Studio version, and an updated installer is provided. There are no other changes. "Preview" is just what we call the Program view when studio mode is not enabled, and what most of our users are familiar with in terms of terminology. It's the program view that is sent by default from the Tools menu, but you can add the filter to any scene/source you want. This will not uninstall the previous version, but it will overwrite the files.
 

Fenrir

Forum Admin
early version it can work.
but when I update it to 25.8.0.5 version. it can't work!


But early version works, until I updated 25.0.8 version.it just can't work!

Yes , it (OBS 25.0.8 version) works on streamyard
OBS early version works,but when I updated obs software 25.0.8 version,it just can't work!
Have you tried uninstalling and reinstalling? I have just verified that virtualcam 2.0.5 with OBS 25.0.8 works just fine with Google Meet.
 

Deiyan

New Member
I use Windows 10 64bit.
I have downloaded the latest version of Virtual Cam 2.0.5 and Obs 64bit 25.0.8
virtual cam tools already exist and run too.

but when starting the zoom meeting video does not appear the picture from the obs camera.
how can you make an obs camera appear in zoom?
thanks.
 

Attachments

Fenrir

Forum Admin
Yes. I have unistalled and installed a couple of times. ><....
Please provide a log from OBS. Help -> Log Files -> Upload Current Log and paste the link here.

I use Windows 10 64bit.
I have downloaded the latest version of Virtual Cam 2.0.5 and Obs 64bit 25.0.8
virtual cam tools already exist and run too.

but when starting the zoom meeting video does not appear the picture from the obs camera.
how can you make an obs camera appear in zoom?
thanks.
The latest version of Zoom, as far as I am aware, is blocking virtual camera devices.
 

Deiyan

New Member
Please provide a log from OBS. Help -> Log Files -> Upload Current Log and paste the link here.



The latest version of Zoom, as far as I am aware, is blocking virtual camera devices.
Please provide a log from OBS. Help -> Log Files -> Upload Current Log and paste the link here.



The latest version of Zoom, as far as I am aware, is blocking virtual camera devices.
then how do you not block virtual camera devices? so that I can use obs to zoom to show pictures and videos.

I have used the latest zoom, for example.
if I zoom back in the old version, can the virtual camera be used?

Thank you very much
 

nimoab

New Member
I am trying to run this on my work machine that I do not have admin privs. to as well to make the virtual cam work in Teams.
I installed OBS and the virtual cam on a bootcamp mac and copied the program folder contents onto a USB stick. (not the best way, i know)
I can get OBS to open with the virtualcam option on my work machine but the virtual cam is not detected on Skype or Teams. I have access to 3 physical webcams but the virtual one fails to show in camera select dropdowns. I have also tried and older version of OBS and virtual cam but still cant get the OBS-virtualcam in the camera select dropdown.
I'm guessing you need to run the installer as admin to register the direct show .dll's maybe.
 

Attachments

Top