OBS Studio 27.2 Beta

dodgepong

Administrator
Forum Admin
Disclaimer: This is a test build, not a full release. This build may contain bugs or broken functionality. For production usage, we still recommend using the latest stable build of OBS. If you are willing to test this build, please let us know if you run into any issues.

We have beta build for OBS Studio 27.2 available for testing! This will be a big release with lots of new features, including:
  • Support for AJA devices (both input and output)
  • Support for source blending modes (similar to Photoshop blending modes)
  • Experimental support for AOM AV1 and SVT-AV1 encoders (work best with strong CPUs)
  • Hotkey duplicate detection and filter search
  • Official Flatpak support for Linux
  • Updated CEF to Chrome 95 for browser sources/panels
  • RIST output support
  • And much, much more!
Find the the full patch notes and download links for OBS Studio 27.2 Beta 3 here:
Flatpak Beta Installation:
Bash:
$ flatpak remote-add --if-not-exists flathub-beta https://flathub.org/beta-repo/flathub-beta.flatpakrepo
$ flatpak install flathub-beta com.obsproject.Studio
Ubuntu PPA Beta Installation:
Bash:
Install
$ sudo add-apt-repository ppa:obsproject/obs-studio-unstable
$ sudo apt install obs-studio
Uninstall
$ sudo add-apt-repository --remove ppa:obsproject/obs-studio-unstable
$ sudo apt remove obs-studio

Please give the release a try and let us know here or in the #beta-testing channel on Discord if you have any issues. Thanks for your help!
 
Last edited:

dodgepong

Administrator
Forum Admin
Known issues with beta 1:
  • Flatpak is currently being published to the wrong branch, will be fixed in next release
  • Crash when transitioning to a new scene using a transition override
  • Vertical audio meters are not properly grayed out
 

RichieTee

Member
1640926721117.png


Getting this error when I run OBS 27.2, I've had the file for a while (OBS 25) now and my OBS installation is on a different drive, but after updating to the latest beta version, I get this popup dialog. Tried lots of things even creating a folder for it, still no solution.
 

dodgepong

Administrator
Forum Admin
Seems like that comes from a third party plugin, perhaps an ASIO plugin. I would contact the developer of that plugin for assistance.
 

qhobbes

Active Member
Appears to use a bit less memory (~20MB in my setup). Not sure if it's the CEF improvements and/or QSV fixes. BlackMagic UltraStudio Mini Recorder still works. Lookin' good.
 

morinohito

New Member
I tried using Beta2 on M1 iMac OS Monterey 12.1.
When I streamed it with niconico, the delivery stopped in a few minutes.
 

SHentschke

New Member
There was once a rumor that version 27.2 should get BETA support for the Apple silicon chips.
Unfortunately, in the release note of V 27.2 BETA 2, I don't find anything about M1 support.
Does the V 27.2 Apple Silicon get support without Rosetta?
 

scaramanga

New Member
I tried out the new Flatpak version and came across the following issue: After docking any browser window (I tried Twitch Chat and a custom Browser Dock) and then clicking on it, OBS and all other open windows basically froze. I was able to kill OBS from terminal though.

Apart from that the support of Blackmagic capture devices breaks using Flatpak. From what I read that issue probably has to be solved by their support though. I tried following these instructions (adapting the JSON to the latest drivers and the beta branch), wasn't successful though.
 

tmyrdal

New Member
To bad that we need to log in to all accounts on every singel time we start the OBS studio beta.
It will be cool ot have remembered the logins and stays loged in on the streamings acouunts and all that, as the orginal obs studio does.

On every singel time I start the beta I need to log back in to everything lol. Isent it any way this can be remembered as the orginal version ?
 
Top