How do I rollback to the previous version of OBS (before 28.0.1)?

Andy Hexagon

New Member
Update 28.0.1 of OBS Studio is a hot mess; Stream Deck doesn't work anymore and the tuna plugin won't display artist names from Spotify. How do I rollback to the previous version of OBS Studio?
 

Gradus

Member
Most likely they got some pressure from well known vendor to release v28 since it support new CPU’s etc. I have also rolled back to v27 due to compatibility issues e.g. unsupported plugins.
 

koala

Active Member
I don't understand your complaints. The update notice clearly said in the first sentence that many plugins are incompatible, and even without knowing which plugins specifically this should ring a bell and make everyone using plugins not directly update but investigate before actually update. Keep this in mind for future software updates for software that comes with user supplied plugins.
 

CS Murphy

New Member
I don't understand your complaints. The update notice clearly said in the first sentence that many plugins are incompatible, and even without knowing which plugins specifically this should ring a bell and make everyone using plugins not directly update but investigate before actually update. Keep this in mind for future software updates for software that comes with user supplied plugins

Well, my complaint comes from the fact that rolling back has permanently botched my setup. I can no longer get audio from my DAW into OBS. I wrote down specific instructions on my setup which no longer work. It'd be one thing to rollback and be done with it.

But after an almost month of scouring the internet I still see no way of remedying my setup that was near perfect and at least working.
 

Clapper

New Member
Well, my complaint comes from the fact that rolling back has permanently botched my setup. I can no longer get audio from my DAW into OBS. I wrote down specific instructions on my setup which no longer work. It'd be one thing to rollback and be done with it.

But after an almost month of scouring the internet I still see no way of remedying my setup that was near perfect and at least working.
One very good reason to backup the HDD or SSD just before installing a new version of any software.
I do a backup after I install all the software I know that works fine, even before going into internet. And then backup again just before installing a new version to of any software. Acronis does a very good job.
 

Randle

New Member
Well, my complaint comes from the fact that rolling back has permanently botched my setup. I can no longer get audio from my DAW into OBS. I wrote down specific instructions on my setup which no longer work. It'd be one thing to rollback and be done with it.

But after an almost month of scouring the internet I still see no way of remedying my setup that was near perfect and at least working.
I understand the complaints. The 28.0.3 update had no mention of incompatibility of plugins. I had skipped previous updates.
This warning needs to be in capital letter at the top until all plugins are compatible - preferably with a link to this page!
Fortunately, I was able to just download 27.2.4 Windows x64 installer and install over the top of the version 28.0.3. I'm so glad that worked as I nearly thought I was going to need to spend a day I don't have fixing this issue before our next livestream!
I really appreciate all the volunteers working to update existing plugins for compatibility and look forward to trying out version 28 soon!
 

Clapper

New Member
I understand the complaints. The 28.0.3 update had no mention of incompatibility of plugins. I had skipped previous updates.
This warning needs to be in capital letter at the top until all plugins are compatible - preferably with a link to this page!
Fortunately, I was able to just download 27.2.4 Windows x64 installer and install over the top of the version 28.0.3. I'm so glad that worked as I nearly thought I was going to need to spend a day I don't have fixing this issue before our next livestream!
I really appreciate all the volunteers working to update existing plugins for compatibility and look forward to trying out version 28 soon!
I use the portable version. So yesterday I tried version 28.0.3 and had no apparent problems. In my case it didn't do any difference by using this latest version, so I just deleted version 28.0.3 and went back 27.2.3.
 
Top